Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Sun Jun 16, 2019 12:00 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: Poller invalid response warning and no graphs
PostPosted: Fri Jan 05, 2018 4:22 pm 
Offline
Cacti User

Joined: Thu May 04, 2017 8:49 am
Posts: 59
I get this warning for some new graphs I created:
2018/01/05 16:20:07 - POLLER: Poller[1] WARNING: Invalid Response(s), Errors[4] Device[3pfrontutrt1] Graphs[3pfrontutrt1 - Traffic - POS0/1/0--SONET/SDH Medium/Section/Line/5, 3pfrontutrt1 - Traffic - POS0/1/0--SONET/SDH Medium/Section/Line/5] Graphs[3pfrontutrt1 - Traffic - POS0/1/1--SONET/SDH Medium/Section/Line/7, 3pfrontutrt1 - Traffic - POS0/1/1--SONET/SDH Medium/Section/Line/7] Graphs[3pfrontutrt1 - Traffic - POS0/1/2--SONET/SDH Medium/Section/Line/9, 3pfrontutrt1 - Traffic - POS0/1/2--SONET/SDH Medium/Section/Line/9] Graphs[3pfrontutrt1 - Traffic - POS0/1/3--SONET/SDH Medium/Section/Line/11, 3pfrontutrt1 - Traffic - POS0/1/3--SONET/SDH Medium/Section/Line/11] DS[63, 65, 67, 69]

Several other graphs are showing results fine. I am able to snmpwalk to this device and retrieve information. What does "Invalid Response" mean?


Top
 Profile  
 
 Post subject: Re: Poller invalid response warning and no graphs
PostPosted: Fri Jan 05, 2018 6:55 pm 
Offline
Cacti Guru User

Joined: Sun Aug 27, 2017 12:05 am
Posts: 2499
Invalid response is usually where the value is outside the defined minimum/maximum or not a numeric but not also 'U' for undefined. For the device in question, you can enter the id into the device debug section of the configuration settings. This will provide extra debug information about the device. Another option is to use the data source debug when editing the device by clicking the verbose query of each associated query.

_________________
Official Cacti Developer

Cacti Resources:
Cacti Website (including releases)
Cacti Issues
Cacti Development Releases
Cacti Development Documentation

My resources:
How to submit Pull Requests
Development Wiki and How To's
Updated NetSNMP Memory template for Cacti 1.x
Cisco SFP template for Cacti 0.8.8


Top
 Profile  
 
 Post subject: Re: Poller invalid response warning and no graphs
PostPosted: Wed Mar 13, 2019 2:52 am 
Offline

Joined: Mon Mar 11, 2019 12:55 am
Posts: 7
netniV wrote:
Invalid response is usually where the value is outside the defined minimum/maximum or not a numeric but not also 'U' for undefined. For the device in question, you can enter the id into the device debug section of the configuration settings. This will provide extra debug information about the device. Another option is to use the data source debug when editing the device by clicking the verbose query of each associated query.


Hi Dear
I have this problem too
My Device for set graphing is Windows Server 2016 , All Graph like "CPU, RAM , ..." is ok but for Interface Graph I get this warnnig msg >> "POLLER: Poller[Main Poller] WARNING: Invalid Response(s)"
Maximum value is 100000000000
I Enable device debug :
"POLLER: Poller[Main Poller] Device[Local Windows Machine] DS[Local Windows Machine - Traffic] Graphs[Local Windows Machine - Traffic - Ethernet0-WFP 802.3 MAC Layer LightWeigh] SNMP: v2: localhost, dsname: traffic_out, oid: .1.3.6.1.2.1.31.1.1.1.10.18, output: U"


Attachments:
1 (3).png
1 (3).png [ 379 KiB | Viewed 676 times ]
1 (2).png
1 (2).png [ 221.96 KiB | Viewed 676 times ]
1 (1).png
1 (1).png [ 210.56 KiB | Viewed 676 times ]
Top
 Profile  
 
 Post subject: Re: Poller invalid response warning and no graphs
PostPosted: Wed Mar 13, 2019 4:22 am 
Offline
Cacti Guru User

Joined: Sun Aug 27, 2017 12:05 am
Posts: 2499
You need to ensure you have set four things:

1. The security tab's community and either Accept from any host, or specify your cacti host
2. Ensure that everything is ticked on the Service section of the Agent tab plus set your Contact/Location details.
3. Ensure that the trap tab has been visited so that it creates the registry entry (a bug I found were you'd get a repeated eventlog entry until you did)
4. Ensure that the windows firewall and/or any other firewall in between cacti and the host allows SNMP to flow

_________________
Official Cacti Developer

Cacti Resources:
Cacti Website (including releases)
Cacti Issues
Cacti Development Releases
Cacti Development Documentation

My resources:
How to submit Pull Requests
Development Wiki and How To's
Updated NetSNMP Memory template for Cacti 1.x
Cisco SFP template for Cacti 0.8.8


Top
 Profile  
 
 Post subject: Re: Poller invalid response warning and no graphs
PostPosted: Wed Mar 13, 2019 5:02 am 
Offline

Joined: Mon Mar 11, 2019 12:55 am
Posts: 7
netniV wrote:
You need to ensure you have set four things:

1. The security tab's community and either Accept from any host, or specify your cacti host
2. Ensure that everything is ticked on the Service section of the Agent tab plus set your Contact/Location details.
3. Ensure that the trap tab has been visited so that it creates the registry entry (a bug I found were you'd get a repeated eventlog entry until you did)
4. Ensure that the windows firewall and/or any other firewall in between cacti and the host allows SNMP to flow


tanks for your reply
All thinks is ok at cactiez 0.7 , Now I am install Cacti 1.2.2 and get this WARNING msg


Top
 Profile  
 
 Post subject: Re: Poller invalid response warning and no graphs
PostPosted: Sat Mar 16, 2019 12:25 am 
Offline

Joined: Mon Mar 11, 2019 12:55 am
Posts: 7
Can anybody help me?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group