Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Tue Apr 23, 2019 11:54 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 8 posts ] 
Author Message
 Post subject: ERROR: Problems parsing Multi SNMP OID!
PostPosted: Mon Jan 21, 2019 9:21 am 
Offline

Joined: Sun Sep 27, 2015 11:46 pm
Posts: 14
Hi,


I have upgrade to cacti 1.2.1 in some devices is not showing any graph.
The only clue that i have is :

ERROR: Problems parsing Multi SNMP OID! bla bla bla


Any idea to solve this ?
Thank you in advanced.


Regards,
Franky


Top
 Profile  
 
 Post subject: Re: ERROR: Problems parsing Multi SNMP OID!
PostPosted: Tue Jan 22, 2019 10:53 am 
Offline

Joined: Thu Apr 12, 2012 12:05 pm
Posts: 2
Same problem I try to upgrade from cacti 1.1.38 to 1.2.0 or 1.2.1 and when I try to look the graphs don't show any.


Top
 Profile  
 
 Post subject: Re: ERROR: Problems parsing Multi SNMP OID!
PostPosted: Tue Jan 22, 2019 11:25 am 
Offline

Joined: Thu Apr 12, 2012 12:05 pm
Posts: 2
Hi I found the solution the problem was on the file in cacti/lib/html_tree.php

The right code is

https://github.com/Cacti/cacti/blob/4fcf03d2801e19be8e8ff7d50cf8f0407dc34bb8/lib/html_tree.php

8)


Top
 Profile  
 
 Post subject: Re: ERROR: Problems parsing Multi SNMP OID!
PostPosted: Tue Jan 22, 2019 12:55 pm 
Offline
Cacti Guru User

Joined: Sun Aug 27, 2017 12:05 am
Posts: 2401
I doubt that is the right code as that is old and in the middle of the beta's. I would not advise using that.

_________________
Official Cacti Developer

Cacti Resources:
Cacti Website (including releases)
Cacti Issues
Cacti Development Releases
Cacti Development Documentation

My resources:
How to submit Pull Requests
Development Wiki and How To's
Updated NetSNMP Memory template for Cacti 1.x
Cisco SFP template for Cacti 0.8.8


Top
 Profile  
 
 Post subject: Re: ERROR: Problems parsing Multi SNMP OID!
PostPosted: Wed Jan 23, 2019 9:23 am 
Offline

Joined: Sun Sep 27, 2015 11:46 pm
Posts: 14
So what should i do ?
Just a few devices that not shown the graphs


Top
 Profile  
 
 Post subject: Re: ERROR: Problems parsing Multi SNMP OID!
PostPosted: Thu Feb 07, 2019 8:06 am 
Offline

Joined: Thu Feb 07, 2019 8:05 am
Posts: 2
The same problem after updating to 1.2.1. How to solve this have no idea, anyone could help?


Top
 Profile  
 
 Post subject: Re: ERROR: Problems parsing Multi SNMP OID!
PostPosted: Thu Feb 07, 2019 6:08 pm 
Offline
Cacti Pro User
User avatar

Joined: Mon Jan 05, 2015 10:10 am
Posts: 753
Please update lib/data_query.php and lib/functions.php from the develop branch in GitHub and then re-index your devices. There was a bug in 1.2.1 that will be addressed shortly in 1.2.2.

_________________
Before history, there was a paradise, now dust.


Top
 Profile  
 
 Post subject: Re: ERROR: Problems parsing Multi SNMP OID!
PostPosted: Fri Feb 08, 2019 3:02 am 
Offline

Joined: Thu Feb 07, 2019 8:05 am
Posts: 2
I found the solution. Look into your log, find the name of the device with this error and check out data sources of it graphs. Look into indextype and indexvalue fields, in my case in indexvalue was ifalias and in value was full switch name, the same was in all device graphs, which cause an errors of multiple similar oids.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: Google Adsense [Bot], pradeeps and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group