[SOLVED]Cannot Install Cacti-1.2.1 new release

Post support questions that directly relate to Linux/Unix operating systems.

Moderators: Moderators, Developers

Author
Message
eholz1
Cacti User
Posts: 129
Joined: Mon Oct 01, 2018 10:09 am

[SOLVED]Cannot Install Cacti-1.2.1 new release

#1 Post by eholz1 » Wed Jan 23, 2019 11:19 am

Hello Members,

I just downloaded the new version of cacti. cacti-1.2.1 and its matching version of spine.
I expanded the cacti-1.2.1 in /var/www/html/cacti directory, set the owner to apache:apache.
Spine compiled no problems.

I created a new database and ran the cacti.sql query - no problems.

I then opened a web browser and was immediately dissapointed.
None of the browsers I tried would run the install.

I tried IE 8, IE 10, Edge, and Firefox.
All versions of IE displayed the message "JaveScript must be activated to continue with install"
Well, JavaScript is enabled in each of the IE versions.

Now to Firefox - I got a little farther, then everything stops, and I get this
dialog window:
Cacti-1.2.1-firefox_error.JPG
Firefox error
Cacti-1.2.1-firefox_error.JPG (21.14 KiB) Viewed 1622 times
So anyone seen this? Or are there some permissons I am missing?

Thanks,

Eholz1
"Cacti a Thorny Proposition"
Last edited by eholz1 on Fri Feb 08, 2019 11:56 am, edited 1 time in total.

netniV
Cacti Guru User
Posts: 2673
Joined: Sun Aug 27, 2017 12:05 am

Re: Cannot Install Cacti-1.2.1 new release

#2 Post by netniV » Wed Jan 23, 2019 2:17 pm

Check your apache error log files and cacti log file. But also check if you have SELinux enabled, if so you need to adjust the SELinux privileges.

eholz1
Cacti User
Posts: 129
Joined: Mon Oct 01, 2018 10:09 am

Re: Cannot Install Cacti-1.2.1 new release

#3 Post by eholz1 » Wed Jan 23, 2019 6:46 pm

Hello and Thanks

I do not have selinux enabled. There is nothing in the cacti.log other than a line saying
the admin was authenticated.

I have checked the apache error log file and here is the message:
Notice: Undefined index: name in /opt/rh/httpd24/root/var/www/html/cacti/lib/installer.php
on line 959, referer: http://xx.xx.xx.xx/cacti/install/install.php

That error is repeated for every time I try to run the install process. There are no
other errors in the file.

The access log has several "gets" with this in the message line: HTTP/1.1" 200

That is what I have. I am running php56, and apache 24

Any ideas?

Eholz1


eholz1
Cacti User
Posts: 129
Joined: Mon Oct 01, 2018 10:09 am

Re: Cannot Install Cacti-1.2.1 new release

#5 Post by eholz1 » Fri Jan 25, 2019 11:34 am

OOPs, brainfade,
I thought I included the error log info for apache!!
Here it is:
[Tue Jan 22 16:20:03.585227 2019] [:error] [pid 5912] [client xx.xx.xx.xx:57089] PHP Notice: Undefined index: name in /opt/rh/httpd24/root/var/www/html/cacti/lib/installer.php on line 959, referer: http://<cacti-host>/cacti/install/install.php

This is the only error related to cacti, get it every time I run the install.

eholz1

netniV
Cacti Guru User
Posts: 2673
Joined: Sun Aug 27, 2017 12:05 am

Re: Cannot Install Cacti-1.2.1 new release

#6 Post by netniV » Fri Jan 25, 2019 5:10 pm

This suggests that your install isn't successfully calling the install/cli_check.php.

Code: Select all

sudo -u www-data php -q /path/to/cacti/install/cli_check.php extensions
Replace www-data with the website user on your box.

eholz1
Cacti User
Posts: 129
Joined: Mon Oct 01, 2018 10:09 am

Re: Cannot Install Cacti-1.2.1 new release

#7 Post by eholz1 » Fri Jan 25, 2019 6:15 pm

Here is the output of the command:
{"simplexml":{"cli":true,"web":false},
"session":{"cli":true,"web":false},
"pdo_mysql":{"cli":true,"web":false},
"PDO":{"cli":true,"web":false},
"sockets":{"cli":true,"web":false},
"spl":{"cli":true,"web":false},
"posix":{"cli":true,"web":false},
"zlib":{"cli":true,"web":false},
"xml":{"cli":true,"web":false},
"standard":{"cli":true,"web":false},
"pcre":{"cli":true,"web":false},
"openssl":{"cli":true,"web":false},
"gd":{"cli":true,"web":false},
"gettext":{"cli":true,"web":false},
"filter":{"cli":true,"web":false},
"date":{"cli":true,"web":false},
"gmp":{"cli":true,"web":false},
"hash":{"cli":true,"web":false},
"mbstring":{"cli":true,"web":false},
"ldap":{"cli":true,"web":false},
"json":{"cli":true,"web":false},
"ctype":{"cli":true,"web":false}}

This is the same configuration I had when I installed ver. 1.2.0, and cacti-develop - those versions completed the install process, but i had other problems with them. Am I missing any modules:

Thanks,
eholz1

paulbeard206
Cacti User
Posts: 149
Joined: Sat Jul 30, 2005 2:15 pm

Re: Cannot Install Cacti-1.2.1 new release

#8 Post by paulbeard206 » Sat Jan 26, 2019 9:09 pm

netniV wrote:This suggests that your install isn't successfully calling the install/cli_check.php.

Code: Select all

sudo -u www-data php -q /path/to/cacti/install/cli_check.php extensions
Replace www-data with the website user on your box.
sudo -u www php -q ./cli_check.php
PHP Notice: Undefined offset: 1 in /usr/local/share/cacti/install/cli_check.php on line 36

paulbeard206
Cacti User
Posts: 149
Joined: Sat Jul 30, 2005 2:15 pm

Re: Cannot Install Cacti-1.2.1 new release

#9 Post by paulbeard206 » Sun Jan 27, 2019 10:13 am

Deinstalled/reinstalled cacti, the install/upgrade process is hung up somewhere. The /install directory is the default and nothing happens.

SElinux is not the problem. AppArmour is not the problem.

Monitoring this thread to see when a solution becomes available.

netniV
Cacti Guru User
Posts: 2673
Joined: Sun Aug 27, 2017 12:05 am

Re: Cannot Install Cacti-1.2.1 new release

#10 Post by netniV » Mon Jan 28, 2019 10:22 am

Code: Select all

PHP Notice: Undefined offset: 1 in /usr/local/share/cacti/install/cli_check.php on line 36
This is a bug that is caused by having no command line arguments. This has been rectified in the latest version of cli_check.php but should not have been an issue if the PHP command was run as specified above (since what I provided has arguments).

However, we have also been made aware that there may be a memory issue using JSON if the memory of the CLI's PHP.INI is too low.

netniV
Cacti Guru User
Posts: 2673
Joined: Sun Aug 27, 2017 12:05 am

Re: Cannot Install Cacti-1.2.1 new release

#11 Post by netniV » Mon Jan 28, 2019 10:22 am

Code: Select all

PHP Notice: Undefined offset: 1 in /usr/local/share/cacti/install/cli_check.php on line 36
This is a bug that is caused by having no command line arguments. This has been rectified in the latest version of cli_check.php but should not have been an issue if the PHP command was run as specified above (since what I provided has arguments).

However, we have also been made aware that there may be a memory issue using JSON if the memory of the CLI's PHP.INI is too low.

eholz1
Cacti User
Posts: 129
Joined: Mon Oct 01, 2018 10:09 am

Re: Cannot Install Cacti-1.2.1 new release

#12 Post by eholz1 » Mon Jan 28, 2019 12:04 pm

ok - BEEN following this
and if I run: sudo -u apache /opt/rh/rh-php56/root/usr/bin/php -q

I get: PHP Notice: Undefined offset: 1 in /opt/rh/httpd24/root/var/www/html/cacti/install/cli_check.php on line 36

My php.ini memory was: 2048, changed to 4096

and: It always fails the intall with a JavaScript message - saying it needs to be enabled. But with IE 10, 11

With firefox - get nowhere either. and see the same dialog as above.

I will un-install and re-install cacti - and do nothing with the perms and see what happens

Just re-installed - no dice still errors out with the same info - javascript must be enabled, and the firefox error dialog.

Thanks,
Eholz1

paulbeard206
Cacti User
Posts: 149
Joined: Sat Jul 30, 2005 2:15 pm

Re: Cannot Install Cacti-1.2.1 new release

#13 Post by paulbeard206 » Mon Jan 28, 2019 9:16 pm

The attached is where things sit right now.

https://mywebsite.org/cacti/install/install.php is the URL that gets returned on each iteration/reload.
Attachments
Screen Shot 2019-01-28 at 6.14.38 PM.png
Screen Shot 2019-01-28 at 6.14.38 PM.png (90.25 KiB) Viewed 1545 times

netniV
Cacti Guru User
Posts: 2673
Joined: Sun Aug 27, 2017 12:05 am

Re: Cannot Install Cacti-1.2.1 new release

#14 Post by netniV » Wed Jan 30, 2019 2:24 pm

eholz1 wrote:ok - BEEN following this
and if I run: sudo -u apache /opt/rh/rh-php56/root/usr/bin/php -q

I get: PHP Notice: Undefined offset: 1 in /opt/rh/httpd24/root/var/www/html/cacti/install/cli_check.php on line 36

My php.ini memory was: 2048, changed to 4096
Did you do this for the CLI or the Web? There are often two separate PHP.INI locations. 2048 MB would be plenty for the cli_check.php, but you didn't give it a parameter so it's giving you the undefined index issue. If you tag on 'extensions' or 'recommends' or 'optionals', you should get some JSON out.

netniV
Cacti Guru User
Posts: 2673
Joined: Sun Aug 27, 2017 12:05 am

Re: Cannot Install Cacti-1.2.1 new release

#15 Post by netniV » Wed Jan 30, 2019 2:25 pm

paulbeard206 wrote:The attached is where things sit right now.

https://mywebsite.org/cacti/install/install.php is the URL that gets returned on each iteration/reload.
Try following this thread for this issue:
viewtopic.php?f=2&t=59480

Post Reply