Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Sat Jun 15, 2019 11:48 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: Cacti on Raspbain rrd ver 1.6 cant select correct ver
PostPosted: Mon Mar 11, 2019 11:45 pm 
Offline

Joined: Mon Mar 11, 2019 9:40 pm
Posts: 2
There is a long roundabout story as to how I got to this post, trying to solve the issue of incorrect date and time reporting in csv export in cacti which revealed other issues, so Im trying to solve "base issues" first.
So Im using Cacti Ver 0.8.8 on a RaspberryPi with RRD Tool ver 1.6.0
The issue starts with Tech Support data says :"ERROR: Installed RRDTool version does not match configured version.
Please visit the Configuration Settings and select the correct RRDTool Utility Version."

When I try to set the correct version I dont have the option for the installed version.
Now maybe its just me but I have run update and upgrade several times and both cacti and RRD Tool seem to be up to date, so what am I doing wrong?


Top
 Profile  
 
 Post subject: Re: Cacti on Raspbain rrd ver 1.6 cant select correct ver
PostPosted: Tue Mar 12, 2019 4:57 am 
Offline
Cacti Guru User

Joined: Sun Aug 27, 2017 12:05 am
Posts: 2499
Console -> Configuration -> Settings, there is an RRD Tool version, make sure that it says 1.6.x in there too.

_________________
Official Cacti Developer

Cacti Resources:
Cacti Website (including releases)
Cacti Issues
Cacti Development Releases
Cacti Development Documentation

My resources:
How to submit Pull Requests
Development Wiki and How To's
Updated NetSNMP Memory template for Cacti 1.x
Cisco SFP template for Cacti 0.8.8


Top
 Profile  
 
 Post subject: Re: Cacti on Raspbain rrd ver 1.6 cant select correct ver
PostPosted: Tue Mar 12, 2019 10:01 am 
Offline

Joined: Mon Mar 11, 2019 9:40 pm
Posts: 2
Thats where the problem is, I dont have the option to select ver 1.6.x it only shows 1.0.x-1.5.x
Am I missing something?
I cant seem to find a newer version of Cacti so I assume it is up to date and current.
I have used cacti for years, but have recently decided to use it more to its potential.

_________________
A PC is like an Air Conditioner, it works fine until you open windows.


Top
 Profile  
 
 Post subject: Re: Cacti on Raspbain rrd ver 1.6 cant select correct ver
PostPosted: Tue Mar 12, 2019 2:37 pm 
Offline
Cacti User
User avatar

Joined: Fri Feb 10, 2017 2:45 pm
Posts: 237
Location: Long Island, New York, USA
An aside:

"A PC is like an Air Conditioner, it works fine until you open windows."

I Like That!

_________________
See the Cacti 1.x templates I use at: http://www.camerabob.com/cacti

Live: Cacti 1.2.3 @ CentOS 7-6.1810.2.el7 & PHP 5.4.16-46.e17
Maint @ 1.2
Monitor @ 2.3.6
Thold @ 1.2.4

Test: Cacti 1.2.3 @ CentOS 7-6.1810.2.el7 & PHP 5.4.45-17.e17.remi
Maint @ 1.2
Monitor @ 2.3.4
Thold @ 1.0.4


Top
 Profile  
 
 Post subject: Re: Cacti on Raspbain rrd ver 1.6 cant select correct ver
PostPosted: Tue Mar 12, 2019 8:00 pm 
Offline
Cacti Guru User

Joined: Sun Aug 27, 2017 12:05 am
Posts: 2499
Wait, you need to downgrade your RRDTool. With 0.8.8 I'm sure the latest supported version was something like 1.5

_________________
Official Cacti Developer

Cacti Resources:
Cacti Website (including releases)
Cacti Issues
Cacti Development Releases
Cacti Development Documentation

My resources:
How to submit Pull Requests
Development Wiki and How To's
Updated NetSNMP Memory template for Cacti 1.x
Cisco SFP template for Cacti 0.8.8


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 15 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group