After upgrade to version 1.2.3, thresholds aren't working

Post support questions that directly relate to Linux/Unix operating systems.

Moderators: Moderators, Developers

Post Reply
Author
Message
stormonts
Cacti User
Posts: 296
Joined: Tue Mar 31, 2009 10:05 am

After upgrade to version 1.2.3, thresholds aren't working

#1 Post by stormonts » Tue Apr 02, 2019 1:11 pm

After the upgrade to version 1.2.3 on CentOS 7, thresholds aren't being created automatically as they should be. We are also seeing this in the log:

2019/04/02 15:42:09 - CMDPHP PHP ERROR WARNING Backtrace: (/poller.php[676]:process_poller_output(), /lib/poller.php[532]:api_plugin_hook_function(), /lib/plugins.php[114]:api_plugin_run_plugin_hook_function(), /lib/plugins.php[221]:thold_poller_output(), /plugins/thold/includes/polling.php[368]:thold_calculate_percent(), /plugins/thold/thold_functions.php[1126]:CactiErrorHandler())
2019/04/02 15:42:09 - ERROR PHP WARNING in Plugin 'thold': A non-numeric value encountered in file: /usr/local/cacti-1.2.3/plugins/thold/thold_functions.php on line: 1126
2019/04/02 15:42:09 - CMDPHP PHP ERROR WARNING Backtrace: (/poller.php[676]:process_poller_output(), /lib/poller.php[532]:api_plugin_hook_function(), /lib/plugins.php[114]:api_plugin_run_plugin_hook_function(), /lib/plugins.php[221]:thold_poller_output(), /plugins/thold/includes/polling.php[368]:thold_calculate_percent(), /plugins/thold/thold_functions.php[1126]:CactiErrorHandler())
2019/04/02 15:42:09 - ERROR PHP WARNING in Plugin 'thold': A non-numeric value encountered in file: /usr/local/cacti-1.2.3/plugins/thold/thold_functions.php on line: 1126
2019/04/02 15:42:09 - CMDPHP PHP ERROR WARNING Backtrace: (/poller.php[676]:process_poller_output(), /lib/poller.php[532]:api_plugin_hook_function(), /lib/plugins.php[114]:api_plugin_run_plugin_hook_function(), /lib/plugins.php[221]:thold_poller_output(), /plugins/thold/includes/polling.php[368]:thold_calculate_percent(), /plugins/thold/thold_functions.php[1126]:CactiErrorHandler())
2019/04/02 15:42:09 - ERROR PHP WARNING in Plugin 'thold': A non-numeric value encountered in file: /usr/local/cacti-1.2.3/plugins/thold/thold_functions.php on line: 1126

netniV
Cacti Guru User
Posts: 2905
Joined: Sun Aug 27, 2017 12:05 am

Re: After upgrade to version 1.2.3, thresholds aren't workin

#2 Post by netniV » Tue Apr 02, 2019 8:19 pm

Yeah, my bad this one. I have noticed it on my local systems but I haven't posted an issue for it yet. Can you create one and i'll have a fix for it tomorrow.

stormonts
Cacti User
Posts: 296
Joined: Tue Mar 31, 2009 10:05 am

Re: After upgrade to version 1.2.3, thresholds aren't workin

#3 Post by stormonts » Tue Apr 02, 2019 8:31 pm



User avatar
ARC1450
Cacti User
Posts: 100
Joined: Wed Jun 24, 2009 9:42 am
Contact:

Re: After upgrade to version 1.2.3, thresholds aren't workin

#5 Post by ARC1450 » Sun Aug 11, 2019 3:20 pm

Is there somewhere one can download the latest THold that works for 1.2.2 of Cacti?

I noticed on git that all we can grab is 1.2.0 of THold and there's a few issues that I'm running into where you've posted fixes. However, Gentoo is only up to 1.2.2 for Cacti/Spine, so the 1.3 train of THold doesn't work.

Thanks
[color=black]mount -o protected -t voluptuous,selfmaintaining /dev/woman /mnt/me
Attitude is no substitute for competence
See through faded, super jaded, out of my mind[/color]

Post Reply