Unable to install Cacti 1.2.7

Post support questions that directly relate to Linux/Unix operating systems.

Moderators: Moderators, Developers

Post Reply
Author
Message
lukeDev
Posts: 3
Joined: Wed Oct 30, 2019 3:23 pm

Unable to install Cacti 1.2.7

#1 Post by lukeDev » Wed Oct 30, 2019 3:55 pm

Hello guys,

I'm new to Cacti so I'm trying to install it on RHEL 7 server but I'm stuck in the first step of the wizard :(
I have an error in PHP - Recommendations (web) "date.timezone" whereas is OK in PHP - Recommendations (cli), I edited the file /etc/php.ini but I guess for PHP - Recommendations (web) I have to modify another file, am I wrong?

img1.JPG
img1.JPG (98.03 KiB) Viewed 468 times

The second problem is that I installed all required module but for "mbstring" and "ldap" it's say "Web - No", can you help me solve these problems?


img2.JPG
img2.JPG (84.44 KiB) Viewed 468 times

Here the output of "rpm -qa | grep php":
php-process-5.4.16-46.el7.x86_64
php-common-5.4.16-46.el7.x86_64
php-gd-5.4.16-46.el7.x86_64
php-cli-5.4.16-46.el7.x86_64
php-pear-1.9.4-21.el7.noarch
php-pdo-5.4.16-46.el7.x86_64
php-mysql-5.4.16-46.el7.x86_64
php-mbstring-5.4.16-46.el7.x86_64
php-ldap-5.4.16-46.el7.x86_64
php-5.4.16-46.el7.x86_64
php-xml-5.4.16-46.el7.x86_64

Any help will be appreciated, thank you for your time :D

netniV
Cacti Guru User
Posts: 3132
Joined: Sun Aug 27, 2017 12:05 am

Re: Unable to install Cacti 1.2.7

#2 Post by netniV » Wed Oct 30, 2019 5:14 pm

If you are using apache, you need to edit the php.ini that it's using (whether that's via php-fpm or the php module). You will also need to make sure that the modules are not only installed but enabled.

lukeDev
Posts: 3
Joined: Wed Oct 30, 2019 3:23 pm

Re: Unable to install Cacti 1.2.7

#3 Post by lukeDev » Thu Oct 31, 2019 2:00 am

Hello NetniV,

thank you for your answer :D I'm using httpd 2.4 but if I search on the server for "php.ini" these are the only files:

/etc/php.ini
/etc/php.ini.rpmsave
/usr/share/doc/php-common-5.4.16/php.ini-development
/usr/share/doc/php-common-5.4.16/php.ini-production

Like I said I edited php.ini in etc folder but it modifies only php-cli, in "/etc/httpd/" folder I don't have a php.ini file, I just have a "php.conf" in "/etc/httpd/conf.d" folder.

How can I check if modules are enabled? If it could be helpful I checked /etc/php.d/ldap.ini and /etc/php.d/mbstring.ini files.

img1.JPG
img1.JPG (17.8 KiB) Viewed 459 times

img2.JPG
img2.JPG (17.88 KiB) Viewed 459 times

netniV
Cacti Guru User
Posts: 3132
Joined: Sun Aug 27, 2017 12:05 am

Re: Unable to install Cacti 1.2.7

#4 Post by netniV » Thu Oct 31, 2019 8:41 am

Honestly, couldn't tell you right now as I never use httpd. But if you google for how to enable php modules under httpd, I'm sure there's going to be plenty of people that have had that issue.

lukeDev
Posts: 3
Joined: Wed Oct 30, 2019 3:23 pm

Re: Unable to install Cacti 1.2.7

#5 Post by lukeDev » Thu Oct 31, 2019 2:19 pm

Hello netniV,

thank you again for your answer, after some test I removed php and httpd and then I installed these packages again, now it works and I can continue with the wizard :D

Post Reply