Trying to recover Cacti after upgrade

Post support questions that directly relate to Linux/Unix operating systems.

Moderators: Moderators, Developers

Post Reply
Author
Message
tomlee
Posts: 1
Joined: Mon Jan 13, 2020 10:57 am

Trying to recover Cacti after upgrade

#1 Post by tomlee » Mon Jan 13, 2020 11:55 am

upgraded to 1.2.8 and mariadb 5.56 wasnt ready for it. Got the well documented error when it tried to run

ALTER TABLE poller_output_realtime DROP PRIMARY KEY, ADD PRIMARY KEY (local_data_id, rrd_name, time, poller_id)

I have since upgraded the database, and run the command manually, all seems to be working, the server is polling, and I see current information in the database when I look at the poller table. But when I go to the server via the web, it asks for my login, and when i login i still get the error below.


Error
Your Cacti Server v1.2.8 has been installed/updated with errors

Process Log
--- NO LOG FOUND ---


How can I either re-run the update to get it to finish, or change what i need to to get apache to display the proper page and graphs?

any help would be appreciated

seanmancini
Cacti User
Posts: 110
Joined: Wed Mar 13, 2019 3:37 pm
Location: toronto
Contact:

Re: Trying to recover Cacti after upgrade

#2 Post by seanmancini » Tue Jan 28, 2020 10:07 pm

yeah ive seen this a few times clear cookies and cache on the browser try again
is this a remote poller ? if so perform a sync on the main poller

Post Reply