[SOLVED] Graphs No Longer Displaying After Upgrade to 1.2.8

Post support questions that directly relate to Linux/Unix operating systems.

Moderators: Moderators, Developers

Post Reply
Author
Message
cactlife
Posts: 4
Joined: Thu Jan 16, 2020 11:47 am

[SOLVED] Graphs No Longer Displaying After Upgrade to 1.2.8

#1 Post by cactlife » Thu Jan 16, 2020 1:25 pm

We upgraded Cacti to 1.2.8 and have been unable to get any graphs to display following the upgrade. When a web page loads that should show a graph, a message is presented stating:

Action Failed
Sorry, we could not process your last action.
Error: 200 OK
Reason: {"type":"png","local_graph_id":323,"rra_id":"0","image":"iVBORw........

2020-01-16 10_52_58-Tree Mode.png
2020-01-16 10_52_58-Tree Mode.png (290.24 KiB) Viewed 87 times


Cacti, PHP, and Apache logs don't show any new entries when a page is loaded.

We are running FreeBSD 11.3-RELEASE-p5 with the following installed:
  • Apache: 2.4.41
  • MySQL: 5.7.28_2
  • PHP: 7.3.13
  • RRDTool: 1.7.2_1
I have confirmed that PHP has the following modules loaded:

Code: Select all

[[email protected] ~]$ php -m
[PHP Modules]
bcmath
Core
ctype
date
dom
fileinfo
filter
gd
gettext
gmp
hash
iconv
json
ldap
libxml
mbstring
mysqli
mysqlnd
openssl
pcre
PDO
pdo_mysql
posix
Reflection
session
SimpleXML
snmp
sockets
SPL
standard
xml
xmlreader
xmlwriter
Zend OPcache
zlib
One thing I did find is that PHP was compiled with the "--disable-cli" option. Not sure if this could cause the issue or not.

Code: Select all

'./configure' '--with-layout=GNU' '--with-config-file-scan-dir=/usr/local/etc/php' '--disable-all' '--enable-libxml' '--with-libxml-dir=/usr/local' '--with-pcre-regex=/usr/local' '--with-password-argon2=/usr/local' '--program-prefix=' '--enable-mysqlnd' '--disable-cli' '--disable-cgi' '--with-apxs2=/usr/local/sbin/apxs' '--enable-dtrace' '--prefix=/usr/local' '--localstatedir=/var' '--mandir=/usr/local/man' '--infodir=/usr/local/share/info/' '--build=amd64-portbld-freebsd11.3' 'build_alias=amd64-portbld-freebsd11.3' 'CFLAGS=-O2 -pipe -fstack-protector-strong -fno-strict-aliasing ' 'CPP=cpp' 'CXXFLAGS=-O2 -pipe -fstack-protector-strong -fno-strict-aliasing '
Thanks in advance for any advice you can offer!
Last edited by cactlife on Tue Jan 21, 2020 10:37 am, edited 1 time in total.

cactlife
Posts: 4
Joined: Thu Jan 16, 2020 11:47 am

Re: Graphs No Longer Displaying After Upgrade to 1.2.8

#2 Post by cactlife » Thu Jan 16, 2020 2:11 pm

I have also found that running the following command returns nothing:

Code: Select all

sudo -u www php /usr/local/share/cacti/include/cli_check.php extensions

cactlife
Posts: 4
Joined: Thu Jan 16, 2020 11:47 am

Re: Graphs No Longer Displaying After Upgrade to 1.2.8

#3 Post by cactlife » Thu Jan 16, 2020 2:59 pm

I did get some output from sudo php -q install/cli_check.php extensions:

Code: Select all

{"ctype":{"cli":true,"web":false},"PDO":{"cli":true,"web":false},"zlib":{"cli":true,"web":false},"xml":{"cli":true,"web":false},"standard":{"cli":true,"web":false},"spl":{"cli":true,"web":false},"sockets":{"cli":true,"web":false},"simplexml":{"cli":true,"web":false},"session":{"cli":true,"web":false},"pdo_mysql":{"cli":true,"web":false},"pcre":{"cli":true,"web":false},"date":{"cli":true,"web":false},"openssl":{"cli":true,"web":false},"mbstring":{"cli":true,"web":false},"ldap":{"cli":true,"web":false},"json":{"cli":true,"web":false},"hash":{"cli":true,"web":false},"gmp":{"cli":true,"web":false},"gd":{"cli":true,"web":false},"filter":{"cli":true,"web":false},"posix":{"cli":true,"web":false}}

cactlife
Posts: 4
Joined: Thu Jan 16, 2020 11:47 am

Re: [SOLVED] Graphs No Longer Displaying After Upgrade to 1.2.8

#4 Post by cactlife » Tue Jan 21, 2020 10:44 am

Issue is now resolved. Determined that somehow the config.php got truncated during the upgrade process and only included the first 53 lines of what was originally present. Re-created the config.php using config.php.sample. Graphs now display without error.

Post Reply