patch problem

Support for the Plugin Architecture

Moderators: Moderators, Developers

Post Reply
Author
Message
jjjjjuannnnn
Posts: 9
Joined: Wed Oct 14, 2009 5:22 am

patch problem

#1 Post by jjjjjuannnnn » Wed Oct 14, 2009 5:26 am

hi everyone

i'm not good with debian so all of this it is pretty difficult for me but I managed to install cacti, php5, mysql and everything that i need for cacti an it is working. But now that i'm trying to install the pluging architecture i got this message when i do

debian:~# patch -p1 -N --dry-run < cacti-plugin-0.8.7e-PA-v2.5.diff
can't find file to patch at input line 4
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -Naur cacti-0.8.7e-old/auth_changepassword.php cacti-0.8.7e/auth_changepassword.php
|--- cacti-0.8.7e-old/auth_changepassword.php 2009-06-28 11:07:26.000000000 -0500
|+++ cacti-0.8.7e/auth_changepassword.php 2009-06-28 22:51:07.000000000 -0500
--------------------------
File to patch:


shall i chosee one of those to patch??
have no idea

any ideas?

thanks

jjjjjuannnnn
Posts: 9
Joined: Wed Oct 14, 2009 5:22 am

#2 Post by jjjjjuannnnn » Wed Oct 14, 2009 7:14 am

found the problem

i forgot to move the .diff in the right folder, that is the cacti folder

and i was executing the comand in root, when it should be done in the cacti folder

Post Reply