No Install or Download buttons?

Support for the Plugin Architecture

Moderators: Moderators, Developers

Post Reply
Author
Message
uno
Posts: 32
Joined: Mon Aug 27, 2007 7:22 am

No Install or Download buttons?

#1 Post by uno » Thu Jan 28, 2010 10:54 am

Hi.

I just installed the latest PA on our cacti 0.8.7e install. I used the prepatched files and copied them to the cacti directory. Then I imported pa.sql and enabled the realm in User Management. I can see the Plugin Management link in the menu, but when I click it I only see the installed versions. There are no links to do anything.
Am I missning something fundamental regarding plugins installations, or is there something wrong?
I am trying to install boost, and have imported the sql file.
Attachments
pa.png
pa.png (35.38 KiB) Viewed 2953 times

User avatar
Howie
Cacti Guru User
Posts: 5333
Joined: Thu Sep 16, 2004 5:53 am
Location: United Kingdom
Contact:

#2 Post by Howie » Thu Jan 28, 2010 12:30 pm

Did you put any plugins in the plugins/ directory?
Weathermap 0.98 is out! & QuickTree 1.0. Superlinks is over there now (and built-in to Cacti 1.x).
Some Other Cacti tweaks, including strip-graphs, icons and snmp/netflow stuff.
(Let me know if you have UK DevOps or Network Ops opportunities, too!)

uno
Posts: 32
Joined: Mon Aug 27, 2007 7:22 am

#3 Post by uno » Fri Jan 29, 2010 3:20 am

Yes. First I put boost in that directory. Now I also tried with the clog plugin, but nothing appears on the plugin management page. Should I keep the directory structure of the plugins, including the version-directory, i.e. plugins/boost/v2.5/ ?

User avatar
Howie
Cacti Guru User
Posts: 5333
Joined: Thu Sep 16, 2004 5:53 am
Location: United Kingdom
Contact:

#4 Post by Howie » Fri Jan 29, 2010 3:38 am

no you should have plugins/clog and plugins/boost.
Weathermap 0.98 is out! & QuickTree 1.0. Superlinks is over there now (and built-in to Cacti 1.x).
Some Other Cacti tweaks, including strip-graphs, icons and snmp/netflow stuff.
(Let me know if you have UK DevOps or Network Ops opportunities, too!)

uno
Posts: 32
Joined: Mon Aug 27, 2007 7:22 am

#5 Post by uno » Fri Jan 29, 2010 3:41 am

Thanks, that fixed the problem.

Post Reply