How To Install Plugin Architecture on Ubuntu 9.10 Server ?!

Support for the Plugin Architecture

Moderators: Moderators, Developers

Author
Message
leandrofviana
Posts: 4
Joined: Wed Dec 02, 2009 1:20 pm

Re: How To Install Plugin Architecture on Ubuntu 9.10 Server

#16 Post by leandrofviana » Thu Jul 28, 2011 8:55 am

I'm using ubuntu 10.04, cacti Version 0.8.7e and plugin Architecture v2.9. I do everything as I described, plugins, etc. appear. But the graph stops running. It just does not create more graphic. Can I use version 2.9 of the PIA in cacti 0.8.7e? Has anyone gone through this problem?

leandrofviana
Posts: 4
Joined: Wed Dec 02, 2009 1:20 pm

Re: How To Install Plugin Architecture on Ubuntu 9.10 Server

#17 Post by leandrofviana » Thu Jul 28, 2011 9:25 am

[Thu Jul 28 11:09:59 2011] [error] [client 10.7.5.57] PHP Warning: include_once (): Failed opening '/ usr / share / cacti / site / include / plugins.php' for inclusion (include_path = '.') in / usr / share / cacti / site / include / global.php on line 208
[Thu Jul 28 11:09:59 2011] [error] [client 10.7.5.57] PHP Fatal error: Call to undefined function api_plugin_hook () in / usr / share / cacti / site / include / global_arrays.php on line 663

ealcaniz
Posts: 40
Joined: Fri Sep 30, 2011 3:37 am

Re: How To Install Plugin Architecture on Ubuntu 9.10 Server

#18 Post by ealcaniz » Tue Nov 01, 2011 5:36 am

when you say

For a fresh install you have to import the pa.sql to your cacti database:

Quote:
mysql cacti < pa.sql -u root -p

if I have installed cacti and all configured and I want to add PIA, have to do this?
Thanks

Edu

User avatar
TheWitness
Developer
Posts: 14804
Joined: Tue May 14, 2002 5:08 pm
Location: MI, USA
Contact:

Re: How To Install Plugin Architecture on Ubuntu 9.10 Server

#19 Post by TheWitness » Tue Nov 01, 2011 7:04 am

Look here, but use full files instead of patch method. Also keep in mind that Debian's config.php and global.php are different than stock, so you have to tread lightly. In addition, Debian moves a few directories to alternate locations.

http://docs.cacti.net/manual:087:1_installation.9_pia

TheWitness
True understanding begins only when we realize how little we truly understand...

Life is an adventure, let yours begin with Cacti!

Author of MacTrack, Boost, CLog, SpikeKill, Platform RTM, DSStats, maintainer of Spine, lot's of unpublished work and most of Cacti's bugs.
_________________
Official Cacti Documentation
GitHub Repository with Supported Plugins
Central Plugin Repository
Central Templates Repository


I'm still out there people. Getting excited for Cacti 1.2. I think it will be a great release.

ealcaniz
Posts: 40
Joined: Fri Sep 30, 2011 3:37 am

Re: How To Install Plugin Architecture on Ubuntu 9.10 Server

#20 Post by ealcaniz » Tue Nov 01, 2011 7:15 am

I got working, first time it mess up in my sql server, I have 3 cacti in production, in these one works well, only I had to restart mysqld before apply pa.sql and after.
Thanks

Edu

semihtore
Posts: 5
Joined: Tue Nov 01, 2011 7:04 am

Re: How To Install Plugin Architecture on Ubuntu 9.10 Server

#21 Post by semihtore » Tue Nov 01, 2011 7:18 am

I've installed cacti from repository following the instructions written on cacti's offical site,my linux distribution is ubuntu 10.But when ı want to install a plugin it is not possible to install directly from aministration panel,because there is no such a menu item.
Also,ı've tried to install manually,getting the plugin then extracting into the plugin installation folder.I checked the configuration many times,but didn'd succeed.
What else should ı do more?

Thank you so much for your time.

ealcaniz
Posts: 40
Joined: Fri Sep 30, 2011 3:37 am

Re: How To Install Plugin Architecture on Ubuntu 9.10 Server

#22 Post by ealcaniz » Tue Nov 01, 2011 7:22 am

1 could you copy your /include/config.php here
2 ls fo /plugins/...
3 check if your user have the configuration of PIA tick mark
Thanks

Edu

ealcaniz
Posts: 40
Joined: Fri Sep 30, 2011 3:37 am

Re: How To Install Plugin Architecture on Ubuntu 9.10 Server

#23 Post by ealcaniz » Tue Nov 01, 2011 7:24 am

I did this

tar xvfz cacti-plugin-0.8.7h-PA-v3.0.tar.gz
cd cacti-plugin-arch/
cp cacti-plugin-0.8.7h-PA-v3.0.diff /var/www/cacti/
cd /var/www/cacti/
patch -p1 -N --dry-run < cacti-plugin-0.8.7h-PA-v3.0.diff
patch -p1 -N < cacti-plugin-0.8.7h-PA-v3.0.diff
vi ./include/config.php

Add this lines

/* load up old style plugins here */
$plugins = array();
//$plugins[] = 'thold';

/*
Edit this to point to the default URL of your Cacti install
ex: if your cacti install as at http://serverip/cacti/ this
would be set to /cacti/
*/
$url_path = "/cacti/";



service mysqld restart
cd /tmp/cacti-plugin-arch/
mysql cacti < pa.sql -u root -p
service mysqld restart

and works for me, only you have to go to user management and in your use tick the mark pluggins management.
Thanks

Edu

semihtore
Posts: 5
Joined: Tue Nov 01, 2011 7:04 am

Re: How To Install Plugin Architecture on Ubuntu 9.10 Server

#24 Post by semihtore » Tue Nov 01, 2011 7:40 am

This my screen
Attachments
Untitled.png
Untitled.png (74.83 KiB) Viewed 6426 times

ealcaniz
Posts: 40
Joined: Fri Sep 30, 2011 3:37 am

Re: How To Install Plugin Architecture on Ubuntu 9.10 Server

#25 Post by ealcaniz » Tue Nov 01, 2011 9:01 am

ok did you apply the steps like i did it?
Thanks

Edu

semihtore
Posts: 5
Joined: Tue Nov 01, 2011 7:04 am

Re: How To Install Plugin Architecture on Ubuntu 9.10 Server

#26 Post by semihtore » Tue Nov 01, 2011 4:28 pm

Successfully apply a patch consists of these steps, while the point while cactinin lot of trouble from there I'm doing is taking the main directory of the diff file. but it was not
I am about to go nuts:)
From there can I contact if I have an email address.

vincentmr9
Posts: 14
Joined: Wed May 11, 2011 3:10 pm

Re: How To Install Plugin Architecture on Ubuntu 9.10 Server

#27 Post by vincentmr9 » Wed Jan 16, 2013 12:12 pm

I think something might be wrong with the forum site, would someone be able to post what is the correct code- see whats underlined below. I opened this forum page in firefox, chrome, and ie and get the same scrambled code. Not sure why. Thank you.
$config["rra_path"] = $config["base_path"]."/rra";
change it to:
$config["rra_path"] = "/var/lib/cacti/rra";


include($config["library_path"]."/adodb/adodb.inc.php");
change it to:
include("/usr/share/php/adodb/adodb.inc.php");


$config[’url_path’] = ‘/’;
to:
$config[’url_path’] = ‘/cacti/’;

Post Reply