Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Wed Jul 26, 2017 5:53 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 7 posts ] 
Author Message
 Post subject: Plugins problems
PostPosted: Sun Jul 14, 2013 4:30 am 
Offline

Joined: Sun Jul 14, 2013 4:20 am
Posts: 1
I've downloaded the latest Cacti version (0.8.8 ) from the website last week.
I've read that i don't need to install PIA because it's invluded inside the Cacti 0.8.8.
Now i'm trying to install some plugins (Weathermap, thold, realtime), so i've downloaded the files, extracted them and moved them to /var/www/html/cacti/plugins
Now I have no idea why, but i can't see them in the Plugin Management inside Cacti.
Can anyone please help me? maybe i'm missing something?


Top
 Profile  
 
 Post subject: Re: Plugins problems
PostPosted: Tue Aug 13, 2013 12:39 pm 
Offline
Developer

Joined: Thu Apr 07, 2005 3:29 pm
Posts: 2591
Location: B/CS Texas
1st, check the permissions on the plugin folders, make sure them and all files under then are readable by the webserver.
2nd, check and ensure the folder names are correct (ex: thold plugins folder name should be "thold" and the setup.php files should be directly under that folder)

_________________
CactiEZ CD


Top
 Profile  
 
 Post subject: Re: Plugins problems
PostPosted: Fri Aug 23, 2013 2:21 pm 
Offline

Joined: Fri Aug 23, 2013 2:17 pm
Posts: 17
I have the same problem as the OP, does the plugins directory need the same owner as rra, or as the rest of the cacti files?

I am trying to install rrdclean, and I double checked, it is the only folder inside /var/www/cacti/plugins/, and there exists a /var/www/cacti/plugins/setup.php with the below function (and others) inside:

Code:
function plugin_rrdclean_install () {
        api_plugin_register_hook('rrdclean', 'config_arrays', 'rrdclean_config_arrays', 'setup.php');
        api_plugin_register_hook('rrdclean', 'draw_navigation_text', 'rrdclean_draw_navigation_text', 'setup.php');
        api_plugin_register_hook('rrdclean', 'config_settings', 'rrdclean_config_settings', 'setup.php');
        api_plugin_register_hook('rrdclean', 'poller_bottom', 'rrdclean_poller_bottom', 'setup.php');

        rrdclean_setup_table_new ();
}


Top
 Profile  
 
 Post subject: Re: Plugins problems
PostPosted: Fri Aug 23, 2013 2:31 pm 
Offline
Developer
User avatar

Joined: Thu Dec 02, 2004 2:46 am
Posts: 22461
Location: Muenster, Germany
mabelrxu wrote:
and there exists a /var/www/cacti/plugins/setup.php with the below function (and others) inside:
That's strange. It should be /var/www/cacti/plugins/rrdclean/setup.php
R.

_________________
Official Cacti Documentation
Official Debugging Help
Central Plugin Repository
Central Templates Repository


Top
 Profile  
 
 Post subject: Re: Plugins problems
PostPosted: Fri Aug 23, 2013 2:55 pm 
Offline

Joined: Fri Aug 23, 2013 2:17 pm
Posts: 17
sorry, I mistyped ... when I do
Code:
ls -al plugins/rrdclean/
I have

Code:
drwxrwxr-x. 2 root root  4096 Dec 14  2010 .
drwxrwxr-x. 3 root root  4096 Aug 23 09:12 ..
-rw-rw-r--. 1 root root  1117 Nov 18  2010 inc_rrdclean_filter_table.php
-rw-rw-r--. 1 root root 15237 Nov 18  2010 LICENSE
-rw-rw-r--. 1 root root  3157 Dec 14  2010 README
-rw-rw-r--. 1 root root 18813 Dec 14  2010 rrdcleaner.php
-rw-rw-r--. 1 root root 10754 Dec 14  2010 rrdmove.php
-rw-rw-r--. 1 root root  7330 Dec 14  2010 setup.php


I think my main problem is this:

Code:
mysql> select * from plugin_config;
Empty set (0.00 sec)


what populates the plugin_config database table?


Top
 Profile  
 
 Post subject: Re: Plugins problems
PostPosted: Fri Aug 23, 2013 3:22 pm 
Offline

Joined: Fri Aug 23, 2013 2:17 pm
Posts: 17
I have no plugins detected, despite the below:

Code:
ls -al plugins/
total 16
drwxrwxr-x.  3 root root 4096 Aug 23 09:12 .
drwxr-xr-x. 13 root root 4096 Aug 23 09:06 ..
-rw-r--r--.  1 root root   45 Aug 23 09:04 index.php
drwxrwxr-x.  2 root root 4096 Dec 14  2010 rrdclean


any thoughts?


Attachments:
Untitled.png
Untitled.png [ 193.14 KiB | Viewed 3365 times ]
Top
 Profile  
 
 Post subject: Re: Plugins problems
PostPosted: Sat Aug 24, 2013 1:35 am 
Offline

Joined: Fri Aug 23, 2013 2:17 pm
Posts: 17
fixed it by upgrading from 0.8.8a to 0.8.8b. lol


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group