Plugins not showing in Plugin Management

Support for the Plugin Architecture

Moderators: Moderators, Developers

Post Reply
Author
Message
cristip0p
Posts: 4
Joined: Sun Feb 01, 2015 5:40 pm

Plugins not showing in Plugin Management

#1 Post by cristip0p » Sun Feb 01, 2015 6:01 pm

Hello,

Of my 9 plugins in var/www/html/cacti/plugins/ only 6 are showing in the Plugin Management page:
Monitor 1.3
Fix64bit 0.4
Settings 0.71
Boost 5.1
Nectar 0.11
Thold 0.5

The other 3 not working:
aggregate-070B2
rrdclean-0.38
mURLin

Cacti Version: 0.8.8c, Plugin Architecture Version: 3.1 on Linux 3.10.0-123.el7.x86_64

I have no idea where to start looking for the problem - for my PA version my understanding was that all I had to do was put the plugin folders in cacti/plugins/

Thank you in advance.

cigamit
Developer
Posts: 2772
Joined: Thu Apr 07, 2005 3:29 pm
Location: B/CS Texas
Contact:

Re: Plugins not showing in Plugin Management

#2 Post by cigamit » Sun Feb 01, 2015 8:35 pm

Post the contents of the plugin directory, and also permissions on each folder.

cristip0p
Posts: 4
Joined: Sun Feb 01, 2015 5:40 pm

Re: Plugins not showing in Plugin Management

#3 Post by cristip0p » Mon Feb 02, 2015 2:41 am

See the attached file.

Thank you
Attachments
Image 1.png
Image 1.png (12 KiB) Viewed 3394 times

cigamit
Developer
Posts: 2772
Joined: Thu Apr 07, 2005 3:29 pm
Location: B/CS Texas
Contact:

Re: Plugins not showing in Plugin Management

#4 Post by cigamit » Mon Feb 02, 2015 9:13 am

ya, as I thought. Plugin directories have to be named EXACTLY like their name (spelling and case). For instance
aggregate-070B2
needs to be renamed
aggregate

Case is important too, so
mURLin
needs to be
murlin

rrdclean-0.38
needs to be
rrdclean

cristip0p
Posts: 4
Joined: Sun Feb 01, 2015 5:40 pm

Re: Plugins not showing in Plugin Management

#5 Post by cristip0p » Tue Feb 03, 2015 7:39 am

You were right! Problem solved.

Thank you, cigamit.

Post Reply