Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Mon Jul 22, 2019 2:43 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 7 posts ] 
Author Message
 Post subject: Added graph to host, graph not showing up in the tree
PostPosted: Thu Jul 11, 2019 10:29 am 
Offline
User avatar

Joined: Tue Mar 23, 2004 1:52 pm
Posts: 37
Friends,

I added a new graph for the local cacti host, but it does not show up under that host in the graph tree. I can see the graph in Management|Graphs, it has data in it and looks okay. I've also added that graph template to the Management|Devices entry for the host. I've deleted it and recreated it as well to see if I can "trigger" it being added to the host under the tree, but it never shows up.

Also, while viewing the tree, the template does not show up when I hit the drop-down for selecting a specific template. It also does not show up when I select "Not Templated".

I was able to manually add the individual graph to the tree, but no way to add it under the host.

Any ideas why this one graph is not showing up in the tree under the host?


Top
 Profile  
 
 Post subject: Re: Added graph to host, graph not showing up in the tree
PostPosted: Thu Jul 11, 2019 5:33 pm 
Offline
Cacti Guru User

Joined: Sun Aug 27, 2017 12:05 am
Posts: 2601
When you say that it does not show up under the host on the tree, do you mean that you added the host to the tree but when you click on the host it does not show?

_________________
Official Cacti Developer

Cacti Resources:
Cacti Website (including releases)
Cacti Issues
Cacti Development Releases
Cacti Development Documentation

My resources:
How to submit Pull Requests
Development Wiki and How To's
Updated NetSNMP Memory template for Cacti 1.x
Cisco SFP template for Cacti 0.8.8


Top
 Profile  
 
 Post subject: Re: Added graph to host, graph not showing up in the tree
PostPosted: Thu Jul 11, 2019 9:26 pm 
Offline
User avatar

Joined: Tue Mar 23, 2004 1:52 pm
Posts: 37
netniV wrote:
When you say that it does not show up under the host on the tree, do you mean that you added the host to the tree but when you click on the host it does not show?


Yes, as normally all I have to do is add a host to a spot on the tree, and then when I click on the host all the graphs for that host show up. Several times now I've added new graphs to a host and they then show up in the graph tree under the host just fine. But for some reason this new one didn't do that. I am able to manually add the individual graph to a spot on the tree, but then it is not part of that host. I hope I am explaining this well. :(


Top
 Profile  
 
 Post subject: Re: Added graph to host, graph not showing up in the tree
PostPosted: Fri Jul 12, 2019 8:17 am 
Offline
Cacti Guru User

Joined: Sun Aug 27, 2017 12:05 am
Posts: 2601
Without having your data that could be tricky to replicate. Is there any chance you can send a database dump to [email protected] and include the host id/name and graph id/names for the working/missing item, and the obviously which tree/node it should appear under?

_________________
Official Cacti Developer

Cacti Resources:
Cacti Website (including releases)
Cacti Issues
Cacti Development Releases
Cacti Development Documentation

My resources:
How to submit Pull Requests
Development Wiki and How To's
Updated NetSNMP Memory template for Cacti 1.x
Cisco SFP template for Cacti 0.8.8


Top
 Profile  
 
 Post subject: Re: Added graph to host, graph not showing up in the tree
PostPosted: Fri Jul 12, 2019 8:27 am 
Offline
User avatar

Joined: Tue Mar 23, 2004 1:52 pm
Posts: 37
netniV wrote:
Without having your data that could be tricky to replicate. Is there any chance you can send a database dump to [email protected] and include the host id/name and graph id/names for the working/missing item, and the obviously which tree/node it should appear under?


That is a very generous offer, and I sincerely appreciate your assistance, but I'm afraid I cannot send in the data you requested. Long story. Meanwhile, I'm going to try out a few more things and see if I can find a solution. Unique about this graph is that I created it from a template that was supposed to be for the .8 version of Cacti, yet it imported without any issues. I can't help but feel like there's something not quite right so I may end up recreating part or all of the template by hand and see if that makes any difference.

That said, I have already found a work-around by manually creating an entry in the tree, and then adding the graphs directly to that spot. And the truth is that may end up being a more elegant solution for how I want to arrange the tree regardless, so it may work out long-term just fine.
-Eric


Top
 Profile  
 
 Post subject: Re: Added graph to host, graph not showing up in the tree
PostPosted: Fri Jul 12, 2019 11:41 am 
Offline
User avatar

Joined: Tue Mar 23, 2004 1:52 pm
Posts: 37
Okay I don't know what the heck happened but the graphs started showing up in the host. I reproduced the issue, creating new graphs, adding them to the device template, pushing the device templte update to the devices, then adding the graph to the devices. They didn't show up in the tree right away. Even after refreshing and such they weren't there. I did do some tree editing, lock, unlock, etc, at some point so maybe that triggered something. /boggle/


Top
 Profile  
 
 Post subject: Re: Added graph to host, graph not showing up in the tree
PostPosted: Fri Jul 12, 2019 1:47 pm 
Offline
Cacti Guru User

Joined: Sun Aug 27, 2017 12:05 am
Posts: 2601
What version of Cacti are you on?

_________________
Official Cacti Developer

Cacti Resources:
Cacti Website (including releases)
Cacti Issues
Cacti Development Releases
Cacti Development Documentation

My resources:
How to submit Pull Requests
Development Wiki and How To's
Updated NetSNMP Memory template for Cacti 1.x
Cisco SFP template for Cacti 0.8.8


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: Google [Bot] and 12 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group