[SOLVED]RRD file not written - Strange

Post general support questions here that do not specifically fall into the Linux or Windows categories.

Moderators: Moderators, Developers

Post Reply
Author
Message
eholz1
Cacti User
Posts: 149
Joined: Mon Oct 01, 2018 10:09 am

[SOLVED]RRD file not written - Strange

#1 Post by eholz1 » Fri Nov 01, 2019 12:51 pm

Hello,
I have not figured this one out (yet).
I have two servers running cacti, one is for testing, and one is production.
The production is running cacti-1.1.38, the test is running 1.2.7 - both work fine (sort of), and are polling the same devices.

I am polling a Juniper MX-80 with the FRU Stats query/graps/datasource I downloaded from somewhere.
I imported the host template, graph templates, datasource templates/query (juniper_fru.xml) into the 1.1.38 server.
Added the data query to the device, along with the interfaces query.Both of these queries run. I created a graph for the
juniper temperatature - and the sys utils show the query running, the rrd file built and updated, and graph shows up.

BUT:
I imported the same query, templates and host template etc into my 1.2.7 server, and get the interfaces query OK,
and it creates graphs. I load the Juniper FRU Stats query (in data queries,etc) the xml file scans ok.
I then try to create the same FRU temperature graph - but no rrd file is created, because the query does not run.

Is there a difference in the way the two different version of cacti interpret the xml files? I get now warnings on cacti-1.1.38, but get a
"index_order_type" warning when I run this on cacti-1.2.7.

Any suggestions on this??
Thanks,
eholz1

p.s. the utils on 1.1.38, for the query cache and the poller cache show polling and query data for the ds in question
Last edited by eholz1 on Wed Nov 13, 2019 2:49 pm, edited 1 time in total.

eholz1
Cacti User
Posts: 149
Joined: Mon Oct 01, 2018 10:09 am

Re: RRD file not written - Strange

#2 Post by eholz1 » Tue Nov 05, 2019 1:20 pm

Hope someone replies,

I have discovered an issue with a particular device. I have download a host template, and associated graphs for a juniper mx-80.
These templates seem to work in cacti-1.1.38, i.e. the FRU temperature for one. The template is Juniper FRU stats.

I can get interface data from the device via the std. cacti snmp interrfaces template. I cannot get data from the query, juniper_fru.xml.
I can use snmpwalk to get the value (GUAGE) from the device using the correct OID.
I can run spine manually, and if I have a graph for the temp, spine returns the index and the value: 37 deg C.
But this data is not reflected in the query utilities or the datasource info, or the RRD file.
The rrd file is created but gets no data from the query.

the rrd files are owned by cacti:cacti, the poller is run by the cacti user.
The datasource shows all NAN,

Any suggestions?
eholz1

netniV
Cacti Guru User
Posts: 2978
Joined: Sun Aug 27, 2017 12:05 am

Re: RRD file not written - Strange

#3 Post by netniV » Fri Nov 08, 2019 8:41 am

That sort of thing is very hard to diagnose without having access to the network, server and data.

eholz1
Cacti User
Posts: 149
Joined: Mon Oct 01, 2018 10:09 am

Re: [SOLVED]RRD file not written - Strange

#4 Post by eholz1 » Wed Nov 13, 2019 2:52 pm

Hello NetiV,
you are correct. BUT, it was the permissions again!
I reverted the virtual machine to the "working" state, and did not change any permissions.
It seems that it is TOO easy to mess up the permissons on the cacti file chain. (/var/www/cacti/...)

Thanks for the reply - this is a good source of info, even when I make obvious mistakes

eholz1
Cacti intermediate

Post Reply