Error: XML: Hash version does not exist.

Post general support questions here that do not specifically fall into the Linux or Windows categories.

Moderators: Moderators, Developers

Author
Message
mseba
Posts: 2
Joined: Wed Nov 02, 2005 1:56 am

Error: XML: Hash version does not exist.

#1 Post by mseba » Wed Nov 02, 2005 10:23 am

I have result:
my cacti on debian (version 8.6.c) get this error.

New version cacti-0.8.6g have't error ...

User avatar
fmangeant
Cacti Guru User
Posts: 2326
Joined: Fri Sep 19, 2003 8:36 am
Location: Sophia-Antipolis, France
Contact:

#2 Post by fmangeant » Wed Nov 02, 2005 10:42 am

Hi

Cacti supports importing templates exported with an older version into a newer version, but not the reverse.
[size=84]
[color=green]HOWTOs[/color] :
[list][*][url=http://forums.cacti.net/viewtopic.php?t=15353]Install and configure the Net-SNMP agent for Unix[/url]
[*][url=http://forums.cacti.net/viewtopic.php?t=26151]Install and configure the Net-SNMP agent for Windows[/url]
[*][url=http://forums.cacti.net/viewtopic.php?t=28175]Graph multiple servers using an SNMP proxy[/url][/list]
[color=green]Templates[/color] :
[list][*][url=http://forums.cacti.net/viewtopic.php?t=15412]Multiple CPU usage for Linux[/url]
[*][url=http://forums.cacti.net/viewtopic.php?p=125152]Memory & swap usage for Unix[/url][/list][/size]

akai
Posts: 7
Joined: Tue Feb 01, 2005 3:59 am

#3 Post by akai » Thu Nov 03, 2005 6:17 am

Cacti supports importing templates exported with an older version into a newer version
old v. template->newer cacti v.
Sometimes!

User avatar
N3NCY
Cacti User
Posts: 242
Joined: Thu Sep 22, 2005 7:50 pm
Location: Landenberg, PA
Contact:

#4 Post by N3NCY » Thu Nov 03, 2005 8:28 am

I made this template and exported it with 0.8.6g.
I get this error when importing it to my other 0.8.6g box:
Error: XML: Cacti version does not exist.

This is a simple host template for charting ink levels in a typical HP Inkjet printer (network printer)

See attached.
Attachments
cacti_host_template_hp_network_printer.xml
HP Network Injet Printer - Ink Levels Host Template
(124.86 KiB) Downloaded 1367 times
Thank you,

Ernie
http://www.NMSWorld.com
[b]Dual Zeon Dual Core 2.6Ghz / 8GB RAM / 4x15k RPM SATA RAID5[/b]
[b]Cacti Version[/b] - 0.8.7b
[b]Poller Type[/b] - cactid 0.8.7 with Boost v1.7
[b]Server Info[/b] - FreeBSD 7.0-RELEASE
[b]Web Server[/b] - Apache/2.2.6 (Unix) mod_ssl/2.2.6 OpenSSL/0.9.8g DAV/2 PHP/5.2.5 mod_perl/2.0.3 Perl/v5.8.8
[b]PHP[/b] - 5.2.6
[b]MySQL[/b] - 5.0.51b Mod: poller_output ENGINE = MEMORY
[b]RRDTool[/b] - 1.3.0
[b]SNMP[/b] - 5.4.1
[b]Plugins[/b] - Host Info (hostinfo - v0.2), Update Checker (update - v0.3), Network Tools (tools - v0.2), FlowView (flowview - v0.3), Read-only Devices Tab (devices - v0.4), Network Discovery (discovery - v0.8.3), Syslog Monitoring (syslog - v0.5.2), Thresholds (thold - v0.3.9), Device Monitoring (monitor - v0.8.2), PHP Network Weathermap (weathermap - v0.941), SuperLinks (superlinks - v0.72), Report Creator (reports - v0.1b)

carrison
Posts: 30
Joined: Fri Oct 14, 2005 2:26 am

#5 Post by carrison » Mon Nov 28, 2005 1:55 am

I encounter same error while importing new templetes into cacti 0.8.6g....

User avatar
TheWitness
Developer
Posts: 14817
Joined: Tue May 14, 2002 5:08 pm
Location: MI, USA
Contact:

#6 Post by TheWitness » Mon Nov 28, 2005 6:51 am

PHP version that you are running please? Also, would like someone to submit a bug report. http://bugs.cacti.net.

TheWitness
True understanding begins only when we realize how little we truly understand...

Life is an adventure, let yours begin with Cacti!

Author of MacTrack, Boost, CLog, SpikeKill, Platform RTM, DSStats, maintainer of Spine, lot's of unpublished work and most of Cacti's bugs.
_________________
Official Cacti Documentation
GitHub Repository with Supported Plugins
Central Plugin Repository
Central Templates Repository


I'm still out there people. Getting excited for Cacti 1.2. I think it will be a great release.

User avatar
BSOD2600
Cacti Moderator
Posts: 12160
Joined: Sat May 08, 2004 12:44 pm
Location: USA

#7 Post by BSOD2600 » Mon Nov 28, 2005 1:34 pm

You sure you both are running the same patch level as when the template was created?

User avatar
rony
Developer/Forum Admin
Posts: 6016
Joined: Mon Nov 17, 2003 6:35 pm
Location: Michigan, USA
Contact:

#8 Post by rony » Mon Nov 28, 2005 2:00 pm

Do you have any plugins installed.
[size=117][i][b]Tony Roman[/b][/i][/size]
[size=84][i]Experience is what causes a person to make new mistakes instead of old ones.[/i][/size]
[size=84][i]There are only 3 way to complete a project: Good, Fast or Cheap, pick two.[/i][/size]
[size=84][i]With age comes wisdom, what you choose to do with it determines whether or not you are wise.[/i][/size]

carrison
Posts: 30
Joined: Fri Oct 14, 2005 2:26 am

#9 Post by carrison » Mon Nov 28, 2005 7:40 pm

PHP 5.0.5 (cli) (built: Oct 12 2005 13:48:53)
Copyright (c) 1997-2004 The PHP Group
Zend Engine v2.0.5, Copyright (c) 1998-2004 Zend Technologies


apply these patches...
wget http://www.cacti.net/downloads/patches/ ... rror.patch
wget http://www.cacti.net/downloads/patches/ ... zoom.patch
wget http://www.cacti.net/downloads/patches/ ... auth.patch
wget http://www.cacti.net/downloads/patches/ ... ding.patch
patch -p1 -N < short_open_tag_parse_error.patch
patch -p1 -N < graph_properties_zoom.patch
patch -p1 -N < script_server_snmp_auth.patch
patch -p1 -N < mib_file_loading.patch

and installed threshold plugins

carrison
Posts: 30
Joined: Fri Oct 14, 2005 2:26 am

#10 Post by carrison » Mon Nov 28, 2005 7:43 pm

and cactid :lol:

carrison
Posts: 30
Joined: Fri Oct 14, 2005 2:26 am

#11 Post by carrison » Mon Nov 28, 2005 8:02 pm

error snapshot
Attachments
pic1.jpg
pic1.jpg (113.03 KiB) Viewed 53996 times
pic2.jpg
pic2.jpg (101.34 KiB) Viewed 53996 times

User avatar
TheWitness
Developer
Posts: 14817
Joined: Tue May 14, 2002 5:08 pm
Location: MI, USA
Contact:

#12 Post by TheWitness » Mon Nov 28, 2005 8:03 pm

Click the Cactus and post your Cacti version, then if you XML file is not attached, please attach.

TheWitness
True understanding begins only when we realize how little we truly understand...

Life is an adventure, let yours begin with Cacti!

Author of MacTrack, Boost, CLog, SpikeKill, Platform RTM, DSStats, maintainer of Spine, lot's of unpublished work and most of Cacti's bugs.
_________________
Official Cacti Documentation
GitHub Repository with Supported Plugins
Central Plugin Repository
Central Templates Repository


I'm still out there people. Getting excited for Cacti 1.2. I think it will be a great release.

User avatar
TheWitness
Developer
Posts: 14817
Joined: Tue May 14, 2002 5:08 pm
Location: MI, USA
Contact:

#13 Post by TheWitness » Mon Nov 28, 2005 8:05 pm

Also, seems to me that there was an issue with THold some time ago, where Cigamit was not updating the hash array in config_arrays.php. Compare you Cacti versions array in that file with the SVN version.

TheWitness
True understanding begins only when we realize how little we truly understand...

Life is an adventure, let yours begin with Cacti!

Author of MacTrack, Boost, CLog, SpikeKill, Platform RTM, DSStats, maintainer of Spine, lot's of unpublished work and most of Cacti's bugs.
_________________
Official Cacti Documentation
GitHub Repository with Supported Plugins
Central Plugin Repository
Central Templates Repository


I'm still out there people. Getting excited for Cacti 1.2. I think it will be a great release.

User avatar
rony
Developer/Forum Admin
Posts: 6016
Joined: Mon Nov 17, 2003 6:35 pm
Location: Michigan, USA
Contact:

#14 Post by rony » Mon Nov 28, 2005 8:05 pm

In the include/config_arrays.php there is an array called hash_version_codes , make sure this array is the array from the version of cacti you have installed and not the thold plugin.
[size=117][i][b]Tony Roman[/b][/i][/size]
[size=84][i]Experience is what causes a person to make new mistakes instead of old ones.[/i][/size]
[size=84][i]There are only 3 way to complete a project: Good, Fast or Cheap, pick two.[/i][/size]
[size=84][i]With age comes wisdom, what you choose to do with it determines whether or not you are wise.[/i][/size]

User avatar
TheWitness
Developer
Posts: 14817
Joined: Tue May 14, 2002 5:08 pm
Location: MI, USA
Contact:

#15 Post by TheWitness » Mon Nov 28, 2005 8:06 pm

Should be:

$hash_version_codes = array(
"0.8.4" => "0000",
"0.8.5" => "0001",
"0.8.5a" => "0002",
"0.8.6" => "0003",
"0.8.6a" => "0004",
"0.8.6b" => "0005",
"0.8.6c" => "0006",
"0.8.6d" => "0007",
"0.8.6e" => "0008",
"0.8.6f" => "0009",
"0.8.6g" => "0010"
);

TheWitness
True understanding begins only when we realize how little we truly understand...

Life is an adventure, let yours begin with Cacti!

Author of MacTrack, Boost, CLog, SpikeKill, Platform RTM, DSStats, maintainer of Spine, lot's of unpublished work and most of Cacti's bugs.
_________________
Official Cacti Documentation
GitHub Repository with Supported Plugins
Central Plugin Repository
Central Templates Repository


I'm still out there people. Getting excited for Cacti 1.2. I think it will be a great release.

Post Reply