Unable to login to fresh installation of cacti

Post general support questions here that do not specifically fall into the Linux or Windows categories.

Moderators: Moderators, Developers

Post Reply
Author
Message
Dan
Posts: 10
Joined: Fri Dec 28, 2001 7:00 pm

#1 Post by Dan » Sun Dec 30, 2001 12:03 am

Hi,

I installed cacti this evening and all went well until I tried to login... This is what I get...

Warning: Cannot add header information - headers already sent by (output started at /var/www/html/cacti/include/config.php:73) in /var/www/html/cacti/auth/include/login.php on line 68

Warning: Cannot add header information - headers already sent by (output started at /var/www/html/cacti/include/config.php:73) in /var/www/html/cacti/auth/include/login.php on line 74

I've looked at login.php, and these lines are where it's trying to (on 68) set a cookie and (on 74) redirect back to the referring page... I've tried to look at line 73 in the config.php, but it's only 72 lines long... I tried removing the cache control header settings at the top of auth.php incase there was a problem with them having been set, and this made no difference...

I'm stuck with this...

I'm using PHP 4.1.0 if that makes any difference on RedHat 7.1...

If anyone has any idea where I should look next it would be much appreciated...

Thanks

Dan

Dan
Posts: 10
Joined: Fri Dec 28, 2001 7:00 pm

#2 Post by Dan » Sun Dec 30, 2001 12:20 am

Ohh, and using 0.6.2 of cacti, should have said that in the previous post, d'oh...

Dan
Posts: 10
Joined: Fri Dec 28, 2001 7:00 pm

#3 Post by Dan » Sun Dec 30, 2001 12:31 am

After all that, I've fixed it...

The problem was config.php...

I'd edited in with emacs, and having paged down to the end it had added a couple of lines white space after the ?>... removed them... and it works!

Argh!

Thanks for looking anyway :smile:

Dan

raX
Lead Developer
Posts: 2237
Joined: Sat Oct 13, 2001 7:00 pm
Location: Carlisle, PA
Contact:

#4 Post by raX » Sun Dec 30, 2001 3:14 pm

Glad to hear it is working now. Sorry about the lack of responce, I was out of town for the weekend. Feel free to post anymore problems you may have.

-Ian

Post Reply