Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Mon Aug 20, 2018 10:59 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 54 posts ]  Go to page 1, 2, 3, 4  Next
Author Message
 Post subject: ERROR:the RRD does not contain an RRA matching the chosen CF
PostPosted: Mon Apr 05, 2004 11:53 am 
Offline

Joined: Tue Dec 02, 2003 11:07 am
Posts: 11
Anyone get this before? This is the error message from the graph debug. What is a CF?

thx

rt


Top
 Profile  
 
 Post subject: me too
PostPosted: Sat Apr 10, 2004 1:54 am 
Offline
Cacti User

Joined: Mon Oct 06, 2003 5:40 pm
Posts: 132
Location: Stanford, CA
Just installed 0.8.5a upgrade - getting these now

RRDTool Says:

ERROR: the RRD does not contain an RRA matching the chosen CF


instead of the parse errors from 0.8.5


Top
 Profile  
 
 Post subject: FIXED
PostPosted: Sat Apr 10, 2004 3:14 am 
Offline
Cacti User

Joined: Mon Oct 06, 2003 5:40 pm
Posts: 132
Location: Stanford, CA
CF is a consolidation function.

I remembered I had chosen LAST for my graph template instead of the default Average.

Change the lasts to averages and resaved the template.
Deleted the old graphs, created new ones - golden


Top
 Profile  
 
 Post subject: Thank you!
PostPosted: Sat Dec 22, 2007 7:03 am 
Offline

Joined: Sat Dec 22, 2007 7:01 am
Posts: 1
Hi,

Just stumbled across this through Google and I can confirm I was using a consolidation function of 'Last' in my graph; changed this to 'Average' and all working ok.

Many thanks!

Jon


Top
 Profile  
 
 Post subject:
PostPosted: Sat Dec 22, 2007 4:12 pm 
Offline
Cacti Moderator
User avatar

Joined: Sat May 08, 2004 12:44 pm
Posts: 12150
Location: USA
There is a fix for cacti 0.8.7a in the announcement forum; you need an updated functions.php.

_________________

| Scripts: Monitor processes | RFC1213 MIB | DOCSIS Stats | Dell PowerEdge | Speedfan | APC UPS | DOCSIS CMTS | 3ware | Motorola Canopy |
| Guides: Windows Install | [HOWTO] Debug Windows NTFS permission problems |
| Tools: Windows All-in-one Installer |


Top
 Profile  
 
 Post subject:
PostPosted: Thu Jan 10, 2008 1:25 pm 
Offline

Joined: Mon Aug 09, 2004 8:51 am
Posts: 13
The updated functions.php did not get rid of this problem. I can still fix it by changing LAST to AVERAGE, but my graph doesn't look the way that I want it.


Top
 Profile  
 
 Post subject:
PostPosted: Thu Jan 10, 2008 1:49 pm 
Offline

Joined: Wed May 02, 2007 9:11 am
Posts: 42
Have you confirmed that LAST is selected in the defined RRA?


Top
 Profile  
 
 Post subject:
PostPosted: Thu Jan 10, 2008 4:48 pm 
Offline

Joined: Mon Jan 24, 2005 6:36 pm
Posts: 10
I suffer the same problem and the posted fix doesn't help. See my post here (which should answer otisbrown's question): http://forums.cacti.net/viewtopic.php?p=122040#122040

_________________
Cacti 0.8.7a|Spine 0.8.7a|RRDTool 1.2.26 (win32)|MySQL 5.0.45 (x64)|Net-SNMP 5.4.1-3 (win32)|PHP 5.2.5|Windows Server 2003 SE x64


Top
 Profile  
 
 Post subject:
PostPosted: Thu Jan 10, 2008 5:46 pm 
Offline

Joined: Wed May 02, 2007 9:11 am
Posts: 42
I ran into the same issue as the OP and this is what I found. If the RRA that is used by the data template that is used by the graph template does not have LAST selected as the consolidation function, when you modify your graph template to use LAST as the consolidation function your graph will not draw. After you make the change to the RRA I believe you will have to recreate the graphs, so the new RRA is generated.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Jan 14, 2008 11:30 am 
Offline
Developer
User avatar

Joined: Thu Dec 02, 2004 2:46 am
Posts: 22461
Location: Muenster, Germany
Not REALLY REALLY sure, but quite:
I suppose that this drawback only hold, if you are using the LAST CF for a graph element as LINEx, AREA or STACK. It should not matter on a GPRINT.
To be honest, Up to now, personally I did not find any use of the LAST CF on a LINE. If anyone could please tell me, where this is required? Then I would like to add this as an example to the docs.cacti.net site.
Reinhard

_________________
Official Cacti Documentation
Official Debugging Help
Central Plugin Repository
Central Templates Repository


Top
 Profile  
 
 Post subject:
PostPosted: Sat Feb 02, 2008 10:53 am 
Offline

Joined: Sun Nov 04, 2007 8:19 am
Posts: 21
Hi,

I had the same problem with some of my graphs when upgrading cacti from 0.8.6 to 0.8.7.a (I have also updated rrdtool to 1.2.26) - I was sure nothing was wrong with graph templates, and as I could not find any other solution I just deleted the problematic .rrd files ... and than the error dissapeard (and also the hystory from deleted .rrd files ... :( ).


Top
 Profile  
 
 Post subject:
PostPosted: Sat Feb 02, 2008 12:49 pm 
Offline
Developer
User avatar

Joined: Thu Dec 02, 2004 2:46 am
Posts: 22461
Location: Muenster, Germany
This one should be fixed by now. Will be published with next bugfix release.
Reinhard

_________________
Official Cacti Documentation
Official Debugging Help
Central Plugin Repository
Central Templates Repository


Top
 Profile  
 
 Post subject:
PostPosted: Wed Feb 20, 2008 9:29 pm 
Offline
Cacti User

Joined: Thu May 12, 2005 7:26 pm
Posts: 53
gandalf wrote:
This one should be fixed by now. Will be published with next bugfix release.
Reinhard


what release is the fix incorporated into? i have just rolled out a new box running cacti 0.8.7b & rrdtool 1.2.23 with the updated functions.php and am hitting this error when attempting to use LAST in a graph. i have blown away the graph and associated files and started from scratch to no avail.

ideas?


Top
 Profile  
 
 Post subject:
PostPosted: Thu Feb 21, 2008 3:51 pm 
Offline
Developer
User avatar

Joined: Thu Dec 02, 2004 2:46 am
Posts: 22461
Location: Muenster, Germany
There are currently two different answers to the same problem. Some users have their problems fixed, some don't. I hope to work at least with one user to get it solved. Please post the whole failing rrdtool graph statement and rrdtool info for the rrd file used to help me debug it
Reinhard

_________________
Official Cacti Documentation
Official Debugging Help
Central Plugin Repository
Central Templates Repository


Top
 Profile  
 
 Post subject:
PostPosted: Thu Feb 21, 2008 4:52 pm 
Offline
Cacti User

Joined: Sun Feb 01, 2004 3:10 am
Posts: 54
Location: Orlando, FL
Reinhard,

Here's an example for you:

Code:
Data Source Debug

/usr/bin/rrdtool create \
/var/www/localhost/htdocs/cacti/rra/maitland_fl_dewpoint_30.rrd \
--step 300  \
DS:DewPoint:GAUGE:600:-200:200 \
DS:Pressure:GAUGE:600:0:1000 \
DS:Temp:GAUGE:600:-200:200 \
DS:Rain:GAUGE:600:0:500 \
DS:WindSpeed:GAUGE:600:0:1000 \
DS:Humidity:GAUGE:600:0:100 \
DS:FeelsLike:GAUGE:600:-200:200 \
DS:Tries:GAUGE:600:0:100 \
RRA:AVERAGE:0.5:1:600 \
RRA:AVERAGE:0.5:6:700 \
RRA:AVERAGE:0.5:24:775 \
RRA:AVERAGE:0.5:288:797 \
RRA:MAX:0.5:1:600 \
RRA:MAX:0.5:6:700 \
RRA:MAX:0.5:24:775 \
RRA:MAX:0.5:288:797 \


Graph Debug
Code:
RRDTool Command:

/usr/bin/rrdtool graph - \
--imgformat=PNG \
--start=-86400 \
--end=-300 \
--title="Maitland, FL - Humidity" \
--rigid \
--base=1000 \
--height=120 \
--width=500 \
--upper-limit=100 \
--lower-limit=0 \
--vertical-label="%" \
--slope-mode \
--font TITLE:12: \
--font AXIS:8: \
--font LEGEND:10: \
--font UNIT:8: \
DEF:a="/var/www/localhost/htdocs/cacti/rra/maitland_fl_dewpoint_30.rrd":Humidity:LAST \
DEF:b="/var/www/localhost/htdocs/cacti/rra/maitland_fl_dewpoint_30.rrd":Humidity:MAX \
AREA:a#157419FF:"Humidity\n"  \
GPRINT:a:LAST:"Current\:%8.2lf %s"  \
GPRINT:b:MIN:"Minimum\:%8.2lf %s"  \
GPRINT:b:AVERAGE:"Average\:%8.2lf %s"  \
GPRINT:b:MAX:"Maximum\:%8.2lf %s\n"

RRDTool Says:

ERROR: the RRD does not contain an RRA matching the chosen CF


Attachments:
File comment: WeatherBug wind graph template export.
cacti_graph_template_weatherbug_-_wind.xml [16.11 KiB]
Downloaded 2297 times
File comment: RRD file info.
maitland_fl_dewpoint_30.rrd.info.txt [8.01 KiB]
Downloaded 2154 times
Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 54 posts ]  Go to page 1, 2, 3, 4  Next

All times are UTC - 5 hours


Who is online

Users browsing this forum: Google Adsense [Bot] and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group