PIA Version - 0.8.7F ?

Post general support questions here that do not specifically fall into the Linux or Windows categories.

Moderators: Moderators, Developers

Author
Message
mcutting
Cacti Guru User
Posts: 1874
Joined: Mon Oct 16, 2006 5:57 am
Location: United Kingdom
Contact:

PIA Version - 0.8.7F ?

#1 Post by mcutting » Thu May 20, 2010 6:21 am

Can we use PIA 2.6 for Cacti 0.8.7f, or is there likely to be a 2.7 of the PIA surfacing ?

Thanks
Cacti Version 0.8.8b
Cacti OS Ubuntu LTS
RRDTool Version RRDTool 1.4.7
Poller Information
Type SPINE 0.8.8b

User avatar
Sirup
Cacti Moderator
Posts: 348
Joined: Tue Mar 02, 2010 9:03 am

#2 Post by Sirup » Thu May 20, 2010 6:25 am

2.6 is the latest version. As there is no other information I assume it's ok to use 2.6 with 0.8.7f.
I also assume there won't be a PIA 2.7, because in cacti 0.8.8 the PIA will be included in cacti.
Development Road Map:
Inclusion of Plugin Architecture
[size=67]Cacti version: 0.8.7e5
OS: FreeBSD 7.2
Plugin Architecture: 2.6
Plugins: aggregate 0.74, autom8 0.33, loginmod 1.0

[url=http://docs.cacti.net/manual:087]Official Cacti Documentation[/url]
[url=http://docs.cacti.net/manual:087:4_help.2_debugging#debugging]Gandalfs Official Debugging Help[/url]
[/size]

mcutting
Cacti Guru User
Posts: 1874
Joined: Mon Oct 16, 2006 5:57 am
Location: United Kingdom
Contact:

#3 Post by mcutting » Thu May 20, 2010 6:27 am

Sirup wrote:2.6 is the latest version. As there is no other information I assume it's ok to use 2.6 with 0.8.7f.
I also assume there won't be a PIA 2.7, because in cacti 0.8.8 the PIA will be included in cacti.
Development Road Map:
Inclusion of Plugin Architecture
Not sure about this. Historically, each time a newer version of Cacti has been released, a newer PIA is also released.
Cacti Version 0.8.8b
Cacti OS Ubuntu LTS
RRDTool Version RRDTool 1.4.7
Poller Information
Type SPINE 0.8.8b

User avatar
Sirup
Cacti Moderator
Posts: 348
Joined: Tue Mar 02, 2010 9:03 am

#4 Post by Sirup » Thu May 20, 2010 6:30 am

I'll try on my testsystem 0.87f together with pia2.6
[size=67]Cacti version: 0.8.7e5
OS: FreeBSD 7.2
Plugin Architecture: 2.6
Plugins: aggregate 0.74, autom8 0.33, loginmod 1.0

[url=http://docs.cacti.net/manual:087]Official Cacti Documentation[/url]
[url=http://docs.cacti.net/manual:087:4_help.2_debugging#debugging]Gandalfs Official Debugging Help[/url]
[/size]

mcutting
Cacti Guru User
Posts: 1874
Joined: Mon Oct 16, 2006 5:57 am
Location: United Kingdom
Contact:

#5 Post by mcutting » Thu May 20, 2010 6:39 am

Seems to work ok, but for example, lib/html_form.php version 0.8.7f contains much more code than 0.8.7e PIA version.
Cacti Version 0.8.8b
Cacti OS Ubuntu LTS
RRDTool Version RRDTool 1.4.7
Poller Information
Type SPINE 0.8.8b

User avatar
Sirup
Cacti Moderator
Posts: 348
Joined: Tue Mar 02, 2010 9:03 am

#6 Post by Sirup » Thu May 20, 2010 6:42 am

Here is some information from larry: http://forums.cacti.net/viewtopic.php?t=37679
[size=67]Cacti version: 0.8.7e5
OS: FreeBSD 7.2
Plugin Architecture: 2.6
Plugins: aggregate 0.74, autom8 0.33, loginmod 1.0

[url=http://docs.cacti.net/manual:087]Official Cacti Documentation[/url]
[url=http://docs.cacti.net/manual:087:4_help.2_debugging#debugging]Gandalfs Official Debugging Help[/url]
[/size]

mcutting
Cacti Guru User
Posts: 1874
Joined: Mon Oct 16, 2006 5:57 am
Location: United Kingdom
Contact:

#7 Post by mcutting » Thu May 20, 2010 6:49 am

Thanks - already seen this.

Don't have any issues with the plugins, but the PIA level does not seem to be correct.
Cacti Version 0.8.8b
Cacti OS Ubuntu LTS
RRDTool Version RRDTool 1.4.7
Poller Information
Type SPINE 0.8.8b

mcutting
Cacti Guru User
Posts: 1874
Joined: Mon Oct 16, 2006 5:57 am
Location: United Kingdom
Contact:

#8 Post by mcutting » Thu May 20, 2010 6:51 am

Cacti Version 0.8.8b
Cacti OS Ubuntu LTS
RRDTool Version RRDTool 1.4.7
Poller Information
Type SPINE 0.8.8b

User avatar
Sirup
Cacti Moderator
Posts: 348
Joined: Tue Mar 02, 2010 9:03 am

#9 Post by Sirup » Thu May 20, 2010 7:48 am

You were right:
rony wrote:Do not upgrade until the PIA for 0.8.7f is released. This should be today or tomorrow.
[size=67]Cacti version: 0.8.7e5
OS: FreeBSD 7.2
Plugin Architecture: 2.6
Plugins: aggregate 0.74, autom8 0.33, loginmod 1.0

[url=http://docs.cacti.net/manual:087]Official Cacti Documentation[/url]
[url=http://docs.cacti.net/manual:087:4_help.2_debugging#debugging]Gandalfs Official Debugging Help[/url]
[/size]

User avatar
Hyperlord
Cacti User
Posts: 209
Joined: Tue Feb 10, 2009 3:24 am
Location: Frankfurt (a.M.), Germany
Contact:

#10 Post by Hyperlord » Thu May 20, 2010 7:58 am

Hehe yeah I don't know if I'm able to relax for that long. Very cool new features.
I'm a bit redundant. I repeat myself too ...

mcutting
Cacti Guru User
Posts: 1874
Joined: Mon Oct 16, 2006 5:57 am
Location: United Kingdom
Contact:

#11 Post by mcutting » Thu May 20, 2010 8:07 am

I can wait :)
Cacti Version 0.8.8b
Cacti OS Ubuntu LTS
RRDTool Version RRDTool 1.4.7
Poller Information
Type SPINE 0.8.8b

User avatar
TheWitness
Developer
Posts: 14834
Joined: Tue May 14, 2002 5:08 pm
Location: MI, USA
Contact:

#12 Post by TheWitness » Thu May 20, 2010 12:15 pm

They are not compatible. Sorry, we missed this on the Announcement. You have to wait on PIA 2.7. We are just doing a bit of additional QA. Jimmy will have to provide a thumbs up before it's released.

Also, please note, that if you are using Boost, you have to upgrade to 4.0 before, upgrading Cacti and the PIA.

TheWitness
True understanding begins only when we realize how little we truly understand...

Life is an adventure, let yours begin with Cacti!

Author of MacTrack, Boost, CLog, SpikeKill, Platform RTM, DSStats, maintainer of Spine, lot's of unpublished work and most of Cacti's bugs.
_________________
Official Cacti Documentation
GitHub Repository with Supported Plugins
Central Plugin Repository
Central Templates Repository


I'm still out there people. Getting excited for Cacti 1.2. I think it will be a great release.

mcutting
Cacti Guru User
Posts: 1874
Joined: Mon Oct 16, 2006 5:57 am
Location: United Kingdom
Contact:

#13 Post by mcutting » Thu May 20, 2010 2:56 pm

Any ideas as to when this will be released ?

Thanks
Cacti Version 0.8.8b
Cacti OS Ubuntu LTS
RRDTool Version RRDTool 1.4.7
Poller Information
Type SPINE 0.8.8b

cigamit
Developer
Posts: 2790
Joined: Thu Apr 07, 2005 3:29 pm
Location: B/CS Texas
Contact:

#14 Post by cigamit » Thu May 20, 2010 3:17 pm

I just have released 2.7 that is Cacti 0.8.7f compatible. I should seriously think about just changes the version numbers to match the cacti version instead I guess.

mcutting
Cacti Guru User
Posts: 1874
Joined: Mon Oct 16, 2006 5:57 am
Location: United Kingdom
Contact:

#15 Post by mcutting » Thu May 20, 2010 3:23 pm

Thanks Jimmy
Cacti Version 0.8.8b
Cacti OS Ubuntu LTS
RRDTool Version RRDTool 1.4.7
Poller Information
Type SPINE 0.8.8b

Post Reply