There are no items in your poller for this polling cycle

Post general support questions here that do not specifically fall into the Linux or Windows categories.

Moderators: Moderators, Developers

Post Reply
Author
Message
moggie
Posts: 11
Joined: Sat Jul 31, 2010 9:38 am

There are no items in your poller for this polling cycle

#1 Post by moggie » Sat Jul 31, 2010 10:47 am

Greetings,

I updated to cacti 0.8.7g today and tweaked a few template names and stuff (nothing I thought drastic), but sadly cacti seems to have stopped updating the graphs with recent data.

It's as though graphs are being drawn to show the passage of time, but current traffic is not being shown.

The log says there are no items in the current polling cycle, but nothing else seems broken. An extract should be available for a short time here:

http://pastebin.com/qHa72Qsn

I asked it to rebuild the poller cache from the utilities option, but that doesn't seem to have solved it.

If I select the graphs and ask cacti to "reapply suggested names", again, nothing :(

On a couple of the graphs I can see what looks like data a being graphed for just a few instances, but I can't be sure.

If I delete the graph and data source and then re-create them, the traffic is still missing.

Any help or advice would be greatly appreciated. Thank you in advance for your time and consideration.

Kind regards,
moggie

moggie
Posts: 11
Joined: Sat Jul 31, 2010 9:38 am

Empty poller cycle, plus exceeds max runtime

#2 Post by moggie » Sat Jul 31, 2010 4:23 pm

Not sure if it helps, but the problem I seem to be having appears similar to the one described here:

http://bugs.cacti.net/view.php?id=1815

User avatar
gandalf
Developer
Posts: 22375
Joined: Thu Dec 02, 2004 2:46 am
Location: Muenster, Germany
Contact:

#3 Post by gandalf » Mon Aug 02, 2010 12:24 pm

Are you using PIA? Did you apply requied changes to include/config.php?
R.

moggie
Posts: 11
Joined: Sat Jul 31, 2010 9:38 am

#4 Post by moggie » Tue Aug 03, 2010 10:44 am

Sorry, I'm not sure what PIA means? I must have missed it in the docs I've read thus far.

I set both our cron and poller interval to one minute as a temporary fix.

However, our cron normally runs every 5 minutes and our poller every 30 seconds (to match the settings our providers use); so the graphs and data we are currently generating are not as accurate as normal. Less accurate graphs are much more preferable to no graphs at all though :)

moggie
Posts: 11
Joined: Sat Jul 31, 2010 9:38 am

#5 Post by moggie » Tue Aug 03, 2010 10:59 am

Ahh I've just been informed that PIA means plug-in architecture. We don't use any plugins at the moment so our cacti is just the vanilla version. Thanks again, M.

Post Reply