Errors during upgrade from 0.8.5a to 0.8.6

Post general support questions here that do not specifically fall into the Linux or Windows categories.

Moderators: Moderators, Developers

Post Reply
Author
Message
paddy
Posts: 14
Joined: Thu Jul 15, 2004 9:34 am
Location: Stockholm, Sweden

Errors during upgrade from 0.8.5a to 0.8.6

#1 Post by paddy » Mon Sep 13, 2004 12:57 pm

Hi!

Very nice upgrade!
Alot of nice feature which I'm just drooling over!

BUT.. as always...
During upgrade I received the following when it were about to upgrade the database:
Warning: Variable passed to each() is not an array or object in /usr/local/share/cacti/lib/data_query.php on line 465
Warning: Variable passed to each() is not an array or object in /usr/local/share/cacti/lib/data_query.php on line 465
Warning: Variable passed to each() is not an array or object in /usr/local/share/cacti/lib/data_query.php on line 465
Warning: Variable passed to each() is not an array or object in /usr/local/share/cacti/lib/data_query.php on line 465
Warning: Variable passed to each() is not an array or object in /usr/local/share/cacti/lib/data_query.php on line 465
Warning: Variable passed to each() is not an array or object in /usr/local/share/cacti/lib/data_query.php on line 465
altho the upgrade went without hassle after this.. it might be something that needs correcting.. so I thought I'd let you know.

I'm using a FreeBSD 5.2.1-RELEASE-p9 with Apache 2.0.50 and PHP 4.3.8 installed from ports. MySQL server 4.0.20 also installed from ports.

I've also noticed that you remove the date/time selector when you zoom in on the graph.. why? I'd really like to have it even when I zoom in :)

The time selection once zoomed in all the way into a graph doesnt work in Firefox 0.9.3 for Windows .. might be browser error.. dunno.

I'm also receiving alot of
WARNING: Result from SNMP not valid. Partial Result:
which is pretty wierd hense I didnt have any errors at-all before the upgrade.. doesnt matter as the graphs work anyways but.. still wierd.

Well.. thanks alot for a very very nice upgrade!
Keep up the good work! :)

Best Regards,
Paddy

User avatar
TheWitness
Developer
Posts: 14851
Joined: Tue May 14, 2002 5:08 pm
Location: MI, USA
Contact:

#2 Post by TheWitness » Mon Sep 13, 2004 1:21 pm

The invalid results are likely because a certain MIB is not supported on your device. Turn logging to DEBUG for 1 interval and scan your results. You will also have to use a MIB poller to determine the problematic MIB's. It could also be a timeout issue with the device.

I do agree that they are annoying though.

TheWitness
True understanding begins only when we realize how little we truly understand...

Life is an adventure, let yours begin with Cacti!

Author of MacTrack, Boost, CLog, SpikeKill, Platform RTM, DSStats, maintainer of Spine, lot's of unpublished work and most of Cacti's bugs.
_________________
Official Cacti Documentation
GitHub Repository with Supported Plugins
Central Plugin Repository
Central Templates Repository


I'm still out there people. Getting excited for Cacti 1.2. I think it will be a great release.

raX
Lead Developer
Posts: 2237
Joined: Sat Oct 13, 2001 7:00 pm
Location: Carlisle, PA
Contact:

#3 Post by raX » Mon Sep 13, 2004 7:53 pm

I appreciate the positive things you've had to say about this release even though you seem to have run over a few bumps. The errors that you received during the upgrade do not appear to be critical as you had suspected. My guess is that you have a data query or two under "Data Queries" that does not have a valid XML file specified.

The graph zoom UI underwent a lot of change during development based on user feedback. I want to get a feel for what users think before changing anything in this area.

-Ian

Post Reply