Upgraded to 0.8.8b from Epel - Tree no longer collapses

Post general support questions here that do not specifically fall into the Linux or Windows categories.

Moderators: Moderators, Developers

Post Reply
Author
Message
accessnetops
Posts: 2
Joined: Wed Sep 04, 2013 11:55 am

Upgraded to 0.8.8b from Epel - Tree no longer collapses

#1 Post by accessnetops » Wed Sep 04, 2013 12:29 pm

Hello,

Recently upgraded to 0.8.8b. Ran into the thumbnail view bug. Luckily a patch was released for that. Only one problem remains. The tree no longer collapses in graph view mode. Just one big list. The hierarchy still exists. Just no plus or minus boxes anymore.

paulgevers
Cacti Pro User
Posts: 595
Joined: Tue Aug 29, 2006 4:09 pm
Location: NL

Re: Upgraded to 0.8.8b from Epel - Tree no longer collapses

#2 Post by paulgevers » Wed Sep 04, 2013 1:47 pm

I don't know EPEL, but maybe they started using my treeview updates. If that is true, you might need additional javascript packages. jquery and jquery-cookie (at least they are called something like that in Debian).
Maintainer of cacti in Debian (and Ubuntu).
Cacti 1.* is now officially supported on Debian Stretch via Debian backports
FAQ Ubuntu and Debian differences
Generic cacti debugging

accessnetops
Posts: 2
Joined: Wed Sep 04, 2013 11:55 am

Re: Upgraded to 0.8.8b from Epel - Tree no longer collapses

#3 Post by accessnetops » Wed Sep 04, 2013 2:10 pm

Yes, I have found lots of problems on Debian systems with the fix you just described. I don't know what the equivalents would be for me. I also have a whole bunch of jquery stuff, including jquery.js and jquery.cookies.js located in /usr/share/cacti/include/js/jquery/ without doing anything more than upgrading Cacti.

paulgevers
Cacti Pro User
Posts: 595
Joined: Tue Aug 29, 2006 4:09 pm
Location: NL

Re: Upgraded to 0.8.8b from Epel - Tree no longer collapses

#4 Post by paulgevers » Wed Sep 04, 2013 2:18 pm

accessnetops wrote:I also have a whole bunch of jquery stuff, including jquery.js and jquery.cookies.js located in /usr/share/cacti/include/js/jquery/ without doing anything more than upgrading Cacti.
So the EPEL maintainers decided to include those javascript things in the cacti package. The question now is if they get properly called. I suggest you file a bug at EPEL that their package does not work for you and ask for help there. I don't know the EPEL package so I am limited in the possibility to help. Could you provide a screen shot? And maybe find the part of the html page source that mentions the javascript in the page that is not working. And a good thing to check is if you have javascript enabled in your browser.
Maintainer of cacti in Debian (and Ubuntu).
Cacti 1.* is now officially supported on Debian Stretch via Debian backports
FAQ Ubuntu and Debian differences
Generic cacti debugging

vishnubraj
Posts: 23
Joined: Thu Aug 08, 2013 6:37 am

Re: Upgraded to 0.8.8b from Epel - Tree no longer collapses

#5 Post by vishnubraj » Fri Dec 06, 2013 11:55 am

Is there any solution for it?? I am running cacti on a Centos machine and getting the same issue.

paulgevers
Cacti Pro User
Posts: 595
Joined: Tue Aug 29, 2006 4:09 pm
Location: NL

Re: Upgraded to 0.8.8b from Epel - Tree no longer collapses

#6 Post by paulgevers » Fri Dec 06, 2013 12:06 pm

vishnubraj wrote:Is there any solution for it??
It might help if I get answers to the questions I raised.
Maintainer of cacti in Debian (and Ubuntu).
Cacti 1.* is now officially supported on Debian Stretch via Debian backports
FAQ Ubuntu and Debian differences
Generic cacti debugging

vishnubraj
Posts: 23
Joined: Thu Aug 08, 2013 6:37 am

Re: Upgraded to 0.8.8b from Epel - Tree no longer collapses

#7 Post by vishnubraj » Fri Dec 06, 2013 1:29 pm

Capture.JPG
Capture.JPG (8.95 KiB) Viewed 2629 times
[23:54:49.831] TypeError: $(...).jstree is not a function @ http://X.X.X.X/cacti/graph_view.php?act ... 19247:1124

paulgevers, above is the error i get and i have attaced the screen shot also.

vishnubraj
Posts: 23
Joined: Thu Aug 08, 2013 6:37 am

Re: Upgraded to 0.8.8b from Epel - Tree no longer collapses

#8 Post by vishnubraj » Fri Dec 06, 2013 1:43 pm

I found the issue. this happens when i enable reportit plugin on my cacti. when i enable the reportit plugin the last line get added to the graph_view.php file and the tree no longer collapses. I have disabled the reportit plugin now... (But reportit plugin is a very must plugin we need to find out a solution to enable it again).

<script type="text/javascript" src="/cacti/include/layout.js"></script>
<script type="text/javascript" src="/cacti/include/js/jquery/jquery.js" language="javascript"></script>
<script type="text/javascript" src="/cacti/include/js/jquery/jquery.cookie.js" language="javascript"></script>
<script type="text/javascript" src="/cacti/include/js/jquery/jquery.jstree.js"></script>
<script type="text/javascript" src="/cacti/include/jscalendar/calendar.js"></script>
<script type="text/javascript" src="/cacti/include/jscalendar/lang/calendar-en.js"></script>
<script type="text/javascript" src="/cacti/include/jscalendar/calendar-setup.js"></script>
<script type="text/javascript" src="/cacti/plugins/reportit/lib_ext/jquery/jquery-1.4.2.min.js"></script>

paulgevers
Cacti Pro User
Posts: 595
Joined: Tue Aug 29, 2006 4:09 pm
Location: NL

Re: Upgraded to 0.8.8b from Epel - Tree no longer collapses

#9 Post by paulgevers » Sat Dec 07, 2013 2:13 am

Hmm, interesting. /cacti/include/js/jquery/jquery.js and /cacti/plugins/reportit/lib_ext/jquery/jquery-1.4.2.min.js are the same library, but maybe with different versions. I have no idea what happens if you declare a library twice. You could try to enable the plugin, but disable the last line. If that helps, you should try out to find which version of jquery is shipped with your cacti (we can't know because it does not come with the original version of cacti).

If we know the answer to the above questions, we can start to think in what direction lies a solution.
Maintainer of cacti in Debian (and Ubuntu).
Cacti 1.* is now officially supported on Debian Stretch via Debian backports
FAQ Ubuntu and Debian differences
Generic cacti debugging

vishnubraj
Posts: 23
Joined: Thu Aug 08, 2013 6:37 am

Re: Upgraded to 0.8.8b from Epel - Tree no longer collapses

#10 Post by vishnubraj » Wed Jan 22, 2014 2:38 am

I deleted the file jquery-1.4.2.min.js from /var/www/cacti/plugins/reportit/lib_ext/jquery and reenabled the reportit plugin. Now it works :)
Not sure why this is jquery file is used for.

tbilan
Posts: 15
Joined: Fri Sep 14, 2012 6:57 pm

Re: Upgraded to 0.8.8b from Epel - Tree no longer collapses

#11 Post by tbilan » Thu May 15, 2014 3:53 pm

I had the same problem but it was my superlinks plugin.

I edited /usr/share/cacti/plugins/superlinks/setup.php and commented out the jquery portion:
print "<script type='text/javascript' src='".$config['url_path'] ."/plugins/superlinks/jquery-latest.min.js'></script>";
to
// print "<script type='text/javascript' src='".$config['url_path'] ."/plugins/superlinks/jquery-latest.min.js'></script>";

Everything worked fine from there and my superlinks functionality still worked.

Post Reply