Legend alignment

Post general support questions here that do not specifically fall into the Linux or Windows categories.

Moderators: Moderators, Developers

Post Reply
Author
Message
moggie
Posts: 11
Joined: Sat Jul 31, 2010 9:38 am

Legend alignment

#1 Post by moggie » Fri Feb 26, 2016 8:00 am

Hi,

I believe a colleague added a device template that has somehow affected regular traffic graphs. I have tried to configure the template how it used to be but there alignment of graph legends is still off. I can't seem to figure out why and was hoping someone might be able to help please.

Thanks in advance!
Attachments
legend.png
legend.png (14.63 KiB) Viewed 663 times

User avatar
micke2k
Cacti User
Posts: 261
Joined: Wed Feb 03, 2016 3:38 pm

Re: Legend alignment

#2 Post by micke2k » Fri Feb 26, 2016 8:32 am

Compared to attached graph template, how does your look?
Attachments
graph.png
graph.png (53.57 KiB) Viewed 658 times

moggie
Posts: 11
Joined: Sat Jul 31, 2010 9:38 am

Re: Legend alignment

#3 Post by moggie » Fri Feb 26, 2016 8:34 am

Thank you very much for your help. The standard template I've tried to repair looks like the attached image.
Attachments
cacti-template.PNG
cacti-template.PNG (23.65 KiB) Viewed 657 times

User avatar
micke2k
Cacti User
Posts: 261
Joined: Wed Feb 03, 2016 3:38 pm

Re: Legend alignment

#4 Post by micke2k » Fri Feb 26, 2016 10:25 am

Actually checked CactiEZ and it has the same exact problem.

Maybe it was fixed in a later version fo cacti/rrdtool?

Its fixed in the latest release atleast.

What version are you running?
Attachments
graphworking.png
graphworking.png (69.76 KiB) Viewed 653 times

moggie
Posts: 11
Joined: Sat Jul 31, 2010 9:38 am

Re: Legend alignment

#5 Post by moggie » Fri Feb 26, 2016 10:49 am

I'm using cacti-0.8.8f_2

User avatar
micke2k
Cacti User
Posts: 261
Joined: Wed Feb 03, 2016 3:38 pm

Re: Legend alignment

#6 Post by micke2k » Fri Feb 26, 2016 10:51 am

What version of rrd tool?

Try adding the <hr> that is in the new version

moggie
Posts: 11
Joined: Sat Jul 31, 2010 9:38 am

Re: Legend alignment

#7 Post by moggie » Fri Feb 26, 2016 11:07 am

rrdtool version is: rrdtool-1.5.5_1

moggie
Posts: 11
Joined: Sat Jul 31, 2010 9:38 am

Re: Legend alignment

#8 Post by moggie » Fri Feb 26, 2016 11:09 am

Oh, wows! There was already a <HR> after the inbound maximum, but after I added a <HR> to the outbound maximum, it seems to have fixed it. I have no idea why, but thanks!

User avatar
micke2k
Cacti User
Posts: 261
Joined: Wed Feb 03, 2016 3:38 pm

Re: Legend alignment

#9 Post by micke2k » Fri Feb 26, 2016 12:01 pm

moggie wrote:Oh, wows! There was already a <HR> after the inbound maximum, but after I added a <HR> to the outbound maximum, it seems to have fixed it. I have no idea why, but thanks!
No problems, glad it worked :)

Post Reply