Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Tue Feb 19, 2019 8:47 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: Problem with Uptime graphs after upgrade to Cacti 1.2.0
PostPosted: Sun Jan 13, 2019 12:11 pm 
Offline
User avatar

Joined: Fri Sep 19, 2014 3:33 am
Posts: 21
Location: Sofia, Bulgaraia
Today, I've managed to find the time to upgrade my Cacti 1.1.37 installation to 1.2.0 and although I was prepared for the unexpected I had some strange problems.

I've done the upgrade as written in the upgrade guide. I only made one additional step to disable the poller job in cron during the process. I'm doing this, so to avoid errors from the scripts for not upgraded database, etc. I had problems with the upgrade (step 10), because the upgrade script wasn't able to complete in 60 seconds, so I increased to 300 in php.ini although the installer was suggesting 60 seconds is OK. I then had some directory permission issues, but these were easy to solve. After the upgrade passed successfully I enabled the poller job again and started investigating the log.

At first there were many RECACHE ASSERT FAILED 'timetics<DD:HH:MM:SS.00 and WARNING: Recache Event Detected for Device messages. I wonder whether stopping the poller job is the reason for these, because I see no other explanation. I wasn't able to find a solution online, so I "solved" the problem by truncating poller_reindex table. Why is this assert so important? If someone could explain this to me I would be grateful, because I noticed that the assert is blocking graphs from being updated.

Then, I had some issues from the re-caching due to some indexes value being changed (e.g. disk labels on some Windows hosts). Perhaps M$ could implement it better (e.g. disk serial number is quite enough as unique identifier of the device). Solved it by updating the index values in the data sources.

Finally (and what I'm still not able to solve), is that all Uptime graphs are not updated. The only messages that left in the log are many WARNING: Invalid Response(s). I enabled debug log level and got WARNING: Result from SNMP not valid. Partial Result: (487695100) 56 days, and WARNING: Result from SNMP not valid. Partial Result: U kind of messages. I only found the topic System uptime via hrSystemUptime with similar messages. I'm using Net-SNMP and querying .1.3.6.1.2.1.1.3.0 of devices works fine. For some reason Cacti doesn't accept the value and it's not written in the RRDs. What could be the reason for this problem?

Please, let me know what other information I have to provide if necessary.


Top
 Profile  
 
 Post subject: Re: Problem with Uptime graphs after upgrade to Cacti 1.2.0
PostPosted: Sun Jan 13, 2019 1:25 pm 
Offline
Cacti Pro User
User avatar

Joined: Mon Jan 05, 2015 10:10 am
Posts: 744
Sorry about that. Update lib/snmp.php from develop.

_________________
Before history, there was a paradise, now dust.


Top
 Profile  
 
 Post subject: Re: Problem with Uptime graphs after upgrade to Cacti 1.2.0
PostPosted: Mon Jan 14, 2019 3:55 pm 
Offline
User avatar

Joined: Fri Sep 19, 2014 3:33 am
Posts: 21
Location: Sofia, Bulgaraia
Thank you very much Osiris! Just downloading the latest version of lib/snmp.php from GitHub solved the problem with the Uptime graphs. And no more warnings in the logs. As I understand the "magic" is into commit 6f96ed1 by cigamit from two days ago to "Properly handle snmp timeouts" and "Additionally address value output format issues". I would not expect this to be a bug, but I'm happy its already solved and I hope it would be included into the next release of Cacti.


Top
 Profile  
 
 Post subject: Re: Problem with Uptime graphs after upgrade to Cacti 1.2.0
PostPosted: Mon Jan 14, 2019 6:47 pm 
Offline
Cacti Pro User
User avatar

Joined: Mon Jan 05, 2015 10:10 am
Posts: 744
It's all about PHP versions. The ground continues to move under our feet.

_________________
Before history, there was a paradise, now dust.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: Google [Bot] and 15 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group