Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Thu Apr 25, 2019 2:57 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: No access to Cacti after set "Force Connections over HTTPS"
PostPosted: Tue Jul 24, 2018 4:18 am 
Offline

Joined: Tue Jul 24, 2018 2:29 am
Posts: 1
Hello!
CentOS 7 x86_64, Cacti 1.1.38, RRDTool 1.7.0, MariaDB 10.3.8
Yesterday, in the configuration of Cacti, I marked the "Force Connections over HTTPS" checkbox (why I do it?..). After that, access to the web interface Cacti disappeared. When I typing the link in the browser {ip_address}/cacti, the link is automatically corrected to https://{ip_address}/cacti. I found the file named "global_settings.php" in the directory with Cacti installed and found the lines associated with the inclusion of this setting. Here is their content:
Quote:
'force_https' => array(
'friendly_name' => __('Force Connections over HTTPS'),
'description' => __('When checked, any attempts to access Cacti will be redirected to HTTPS to ensure high security.'),
'default' => '',
'method' => 'checkbox',
),

The "default" parameter is apparently empty. I looked through similar blocks in this file and tried to substitute the value 0 and off. Every time after changing this setting, I restarted the httpd.service. Unfortunately, there is no effect...
Tell me please, maybe something somewhere else needs to be changed?...
Thank You!


Top
 Profile  
 
 Post subject: Re: No access to Cacti after set "Force Connections over HTT
PostPosted: Tue Jul 24, 2018 10:45 am 
Offline
Cacti Guru User

Joined: Sun Aug 27, 2017 12:05 am
Posts: 2413
First, check the current status. If the field is blank or the row is missing entirely, this means that the setting is off:
Code:
select * from settings where name = 'force_https';


If you need to stop forcing HTTPS because you have not configured apache to use it, run one of the two following commands:

Code:
update settings set value = '' where name = 'force_https';

or
Code:
delete from settings where name = 'force_https';

_________________
Official Cacti Developer

Cacti Resources:
Cacti Website (including releases)
Cacti Issues
Cacti Development Releases
Cacti Development Documentation

My resources:
How to submit Pull Requests
Development Wiki and How To's
Updated NetSNMP Memory template for Cacti 1.x
Cisco SFP template for Cacti 0.8.8


Top
 Profile  
 
 Post subject: Re: No access to Cacti after set "Force Connections over HTT
PostPosted: Tue Jan 15, 2019 9:19 am 
Offline

Joined: Sat Sep 02, 2017 1:10 am
Posts: 1
Modify this file:
<cacti path>/include/global.php

then restart the apache


Top
 Profile  
 
 Post subject: Re: No access to Cacti after set "Force Connections over HTT
PostPosted: Wed Jan 16, 2019 5:41 am 
Offline
Cacti Guru User

Joined: Sun Aug 27, 2017 12:05 am
Posts: 2413
You should not need to modify that file. If you are modifying that file, something else is wrong.

_________________
Official Cacti Developer

Cacti Resources:
Cacti Website (including releases)
Cacti Issues
Cacti Development Releases
Cacti Development Documentation

My resources:
How to submit Pull Requests
Development Wiki and How To's
Updated NetSNMP Memory template for Cacti 1.x
Cisco SFP template for Cacti 0.8.8


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group