Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Fri Apr 26, 2019 11:33 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: All graphs empty
PostPosted: Mon Jan 21, 2019 9:33 am 
Offline

Joined: Mon Jan 21, 2019 9:30 am
Posts: 4
Hi,

every graph on my Cacti is empty.
When I go to the log i can see that rrd update is getting unknown values

/usr/bin/rrdtool update /var/www/html/cacti/rra/test_hdd_used_34.rrd --template hdd_total:hdd_used 1548081061:U:U

and that is for all graphs except ones that are auto created for Local machine. If i run real-time i can see values are fetched. Also, in log i can find results of executed scripts and they are correct.

Ubuntu timezone is set to Europe/Copenhagen and the same is in php.ini, for mariadb utc+1

Can someone help me solve this issue


Top
 Profile  
 
 Post subject: Re: All graphs empty
PostPosted: Wed Jan 30, 2019 2:12 pm 
Offline
Cacti User

Joined: Mon Oct 01, 2018 10:09 am
Posts: 112
I would check permissions for spine (if you are using it), and permissions for rra folder
and log folder (s/b writeable by cacti).
Check your crontab settings, and check the poller settings.

Good Luck,

eholz1


Top
 Profile  
 
 Post subject: Re: All graphs empty
PostPosted: Thu Jan 31, 2019 7:39 am 
Offline

Joined: Mon Jan 21, 2019 9:30 am
Posts: 4
Thanks for your reply.

in crontab poller.php is run every minute by root
owner of the whole cacti folder is www-data.

It worked for 7 days. Now it only works for graphs that are created for localhost.


Top
 Profile  
 
 Post subject: Re: All graphs empty
PostPosted: Thu Jan 31, 2019 1:57 pm 
Offline

Joined: Mon Jan 21, 2019 9:30 am
Posts: 4
Seems like this was the issue:

DQ[Net-SNMP - Get Device I/O] RECACHE ASSERT FAILED '2230477<0:6:12:41.60
DQ[SNMP - Get Mounted Partitions] RECACHE ASSERT FAILED '2230471<0:6:12:41.58
DQ[Net-SNMP - Get Monitored Partitions] RECACHE ASSERT FAILED '2230363<0:6:12:41.56
DQ[SNMP - Interface Statistics] RECACHE ASSERT FAILED '2230354<0:6:12:41.54


After verbos these queries, graphs started working again.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group