support for php 7.2.xx ?

Post general support questions here that do not specifically fall into the Linux or Windows categories.

Moderators: Moderators, Developers

Post Reply
Author
Message
User avatar
classen
Cacti User
Posts: 113
Joined: Thu Nov 12, 2009 3:07 pm

support for php 7.2.xx ?

#1 Post by classen » Fri Feb 08, 2019 11:57 am

Can anyone on the dev team speak to the compatibility of the GitHub develop branch with php 7.2.xx ?

Thanks

tertius
Cacti User
Posts: 71
Joined: Wed Mar 01, 2017 2:34 pm

Re: support for php 7.2.xx ?

#2 Post by tertius » Fri Feb 08, 2019 8:11 pm

I'm not from the dev team, but I just installed cacti 1.2.1 on a RHEL 8 beta system a few day ago, which has php 7.2.11, and it installs and runs flawless, and most important of all: it even collects data!

User avatar
Osiris
Cacti Pro User
Posts: 835
Joined: Mon Jan 05, 2015 10:10 am

Re: support for php 7.2.xx ?

#3 Post by Osiris » Sun Feb 10, 2019 2:53 pm

If you are upgrading, pull from develop, or wait for 1.2.2. Any day now.
Before history, there was a paradise, now dust.

netniV
Cacti Guru User
Posts: 2682
Joined: Sun Aug 27, 2017 12:05 am

Re: support for php 7.2.xx ?

#4 Post by netniV » Tue Feb 12, 2019 5:04 am

classen wrote:Can anyone on the dev team speak to the compatibility of the GitHub develop branch with php 7.2.xx ?

Thanks
1.2.x is compatible with PHP 7.2. This does not necessarily mean that all plugins and custom scripts are, just that the core code should run without errors if PHP is running 7.2 or later.

Post Reply