Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Sat Feb 23, 2019 12:11 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: Missing Data in Graphs 1.1.38
PostPosted: Sat Feb 09, 2019 8:19 am 
Offline

Joined: Tue Jul 12, 2016 11:36 am
Posts: 35
I am running Cacti 1.1.38-3 on Centos 7.5

I have been having issues since pretty much the first installation of Cacti on this server with holes in my data.

This is an example of my graph data:

Code:
2019-02-09 03:30:00   19,149   19,149   537   537   19,149   -536.7047
2019-02-09 03:35:00   19,149   19,149   537   537   19,149   -536.7047
2019-02-09 03:40:00   14,156   14,156   524   524   14,156   -523.699
2019-02-09 03:45:00   -   -   -   -   -   -
2019-02-09 03:50:00   -   -   -   -   -   -
2019-02-09 03:55:00   -   -   -   -   -   -
2019-02-09 04:00:00   -   -   -   -   -   -
2019-02-09 04:05:00   298,028   298,028   561   561   298,028   -561.1444
2019-02-09 04:10:00   196,816   196,816   556   556   196,816   -555.5956
2019-02-09 04:15:00   196,816   196,816   556   556   196,816   -555.5956
2019-02-09 04:20:00   -   -   -   -   -   -
2019-02-09 04:25:00   -   -   -   -   -   -
2019-02-09 04:30:00   -   -   -   -   -   -
2019-02-09 04:35:00   -   -   -   -   -   -
2019-02-09 04:40:00   -   -   -   -   -   -
2019-02-09 04:45:00   -   -   -   -   -   -
2019-02-09 04:50:00   -   -   -   -   -   -
2019-02-09 04:55:00   -   -   -   -   -   -
2019-02-09 05:00:00   -   -   -   -   -   -
2019-02-09 05:05:00   -   -   -   -   -   -
2019-02-09 05:10:00   -   -   -   -   -   -
2019-02-09 05:15:00   -   -   -   -   -   -
2019-02-09 05:20:00   -   -   -   -   -   -
2019-02-09 05:25:00   -   -   -   -   -   -
2019-02-09 05:30:00   -   -   -   -   -   -
2019-02-09 05:35:00   -   -   -   -   -   -
2019-02-09 05:40:00   -   -   -   -   -   -
2019-02-09 05:45:00   -   -   -   -   -   -
2019-02-09 05:50:00   -   -   -   -   -   -
2019-02-09 05:55:00   -   -   -   -   -   -
2019-02-09 06:00:00   -   -   -   -   -   -
2019-02-09 06:05:00   -   -   -   -   -   -
2019-02-09 06:10:00   11,237   11,237   545   545   11,237   -544.5216
2019-02-09 06:15:00   10,813   10,813   446   446   10,813   -445.8933
2019-02-09 06:20:00   8,758   8,758   528   528   8,758   -527.5672
2019-02-09 06:25:00   8,758   8,758   528   528   8,758   -527.5672
2019-02-09 06:30:00   4,828   4,828   525   525   4,828   -524.6663
2019-02-09 06:35:00   -   -   -   -   -   -
2019-02-09 06:40:00   -   -   -   -   -   -
2019-02-09 06:45:00   -   -   -   -   -   -
2019-02-09 06:50:00   10,169   10,169   570   570   10,169   -570.3995
2019-02-09 06:55:00   14,809   14,809   558   558   14,809   -557.7301
2019-02-09 07:00:00   179,672   179,672   476   476   179,672   -476.1035
2019-02-09 07:05:00   179,672   179,672   476   476   179,672   -476.1035
2019-02-09 07:10:00   -   -   -   -   -   -


In the logs it seems to work sometimes:

Code:
2019/02/09 07:09:30 - POLLER: Poller[Main Poller] Device[12] Device[UBNT] RECACHE DQ[Net-SNMP - Get Device I/O] OID: .1.3.6.1.2.1.1.3.0, output: 158442636
2019/02/09 07:09:30 - POLLER: Poller[Main Poller] Device[12] Device[UBNT] RECACHE DQ[SNMP - Get Processor Information] OID: .1.3.6.1.2.1.1.3.0, output: 158442636
2019/02/09 07:09:30 - POLLER: Poller[Main Poller] Device[12] Device[UBNT] RECACHE DQ[SNMP - Get Mounted Partitions] OID: .1.3.6.1.2.1.1.3.0, output: 158442636
2019/02/09 07:09:30 - POLLER: Poller[Main Poller] Device[12] Device[UBNT] RECACHE DQ[Net-SNMP - Get Monitored Partitions] OID: .1.3.6.1.2.1.1.3.0, output: 158442635
2019/02/09 07:09:30 - POLLER: Poller[Main Poller] Device[12] Device[UBNT] RECACHE DQ[SNMP - Interface Statistics] OID: .1.3.6.1.2.1.1.3.0, output: 158442635
2019/02/09 07:09:30 - POLLER: Poller[Main Poller] Device[12] Device[UBNT RECACHE: Processing 5 items in the auto reindex cache for '172.23.23.6'.
2019/02/09 07:09:30 - POLLER: Poller[Main Poller] Device[12] Device[UBNT] STATUS: Device '172.6.4.6' is UP.


I am a loss as to how to try and debug this issue.


Top
 Profile  
 
 Post subject: Re: Missing Data in Graphs 1.1.38
PostPosted: Sat Feb 09, 2019 8:53 am 
Offline

Joined: Tue Jul 12, 2016 11:36 am
Posts: 35
I searched Cacti.log for timeouts for the ip address of the this device and found no timeouts:

Code:
grep SNMP cacti.log | grep -i time | grep 'x.x.x'


I should also clarify that all of my devices are missing data in their graphs


Top
 Profile  
 
 Post subject: Re: Missing Data in Graphs 1.1.38
PostPosted: Sat Feb 09, 2019 9:01 am 
Offline

Joined: Tue Jul 12, 2016 11:36 am
Posts: 35
I also tried to run cmd.php directly for this one host with no data returned:

Code:
# php -q /usr/share/cacti/cmd.php --first=12 --last=12
2019/02/09 07:59:44 - POLLER: Poller[1] NOTE: There are no items in your poller for this polling cycle!


Top
 Profile  
 
 Post subject: Re: Missing Data in Graphs 1.1.38
PostPosted: Sat Feb 09, 2019 9:11 am 
Offline

Joined: Tue Jul 12, 2016 11:36 am
Posts: 35
I turned on Data Source Debug for the Host and Graph I am using as my example issue and I get what I expect:

Code:
/bin/rrdtool create \
/usr/share/cacti/rra/ubnt_traffic_in_60.rrd \
--step 300  \
DS:traffic_in:COUNTER:600:0:10000000000000 \
DS:traffic_out:COUNTER:600:0:10000000000000 \
RRA:AVERAGE:0.5:1:600 \
RRA:AVERAGE:0.5:6:700 \
RRA:AVERAGE:0.5:24:775 \
RRA:AVERAGE:0.5:288:797 \
RRA:MIN:0.5:1:600 \
RRA:MIN:0.5:6:700 \
RRA:MIN:0.5:24:775 \
RRA:MIN:0.5:288:797 \
RRA:MAX:0.5:1:600 \
RRA:MAX:0.5:6:700 \
RRA:MAX:0.5:24:775 \
RRA:MAX:0.5:288:797 \
RRA:LAST:0.5:1:600 \
RRA:LAST:0.5:6:700 \
RRA:LAST:0.5:24:775 \
RRA:LAST:0.5:288:797 \


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group