Initial login fails on fresh RPi installation

Post general support questions here that do not specifically fall into the Linux or Windows categories.

Moderators: Moderators, Developers

Post Reply
Author
Message
sunnshol
Posts: 1
Joined: Sat Feb 09, 2019 9:10 am

Initial login fails on fresh RPi installation

#1 Post by sunnshol » Sat Feb 09, 2019 9:24 am

Hi there!

The standard apologies if this is answered somewhere, I did try to find the answer. I probably posted in the wrong place too, sorry about that.

The title pretty much describes the problem. Fresh install of Raspbian altered only to make it an access point, install with apt-get choosing apache2, run the Chromium browser, try to log in, red "wrong password" message.

I have tried setting the password directly in the database with Password() (no errors but didn't work), and setting it to '' (same). I have added session.auto_start to both the cli and apache2 php.ini files with no joy. No errors, in either syslog or cacti.log, but no joy. I am running php 7.0 BTW.

Any ideas? Seems like it must be something obvious.

User avatar
Osiris
Cacti Pro User
Posts: 835
Joined: Mon Jan 05, 2015 10:10 am

Re: Initial login fails on fresh RPi installation

#2 Post by Osiris » Sun Feb 10, 2019 2:57 pm

There was a bug in 1.2 and earlier that prevented cacti from installing properly if there is more than one cacti database on the system. Fixed in 1.2.2. that is what causes this error.
Before history, there was a paradise, now dust.

Post Reply