No thold emails to notification list

Post general support questions here that do not specifically fall into the Linux or Windows categories.

Moderators: Moderators, Developers

Post Reply
Author
Message
hipsterdoofus
Cacti User
Posts: 80
Joined: Fri Mar 09, 2007 12:35 pm

No thold emails to notification list

#1 Post by hipsterdoofus » Thu Apr 25, 2019 4:02 pm

I have an older cacti install I've been running forever. I don't run notification lists on it, I just have individual email addresses on it.

I have a newer install that I've been running in parallel and never made the jump over on it. Its currently at version 1.2.2. It works fine - graphs great, trips thresholds, etc, but it does not send out emails to a notification list I set up. If I run a test email from settings, it sends out fine. Are there any particular troubleshooting steps I can do to find out why even though the thresholds are tripped, it isn't going out? This is running on CentOS 7.

netniV
Cacti Guru User
Posts: 2691
Joined: Sun Aug 27, 2017 12:05 am

Re: No thold emails to notification list

#2 Post by netniV » Fri Apr 26, 2019 2:33 am

Are you sure that the notification list is associated with the specific threshold? How many emails do you have defined against the list? What errors are appear in the logs?

hipsterdoofus
Cacti User
Posts: 80
Joined: Fri Mar 09, 2007 12:35 pm

Re: No thold emails to notification list

#3 Post by hipsterdoofus » Fri May 03, 2019 3:51 pm

netniV wrote:Are you sure that the notification list is associated with the specific threshold? How many emails do you have defined against the list? What errors are appear in the logs?
Yes, as far as I can tell, it is associated with that threshold...provided I'm checking in the right place (again, first time to use lists). If I go to Notification lists, and pick the only one I have (and it only has 1 email associated with it right now) and then click on the thresholds tab, everything in there for warning and alert lists says "current list", which I assume is what it should say.

Where would I need to look in the logs, or what sort of language should I be looking for?

netniV
Cacti Guru User
Posts: 2691
Joined: Sun Aug 27, 2017 12:05 am

Re: No thold emails to notification list

#4 Post by netniV » Fri May 17, 2019 3:42 pm

If you get the ID of the threshold, use

Code: Select all

SELECT * FROM thold_data where ID = ?
Replace the question mark with the ID

hipsterdoofus
Cacti User
Posts: 80
Joined: Fri Mar 09, 2007 12:35 pm

Re: No thold emails to notification list

#5 Post by hipsterdoofus » Thu Aug 01, 2019 11:55 am

netniV wrote:If you get the ID of the threshold, use

Code: Select all

SELECT * FROM thold_data where ID = ?
Replace the question mark with the ID
Terribly sorry I took so long to get back to this. So here's the weird thing. Even though tholds seem to be getting triggered, when I go look at the database on this install, there is no thold_data table, which I'm guessing would be a large part of the problem. I have a much older install of cacti on another server that has that table. I'm not sure what the deal is then. My thold plugin was old (1.0.3). I went and got an updated one and enabled it and I still do not have that table, which I'm guessing should be created when the plugin is installed?

netniV
Cacti Guru User
Posts: 2691
Joined: Sun Aug 27, 2017 12:05 am

Re: No thold emails to notification list

#6 Post by netniV » Fri Aug 02, 2019 4:45 am

This is likely a innodb large prefix issue, if you search the issues list on github for cacti's core and maybe even the thold one, you'll likely find the various things people have found due to MySQL changing the ways things work or that our indexes become bigger than they allow by default.

Post Reply