Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Sun Jun 16, 2019 3:45 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: Errors starting for no reason
PostPosted: Mon May 13, 2019 8:51 am 
Offline
Cacti User
User avatar

Joined: Fri Feb 10, 2017 2:45 pm
Posts: 237
Location: Long Island, New York, USA
My logs have been all green until 4:09 this morning. Nothing has changed, but the below started showing up:

2019/05/13 04:09:42 - CMDPHP SQL Backtrace: (/poller.php[796]:api_plugin_hook(), /lib/plugins.php[74]:api_plugin_run_plugin_hook(), /lib/plugins.php[177]:thold_poller_bottom(), /plugins/thold/includes/polling.php[41]:thold_update_host_status(), /plugins/thold/includes/polling.php[798]:db_execute(), /lib/database.php[187]:db_execute_prepared())
2019/05/13 04:09:42 - CMDPHP ERROR: A DB Exec Failed!, Error: You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ')' at line 1
2019/05/13 04:09:42 - MAILER INFO: Mail successfully sent via SMTP from 'xxxxx <[email protected]>', to '[email protected]', cc '', Subject 'Device Notice: xxxxx @ 192.168.131.3 is UP'
2019/05/13 04:09:41 - SYSTEM STATS: Time:39.5656 Method:cmd.php Processes:18 Threads:N/A Hosts:88 HostsPerProcess:5 DataSources:394 RRDsProcessed:293

Could someone shed some insight as to what the heck happened?

Thanks in advance.

_________________
See the Cacti 1.x templates I use at: http://www.camerabob.com/cacti

Live: Cacti 1.2.3 @ CentOS 7-6.1810.2.el7 & PHP 5.4.16-46.e17
Maint @ 1.2
Monitor @ 2.3.6
Thold @ 1.2.4

Test: Cacti 1.2.3 @ CentOS 7-6.1810.2.el7 & PHP 5.4.45-17.e17.remi
Maint @ 1.2
Monitor @ 2.3.4
Thold @ 1.0.4


Top
 Profile  
 
 Post subject: Re: Errors starting for no reason
PostPosted: Mon May 13, 2019 10:34 am 
Offline
Cacti User
User avatar

Joined: Fri Feb 10, 2017 2:45 pm
Posts: 237
Location: Long Island, New York, USA
OK, I have figured out that this error has something to do with the MAINT plugin. When I have a device that errors and the maintenance window is in effect, the logs records these errors. I switched from Maint 1.0 to Maint 1.2 and the same errors present.

_________________
See the Cacti 1.x templates I use at: http://www.camerabob.com/cacti

Live: Cacti 1.2.3 @ CentOS 7-6.1810.2.el7 & PHP 5.4.16-46.e17
Maint @ 1.2
Monitor @ 2.3.6
Thold @ 1.2.4

Test: Cacti 1.2.3 @ CentOS 7-6.1810.2.el7 & PHP 5.4.45-17.e17.remi
Maint @ 1.2
Monitor @ 2.3.4
Thold @ 1.0.4


Top
 Profile  
 
 Post subject: Re: Errors starting for no reason
PostPosted: Tue May 14, 2019 8:18 am 
Offline
Cacti User
User avatar

Joined: Fri Feb 10, 2017 2:45 pm
Posts: 237
Location: Long Island, New York, USA
OK, after updating the plugins, I now get THOLD errors in the logs:
Code:
2019/05/14 09:16:46 - SYSTEM THOLD STATS: Time:0.0706 Tholds:0 TotalDevices:88 DownDevices:0 NewDownDevices:0
2019/05/14 09:16:46 - CMDPHP SQL Backtrace: (/poller.php[796]:api_plugin_hook(), /lib/plugins.php[74]:api_plugin_run_plugin_hook(), /lib/plugins.php[177]:thold_poller_bottom(), /plugins/thold/includes/polling.php[77]:thold_prune_old_data(), /plugins/thold/thold_functions.php[5412]:db_execute(), /lib/database.php[187]:db_execute_prepared())
2019/05/14 09:16:46 - CMDPHP ERROR: A DB Exec Failed!, Error: Table 'cacti.plugin_thold_host_failed' doesn't exist
2019/05/14 09:16:46 - CMDPHP SQL Backtrace: (/poller.php[796]:api_plugin_hook(), /lib/plugins.php[74]:api_plugin_run_plugin_hook(), /lib/plugins.php[177]:thold_poller_bottom(), /plugins/thold/includes/polling.php[46]:thold_update_host_status(), /plugins/thold/includes/polling.php[822]:db_execute(), /lib/database.php[187]:db_execute_prepared())
2019/05/14 09:16:46 - CMDPHP ERROR: A DB Exec Failed!, Error: Table 'cacti.plugin_thold_host_failed' doesn't exist
2019/05/14 09:16:46 - CMDPHP SQL Backtrace: (/poller.php[796]:api_plugin_hook(), /lib/plugins.php[74]:api_plugin_run_plugin_hook(), /lib/plugins.php[177]:thold_poller_bottom(), /plugins/thold/includes/polling.php[46]:thold_update_host_status(), /plugins/thold/includes/polling.php[524]:db_fetch_assoc(), /lib/database.php[448]:db_fetch_assoc_prepared(), /lib/database.php[462]:db_execute_prepared())
2019/05/14 09:16:46 - CMDPHP ERROR: A DB Row Failed!, Error: Table 'cacti.plugin_thold_host_failed' doesn't exist


Tried uninstalling/reinstalling. Same issue.

_________________
See the Cacti 1.x templates I use at: http://www.camerabob.com/cacti

Live: Cacti 1.2.3 @ CentOS 7-6.1810.2.el7 & PHP 5.4.16-46.e17
Maint @ 1.2
Monitor @ 2.3.6
Thold @ 1.2.4

Test: Cacti 1.2.3 @ CentOS 7-6.1810.2.el7 & PHP 5.4.45-17.e17.remi
Maint @ 1.2
Monitor @ 2.3.4
Thold @ 1.0.4


Top
 Profile  
 
 Post subject: Re: Errors starting for no reason
PostPosted: Fri May 17, 2019 4:24 pm 
Offline
Cacti Guru User

Joined: Sun Aug 27, 2017 12:05 am
Posts: 2499
I would raise that on the thold repo

_________________
Official Cacti Developer

Cacti Resources:
Cacti Website (including releases)
Cacti Issues
Cacti Development Releases
Cacti Development Documentation

My resources:
How to submit Pull Requests
Development Wiki and How To's
Updated NetSNMP Memory template for Cacti 1.x
Cisco SFP template for Cacti 0.8.8


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group