How do I disable php-snmp? (previously: Downgrade to 1.1.34)

Post general support questions here that do not specifically fall into the Linux or Windows categories.

Moderators: Moderators, Developers

Post Reply
Author
Message
vudiemphuongchi
Posts: 1
Joined: Tue May 21, 2019 10:00 am

How do I disable php-snmp? (previously: Downgrade to 1.1.34)

#1 Post by vudiemphuongchi » Tue May 21, 2019 10:11 am

Hello,

I am currently on 1.1.38. Is it possible to downgrade to 1.1.34?

The reason I am interested in downgrading is because SNMP over TCP broke in 1.1.38. I had TCP working in .34 which was the last version I was using prior to upgrading to .38

This is the error .38 gives me:

Session SNMP error - SNMP::__construct(): php_network_getaddresses: getaddrinfo failed: Name or service not known

I have read the post providing a temporary solution to this problem but it appears it only applies to version 0.8.7 (if I recall correctly).

I have low quality connections to several of my remote hosts where TCP performs much better than UDP - I'm not loosing packets. I've confirmed this with manual snmpwalk commands.

Thanks for any info!

User avatar
Osiris
Cacti Pro User
Posts: 835
Joined: Mon Jan 05, 2015 10:10 am

Re: How do I disable php-snmp? (previously: Downgrade to 1.1

#2 Post by Osiris » Sat Jul 13, 2019 6:16 pm

Please check with the latest 1.2.5 (develop) to see if this issue is now resolved.
Before history, there was a paradise, now dust.

Post Reply