Cannot execute using backquotes in Safe Mode - safe_mode=off

Post general support questions here that do not specifically fall into the Linux or Windows categories.

Moderators: Moderators, Developers

Post Reply
Author
Message
losiledlighting
Posts: 1
Joined: Wed Jun 05, 2019 4:32 am

Cannot execute using backquotes in Safe Mode - safe_mode=off

#1 Post by losiledlighting » Wed Jun 05, 2019 4:40 am

since yesterday cacti doesn't work, I installed the ZendOptimizer and from this time I got no output from cacti.
If I try: /usr/bin/php -q /var/www/cacti/scripts/sql.php
I always get: Warning: shell_exec() [http://www.php.net/function.shell-exec]: Cannot execute using backquotes in Safe Mode in /var/www/cacti/scripts/sql.php on line 6
But the safe_mode is off, in master and local value.
On console I also get this message if I try to run the script as wwwrun(apache), if I run this as root it works.
Where is here the problem?

Ciao
AS-N

netniV
Cacti Guru User
Posts: 2885
Joined: Sun Aug 27, 2017 12:05 am

Re: Cannot execute using backquotes in Safe Mode - safe_mode

#2 Post by netniV » Fri Jun 07, 2019 3:31 pm

It would suggest that you are not looking at the right php.ini for the settings you are looking at. Cacti is not designed to run in safe mode as far as I am aware. You can use php --ini to find out which ini file is being used.

Post Reply