Higher resolution graphs (High Collection Rate) how to?

Post general support questions here that do not specifically fall into the Linux or Windows categories.

Moderators: Moderators, Developers

Post Reply
Author
Message
janrovner
Posts: 4
Joined: Fri Jun 07, 2019 12:11 pm

Higher resolution graphs (High Collection Rate) how to?

#1 Post by janrovner » Fri Jun 07, 2019 12:29 pm

Hello, I am a newbie to Cacti (version 1.1.38 on Ubuntu 18) and need to have a higher resolution graphs - with 30sec resolution (1 minute would be enough as well).

What I did:

1. I cleared all devices and graphs.

2. I went to "Presets/Data Profiles" and have found "High Collection Rate", that should have a 30s graph resolution. I've made this a default profile, then I switched data templates to use it (I see now a 6 templates using "High Collection Rate" and 0 for "System Default").

3. Then I added some devices and graphs for them, Data Sources are showing "Poller Interval" column as "30 Seconds" and graphs started to appear.

What is strange, the graphs look right - x axis of graphs is stepped by 30sec - but the actual data in them is changed after 5 minutes.

Q: What else needs and how to be set up to have a higher resolution than (default) 5 minutes ?

I went to Settings/Poller and set "Poller Type" to spine, "Poller Interval" to "Every 30 seconds", "Cron interval" to "Every minute" and rebooted, but it did not help.

Thank you very much.

netniV
Cacti Guru User
Posts: 2885
Joined: Sun Aug 27, 2017 12:05 am

Re: Higher resolution graphs (High Collection Rate) how to?

#2 Post by netniV » Fri Jun 07, 2019 3:41 pm

Did you remove any existing RRA's before you started afresh with the 30 seconds polling? If not, the RRA's will still have a step size of 5 minutes.

janrovner
Posts: 4
Joined: Fri Jun 07, 2019 12:11 pm

Re: Higher resolution graphs (High Collection Rate) how to?

#3 Post by janrovner » Tue Jun 11, 2019 4:47 am

Thank you for your support, I deleted and recreated everything and it's OK now.

Post Reply