Unique User Templates for Multiple LDAP Domains not working

Post general support questions here that do not specifically fall into the Linux or Windows categories.

Moderators: Moderators, Developers

Post Reply
Author
Message
rasekm
Posts: 23
Joined: Thu Aug 23, 2018 7:28 am

Unique User Templates for Multiple LDAP Domains not working

#1 Post by rasekm » Thu Oct 17, 2019 5:44 am

Hello

I am running Cacti 1.2.6 where I am trying to implement a Multi LDAP solution, where I would like to have different users profile prepared for each different LDAP domain. However I cannot seem to get it to work.

If I change the User Template under each domain in the User Domains section I see no changes.

In order to change the default user template (for all LDAP domains) I have to go back to Settings -> Authentication, set the Authentication Method to be "LDAP Authentication" and set the User Template there. When I do this, this change is affecting all of the LDAP domains I have implemented under "User Domains".

If I set this value to "No User" then all logins from the different LDAP domains are all denied with an error message "No User Template" (as expected when there is no user profile as default by doing this).

Anyone have the same issue or know what I have done wrong?

Best Regards

netniV
Cacti Guru User
Posts: 3061
Joined: Sun Aug 27, 2017 12:05 am

Re: Unique User Templates for Multiple LDAP Domains not working

#2 Post by netniV » Thu Oct 17, 2019 6:15 pm

I have different templates for different domains setup at the office. I'll have am there tomorrow so I'll check what I have in place.

netniV
Cacti Guru User
Posts: 3061
Joined: Sun Aug 27, 2017 12:05 am

Re: Unique User Templates for Multiple LDAP Domains not working

#3 Post by netniV » Tue Oct 22, 2019 6:14 am

so for each user domain, I have it set to enabled and pointing at their own template user. The user is enabled and the group memberships assigned to it. When logging in as a new user, it should record that it has copied from the templated user. Under settings -> authentication, I have it set to Multiple LDAP/AD domains and that's about it.

Post Reply