Windows Installer [Cacti 1.2.8] [Updated 2019-1-10]

Post support questions that relate to the Windows 2003/2000/XP operating systems.

Moderators: Moderators, Developers

Post Reply
Author
Message
nknllaneta
Posts: 1
Joined: Thu Jun 28, 2012 2:08 am

Re: Windows Installer [Cacti 0.8.8a - 2012-05-01]

#721 Post by nknllaneta » Thu Jun 28, 2012 2:20 am

Just installed a Cacti on a Windows 7 desktop.

From the web browser, under http://localhost IT WORKS appear on the window.

Under the http://localhost/cacti link or http://localhost/cacti/index.php it is asking me download a file.

Need help, I don't know where to go from there. nThank you.

User avatar
BSOD2600
Cacti Moderator
Posts: 12160
Joined: Sat May 08, 2004 12:44 pm
Location: USA

Re: Windows Installer [Cacti 0.8.8a - 2012-05-01]

#722 Post by BSOD2600 » Thu Jun 28, 2012 2:15 pm

Sounds like PHP wasn't properly configured in the web server. Which one did you go with? Have you rebooted since the install? Has any variant of PHP been previously installed?

Lucas Rey
Posts: 19
Joined: Fri Oct 22, 2010 2:49 am

Re: Windows Installer [Cacti 0.8.8a - 2012-05-01]

#723 Post by Lucas Rey » Mon Jul 02, 2012 2:45 am

Dear BSOD/all,
I installed the last pack yesterday, but I'm stuck with rrd file creation (from Data Source creation).
My OS is a simple XP Pro SP3.

From process monitor seem rrdtool.exe isn't executed at all (so there's no permission problem), plus there's no rrdtool commands on cacti.log, so I cannot try to execute it from console.

Could someone drive me for a solution? Do you have a simple rrdtool create command so I can test it on cmd console ??

Thanks!

lenzd1
Posts: 8
Joined: Tue Jan 03, 2012 11:45 am

Re: Windows Installer [Cacti 0.8.8a - 2012-05-01]

#724 Post by lenzd1 » Wed Aug 08, 2012 9:20 am

I have successfully installed using this installer, however I cannot get the SSL plugin from http://cactiusers.org/downloads/ to populate in the Plugin Management. I have unzipped the plugin and placed it in the plugins folder (Apache2/htdocs/cacti/plugins), but still no luck. I have also tried updating /include/config.php with the following entry:

#Plugin list
$plugins = array();
$plugins[] = 'ssl-0.1';

Server Specs:
Windows 2008 SP2
64bit

I have attached a screen shot of my current plugins directory, cacti install log, and cacti log.

Thanks!
Attachments
Cacti logs.zip
(19.29 KiB) Downloaded 104 times
PluginsList.jpg
PluginsList.jpg (65.51 KiB) Viewed 4021 times

User avatar
BSOD2600
Cacti Moderator
Posts: 12160
Joined: Sat May 08, 2004 12:44 pm
Location: USA

Re: Windows Installer [Cacti 0.8.8a - 2012-05-01]

#725 Post by BSOD2600 » Wed Aug 08, 2012 11:50 am

1) not a problem with the installer, thus belongs in a separate thread.
2) no need to edit config.php anymore as the plugin arch handles it all.
3) if it doesn't work, you'll need to take the problem up with the plugin author.

jftuga
Posts: 49
Joined: Mon Feb 07, 2011 11:50 am
Location: Athens, GA

Re: Windows Installer [Cacti 0.8.8a - 2012-05-01]

#726 Post by jftuga » Thu Aug 23, 2012 9:43 am

I made a small batch file to help debug the poller process. This is used to replace the program running from Cacti's Scheduled Task. It creates a set of folders under cacti\logs broken down into year\month\day and then places the poller's output (including errors) into this folder. This was tested under Windows 2008 R2 server.

Thanks,
-John

Code: Select all

@echo off

rem (cacti path)\cacti\cli\poller_with_rotate.bat

setlocal

for /f "usebackq tokens=1,2,3,4,5,6,7 delims=/:. " %%a in (`echo %DATE% %TIME%`) do set YR=%%d
for /f "usebackq tokens=1,2,3,4,5,6,7 delims=/:. " %%a in (`echo %DATE% %TIME%`) do set MON=%%b
for /f "usebackq tokens=1,2,3,4,5,6,7 delims=/:. " %%a in (`echo %DATE% %TIME%`) do set DAY=%%c
for /f "usebackq tokens=1,2,3,4,5,6,7 delims=/:. " %%a in (`echo %DATE% %TIME%`) do set NOW=%%d%%b%%c_%%e%%f%%g

set REWT=C:\Apache2\htdocs\cacti\log\%YR%\%MON%\%DAY%
set LOG=%REWT%\poller_%NOW%.log

if not exist %REWT% mkdir %REWT%

cd C:\Apache2\htdocs\cacti
C:\PHP\php.exe C:\Apache2\htdocs\cacti\poller.php >> %LOG% 2>&1

endlocal
Last edited by jftuga on Fri Aug 24, 2012 2:12 pm, edited 1 time in total.

jftuga
Posts: 49
Joined: Mon Feb 07, 2011 11:50 am
Location: Athens, GA

Re: Windows Installer [Cacti 0.8.8a - 2012-05-01]

#727 Post by jftuga » Thu Aug 23, 2012 9:55 am

BSOD2600,

Can you please add to the post-install document that the timezone should be edited in c:\php\php.ini and then Apache needs to be restarted.

Your installer rocks!

Thanks,
-John

User avatar
BSOD2600
Cacti Moderator
Posts: 12160
Joined: Sat May 08, 2004 12:44 pm
Location: USA

Re: Windows Installer [Cacti 0.8.8a - 2012-05-01]

#728 Post by BSOD2600 » Thu Aug 23, 2012 11:55 am

Nice script. Yea, it would be useful if the poller log automatically rolled over on X interval. Feature request time ;)
jftuga wrote:BSOD2600,

Can you please add to the post-install document that the timezone should be edited in c:\php\php.ini and then Apache needs to be restarted.
Done. Included in next update, when I find the time...

nescio
Posts: 7
Joined: Tue Aug 28, 2012 5:26 am

Re: Windows Installer [Cacti 0.8.8a - 2012-05-01]

#729 Post by nescio » Tue Aug 28, 2012 5:46 am

Hello,

I am a brand new user to Cacti with not that much experience on computers. These days I'm having some trouble installing Cacti on a Microsoft Server 2003 to monitor another Sun Solaris 10 server. I've used the Windows installer for Cacti 0.8.8a (actually I reinstalled several times to be sure). I even reinstalled IIS 6.0 with FastCGI before reinstalling Cacti and it still does not work. I recieve a 403 Forbidden error (or in the previous installation it was 404 Page cannot be found).

During the installation I noticed that an error to access 'root'@'localhost' (using password : YES) occured (Error 1045 (28000), if it helps). When i tried c:\>mysql -u root -p cacti in the command line, it asks the password again and it does not accept cacti,cactipw or any other password stated in the post-installation instructions.

I believe IIS is working well, since the trial html page I put under c:\Inetpub\wwwroot is displayed successfully.

If you know/can find a solution, please let me know.

edit: When I was checking the properties of the website, I noticed that index.php was not added to default content page list under "Documents". Right now when I try to access http:\\localhost\cacti, I just see Error 404 - Page cannot be found.

YoMarK
Cacti User
Posts: 78
Joined: Fri Feb 02, 2007 8:36 am
Location: Eindhoven/The Netherlands

Re: Windows Installer [Cacti 0.8.8a - 2012-05-01]

#730 Post by YoMarK » Wed Aug 29, 2012 1:41 pm

Did a fresh install on a Windows 2008R2 server.
Had some difficulties with the PHP timezone in php.ini(cacti creating graphs+rrd's but not updating them), but when that was solved it worked fine, spine including.

Migrated my old database and rrd's. Used rrdtool dump/restore to be sure...didn't know if it's 64bit rrdtool included with the installer?

Anyway, saved a lot of time with this installer. Great work!

User avatar
BSOD2600
Cacti Moderator
Posts: 12160
Joined: Sat May 08, 2004 12:44 pm
Location: USA

Re: Windows Installer [Cacti 0.8.8a - 2012-05-01]

#731 Post by BSOD2600 » Thu Aug 30, 2012 11:31 am

YoMarK wrote:didn't know if it's 64bit rrdtool included with the installer?
It's 32bit. Getting it compiled on Windows is hard enough these days. If someone is able to get a 64bit compile, I'd be interested... as would a patch submitted to Tobias.

jkwine
Posts: 2
Joined: Tue Sep 04, 2012 12:42 am

Re: Windows Installer [Cacti 0.8.8a - 2012-05-01]

#732 Post by jkwine » Tue Sep 04, 2012 1:09 am

Hi,
I used the exe file to install CACTI on a Windows 2003 Server running with IIS. When i try to open i got an error message : This error (HTTP 403 Forbidden) means that Internet Explorer was able to connect to the website, but it does not have permission to view the webpage.
When i looked on C:\php, i can't find the file php5isapi.dll. Is it normal ? The only dll files i found are php5.dll, ssleay32.dll, libsasl.dll and libeay32.dll
Any idea if i have to download Php and reinstall it ?

Thank you in advance.

User avatar
BSOD2600
Cacti Moderator
Posts: 12160
Joined: Sat May 08, 2004 12:44 pm
Location: USA

Re: Windows Installer [Cacti 0.8.8a - 2012-05-01]

#733 Post by BSOD2600 » Tue Sep 04, 2012 1:01 pm

jkwine:
attach your cacti-installer.log file for review. If you want to reinstall PHP, per the first page PHP 5.3.10 was installed. either use the reinstall feature or redownload and manually reinstall.... then you'll need to follow the cacti installation guide for the php and cacti sections.

jkwine
Posts: 2
Joined: Tue Sep 04, 2012 12:42 am

Re: Windows Installer [Cacti 0.8.8a - 2012-05-01]

#734 Post by jkwine » Tue Sep 04, 2012 6:05 pm

I enclosed the cacti installer log. If i reinstall Php like the first page that means it will reinstall all software ?
Attachments
cacti-installer.txt
(151.29 KiB) Downloaded 200 times

User avatar
BSOD2600
Cacti Moderator
Posts: 12160
Joined: Sat May 08, 2004 12:44 pm
Location: USA

Re: Windows Installer [Cacti 0.8.8a - 2012-05-01]

#735 Post by BSOD2600 » Wed Sep 05, 2012 12:27 pm

jkwine wrote:If i reinstall Php like the first page that means it will reinstall all software ?
No, just need to validate the php/cacti portions of the installation guide. It's unknown what settings the PHP installer will change.

Post Reply