Windows Installer [Cacti 1.2.8] [Updated 2019-1-10]

Post support questions that relate to the Windows 2003/2000/XP operating systems.

Moderators: Moderators, Developers

Post Reply
Author
Message
User avatar
smlick
Cacti User
Posts: 267
Joined: Tue May 20, 2008 4:09 am
Location: Italy, Rome

Re: Windows Installer [Cacti 0.8.8a] [Updated 2012-09-13]

#766 Post by smlick » Mon Sep 23, 2013 7:57 am

Please BSOD2600 update the package to the latest Cacti release.
Tnx 4 your work.

Regards
Alex
Cacti Version 0.8.8c production / 0.8.8c test W2008 -- Plugin:Weathermap - Monitor - CAMM 1.6.7 :) - Nectar - GPS Map

User avatar
BSOD2600
Cacti Moderator
Posts: 12160
Joined: Sat May 08, 2004 12:44 pm
Location: USA

Re: Windows Installer [Cacti 0.8.8a] [Updated 2012-09-13]

#767 Post by BSOD2600 » Mon Sep 23, 2013 12:00 pm

I'm holding off until some patches have been released for 0.8.8b, otherwise many users will have problems with existing custom scripts.

wirwav
Posts: 6
Joined: Sun Aug 18, 2013 5:28 am

Re: Windows Installer [Cacti 0.8.8a] [Updated 2012-09-13]

#768 Post by wirwav » Fri Sep 27, 2013 12:52 pm

+1 for this.

I just spent 14 weeks trying to get a project to work using a mix of Cacti and The dude and Ntop.

After 13 weeks of messing around with 7 different Linux distros, I returned to Windows, and finally installed Cacti using the installer.

Little did I realise that the last week spent chasing possible reasons why my graphs wouldnt display was maybe caused by the inherent bug in the 0.8.8a.

Nothing worked as smoothly (for me) as the installer. Especially for a novice.

I have followed 2 sets of instructions of "how to's" install Cacti on Windows 7, and now having ripped out the old version. I am totally unable to knit together Xampp and Cacti.

(Xampp is running fine!!)

So I am very much dependant on your revised installer.

Any chance of a timeline for it, I don't want my new server to sit around collecting much more dust!

User avatar
smlick
Cacti User
Posts: 267
Joined: Tue May 20, 2008 4:09 am
Location: Italy, Rome

Re: Windows Installer [Cacti 0.8.8a] [Updated 2012-09-13]

#769 Post by smlick » Tue Oct 01, 2013 3:07 am

Hi BSOD2600, I tried to update my old 0.8.7.g Cacti version with your installer (0.8.8.a), the installation process goes smoothly, after that I edited the config and global file with the correct path (FQDN and also I tried with the fixed IP) and grant to access the cacti db (another server) but I get always connect problem to the db. Any idea? How to debug this kind of problem?

Regards
Alessio
Cacti Version 0.8.8c production / 0.8.8c test W2008 -- Plugin:Weathermap - Monitor - CAMM 1.6.7 :) - Nectar - GPS Map

User avatar
BSOD2600
Cacti Moderator
Posts: 12160
Joined: Sat May 08, 2004 12:44 pm
Location: USA

Re: Windows Installer [Cacti 0.8.8a] [Updated 2012-09-13]

#770 Post by BSOD2600 » Tue Oct 01, 2013 11:59 am

As the first post states, the installer is not meant for upgrading.

Please follow the standard upgrade procedures as documented in http://docs.cacti.net/

you shouldnt need to edit global.php for any reason. double-check your config.php settings are correct AND you can use those credentials to log into mysql.

swappedsr
Posts: 14
Joined: Wed Oct 02, 2013 11:28 am

Re: Windows Installer [Cacti 0.8.8a] [Updated 2012-09-13]

#771 Post by swappedsr » Wed Oct 02, 2013 11:32 am

Installer doesn't work, I get

*FATAL ERORR*
Error reading MySQL install location

I am on Win 7 64 bit. I tried to install mysql beforehand like someone else here that had the issue and it gave me an error during the install process for this installer that Cacti won't work with this version of mysql. I then got the same fatal error above towards the end of the installation. Anybody know?

User avatar
BSOD2600
Cacti Moderator
Posts: 12160
Joined: Sat May 08, 2004 12:44 pm
Location: USA

Re: Windows Installer [Cacti 0.8.8a] [Updated 2012-09-13]

#772 Post by BSOD2600 » Wed Oct 02, 2013 11:57 am

swappedsr:
please attach the installer log file. Sounds like either my MySQL installer failed and/or you previously have MySQL installed which Cacti cannot detect where it resides.

swappedsr
Posts: 14
Joined: Wed Oct 02, 2013 11:28 am

Re: Windows Installer [Cacti 0.8.8a] [Updated 2012-09-13]

#773 Post by swappedsr » Wed Oct 02, 2013 12:44 pm

Here is the log. I did have mysql installed and completely removed it and completely uninstalled cacti and rebooted. I then ran the installer again, no dice.
Attachments
log.txt
(23.59 KiB) Downloaded 107 times

swappedsr
Posts: 14
Joined: Wed Oct 02, 2013 11:28 am

Re: Windows Installer [Cacti 0.8.8a] [Updated 2012-09-13]

#774 Post by swappedsr » Thu Oct 03, 2013 9:55 am

Anybody?

User avatar
BSOD2600
Cacti Moderator
Posts: 12160
Joined: Sat May 08, 2004 12:44 pm
Location: USA

Re: Windows Installer [Cacti 0.8.8a] [Updated 2012-09-13]

#775 Post by BSOD2600 » Thu Oct 03, 2013 11:39 am

MySQL was presently installed when the Cacti installer was ran. It doesnt have logic to handle this, which is why it failed.

Either completely remove it or follow the installation guide to install cacti manually.

swappedsr
Posts: 14
Joined: Wed Oct 02, 2013 11:28 am

Re: Windows Installer [Cacti 0.8.8a] [Updated 2012-09-13]

#776 Post by swappedsr » Fri Oct 04, 2013 9:22 am

Fixed, there is a registry fix that needed to be applied. I ran mysql by itself and it gave me a "Could not access network location \Hewlett-Packard\\." I googled the registry fix and the answer was here:

To fix it, go into regedit and look in the registry under these two keys:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\
If you see an "InstallLocation" value containing \Hewlett-Packard\\ just delete it. Then the software should be OK.
This value is somehow getting pulled into the MSI installer property "INSTALLDIR", though I'm not sure why. I'm also not sure why this impact some installers but not others, nor is it clear this is a bug in the installer (it sounds like an HP issue to me).

I then reran the cacti installer and it worked without a problem.

isabellaleo
Posts: 8
Joined: Mon Jan 13, 2014 1:20 pm

Re: Windows Installer [Cacti 0.8.8a] [Updated 2012-09-13]

#777 Post by isabellaleo » Thu Jan 16, 2014 7:36 am

Do i need to configure on windows the snmp services? Does it have to be activate or disable?

isabellaleo
Posts: 8
Joined: Mon Jan 13, 2014 1:20 pm

Re: Windows Installer [Cacti 0.8.8a] [Updated 2012-09-13]

#778 Post by isabellaleo » Fri Jan 17, 2014 11:02 am

Hi,im new in cacti and also with all his dependecies, so i dont know how to solve some problems.

I had installed Cacti in Windows 7 with this windows Installer, everything looks like its right, i can make graphics of my pc, they work good, but when i tried to make a graphic of the interface of a Huawei Router im not able too see the interfaces of my divice.
The SNMP looks like its working because when i create the Device i can see the inf of the Router, but i don get any data query [SNMP-Static Interfaces]. Every time i try to reload the data query i get blank pages... any idea?

I have another question, before run de installer my snmp agent was installed and running on my pc, is it ok? And does i have to be running all the time, so i need to use snmp agent and net-snmp?

User avatar
BSOD2600
Cacti Moderator
Posts: 12160
Joined: Sat May 08, 2004 12:44 pm
Location: USA

Re: Windows Installer [Cacti 0.8.8a] [Updated 2012-09-13]

#779 Post by BSOD2600 » Wed Jan 22, 2014 4:43 pm

isabellaleo wrote:Do i need to configure on windows the snmp services? Does it have to be activate or disable?
Not required to be installed on the Cacti server, but helpful.

User avatar
BSOD2600
Cacti Moderator
Posts: 12160
Joined: Sat May 08, 2004 12:44 pm
Location: USA

Re: Windows Installer [Cacti 0.8.8a] [Updated 2012-09-13]

#780 Post by BSOD2600 » Wed Jan 22, 2014 4:44 pm

isabellaleo wrote:Hi,im new in cacti and also with all his dependecies, so i dont know how to solve some problems
As your problem is not with the installer, please create your own thread after reading and following
http://forums.cacti.net/viewtopic.php?f=3&t=11747

Post Reply