Windows Installer [Cacti 1.2.5] [Updated 2019-07-18]

Post support questions that relate to the Windows 2003/2000/XP operating systems.

Moderators: Moderators, Developers

Post Reply
Author
Message
eltaskman
Posts: 1
Joined: Thu Jul 05, 2018 7:44 am

Re: Windows Installer [Cacti 1.1.38] [Updated 2018-04-15]

#946 Post by eltaskman » Thu Jul 05, 2018 7:48 am

i have just installed this realase from .exe and it doesn't work, i installed over w 2016 and iis platform. i cannot get to Access but url. it shows error 500
any idea will be apreciate

thanks in advanced

User avatar
BSOD2600
Cacti Moderator
Posts: 12160
Joined: Sat May 08, 2004 12:44 pm
Location: USA

Re: Windows Installer [Cacti 1.1.38] [Updated 2018-04-15]

#947 Post by BSOD2600 » Thu Sep 13, 2018 10:14 am

For the MySQL issues, I'm currently looking into them.
The pro/con of using their Web Installer, is the code is always up to date... including bugs. In the process of finding reliable workarounds to these. Once thats done an update will released.

bobbomo
Posts: 4
Joined: Fri Oct 26, 2018 8:28 am

Re: Windows Installer [Cacti 1.1.38] [Updated 2018-04-15]

#948 Post by bobbomo » Fri Oct 26, 2018 8:39 am

@BSOD2600, I noticed the defaults file my.ini changed location from "C:\Program Files\MySQL Server 5.7\my.ini" to "C:\ProgramData\MySQL\MySQL Server 5.7\my.ini".

User avatar
BSOD2600
Cacti Moderator
Posts: 12160
Joined: Sat May 08, 2004 12:44 pm
Location: USA

Re: Windows Installer [Cacti 1.1.38] [Updated 2018-04-15]

#949 Post by BSOD2600 » Mon Dec 31, 2018 10:26 am

bobbomo wrote:@BSOD2600, I noticed the defaults file my.ini changed location from "C:\Program Files\MySQL Server 5.7\my.ini" to "C:\ProgramData\MySQL\MySQL Server 5.7\my.ini".
The location has been changed by the MySQL installer, not this one. It's a better and more correctly suited location anyways.

dfp
Posts: 10
Joined: Mon Apr 24, 2006 7:39 am

Re: Windows Installer [Cacti 1.1.38] [Updated 2018-04-15]

#950 Post by dfp » Sat Jan 05, 2019 5:52 pm

I have a problem with 1.1.38 installed with mysql

Configuring MySQL Server 5.7.21
Stopping Server [if necessary] - Done!
Writing configuration file - Done!
Updating firewall-\| - Done!
Adjusting Windows service [if necessary] - Done!
Initializing Database [if necessary]/- - Error!
Configuration of MySQL Server 5.7.21 has completed unsuccessfully! (Check log for more details)
Finished configuring all selected products.
Configuring MySQL...
Stopping MySQL...
MySQL Stopped
Writing my.ini...
Starting MySQL...
MySQL Started
Installing Cacti DB
Output folder: C:\Users\ADMINI~1.BL\AppData\Local\Temp\nsc1B4F.tmp
Extract: timezone_posix.sql... 100%
Installing timezone_posix.sql
"DEBUG: "C:\Program Files\MySQL\MySQL Server 5.7\\bin\mysql" -u root --password=OzV21HjhVb -e "SOURCE C:\Users\ADMINI~1.BL\AppData\Local\Temp\nsc1B4F.tmp\timezone_posix.sql" mysql
mysql: [Warning] C:\Program Files\MySQL\MySQL Server 5.7\\bin\mysql: ignoring option '--no-beep' due to invalid value ''
mysql: [Warning] Using a password on the command line interface can be insecure.
ERROR 2003 (HY000): Can't connect to MySQL server on 'localhost' (10061)
Return value: 1
Installing cacti.sql
"DEBUG: C:\Program Files\MySQL\MySQL Server 5.7\\bin\mysqladmin" -u root --password=OzV21HjhVb create cacti
"DEBUG: C:\Program Files\MySQL\MySQL Server 5.7\\bin\mysql" -u root --password=OzV21HjhVb -e "SOURCE C:\Inetpub\wwwroot\cacti\cacti.sql" cacti
mysqladmin: [Warning] Using a password on the command line interface can be insecure.
mysqladmin: connect to server at 'localhost' failed
error: 'Can't connect to MySQL server on 'localhost' (10061)'
Check that mysqld is running on localhost and that the port is 3306.
You can check this by doing 'telnet localhost 3306'
mysql: [Warning] C:\Program Files\MySQL\MySQL Server 5.7\\bin\mysql: ignoring option '--no-beep' due to invalid value ''
mysql: [Warning] Using a password on the command line interface can be insecure.
ERROR 2003 (HY000): Can't connect to MySQL server on 'localhost' (10061)
Return value: 1
Updating Cacti defaults...



If i goto the windows service it stops it straight away.

Windows Server 2019 installign with IIS

netniV
Cacti Guru User
Posts: 2808
Joined: Sun Aug 27, 2017 12:05 am

Re: Windows Installer [Cacti 1.1.38] [Updated 2018-04-15]

#951 Post by netniV » Mon Jan 07, 2019 8:20 am

I would check if MySQL 5.7 is even supported on Windows 2019... I'd be surprised if it was.


Beast
Cacti User
Posts: 65
Joined: Tue Feb 07, 2017 1:55 pm
Location: Venezuela

Re: Windows Installer [Cacti 1.2.0] [Updated 2019-01-08]

#953 Post by Beast » Sat Jan 12, 2019 9:32 am

Thanks @BSOD2600 for keep up to date this installer and great job for the new RRDTool 1.7 windows compilation. I think that you could create a copy of the new binaries in the address of the main RRDTool page binaries ( https://oss.oetiker.ch/rrdtool/download.en.html ) so more people can find it, the actual link for windows binaries is linked to cacti but to older version of RRDTool ( Cygwin Windows http://www.cacti.net/downloads/rrdtool/win32/ ).

It´s just an idea, excelent work.
Beast
GitHub: DoubleBeast

User avatar
BSOD2600
Cacti Moderator
Posts: 12160
Joined: Sat May 08, 2004 12:44 pm
Location: USA

Re: Windows Installer [Cacti 1.2.0] [Updated 2019-01-08]

#954 Post by BSOD2600 » Sat Jan 12, 2019 2:40 pm

The rrdtool compiled versions included in the installer are posted, just in a different location :)

https://www.cacti.net/downloads/packages/Windows/

kelbyc
Cacti User
Posts: 50
Joined: Mon Nov 28, 2005 8:50 am

Re: Windows Installer [Cacti 1.2.0] [Updated 2019-01-08]

#955 Post by kelbyc » Mon Jan 14, 2019 4:25 pm

I did a fresh install of the latest release on Windows 2012. Everything works well except when I change the poller to use Spine. Spine works when run manually from the command line but when I change to spine from within the Cacti UI my graphs stop updating. Debug log doesn't show anything useful. I have confirmed the paths are correct. Any idea what might be wrong? I'm running the 1.2.0 Development release of Spine.

netniV
Cacti Guru User
Posts: 2808
Joined: Sun Aug 27, 2017 12:05 am

Re: Windows Installer [Cacti 1.2.0] [Updated 2019-01-08]

#956 Post by netniV » Tue Jan 15, 2019 4:37 am

When you run it manually, are you running it as the same user that is running the website? Make sure you are using the runas/user:<user> spine.exe (where <user> is the website user, assuming that is what is being used from the task scheduler).

My knowledge of the windows side is lacking at the moment but I am planning on improving that over the next month.

vgauthier
Posts: 5
Joined: Thu Jan 31, 2019 8:18 am

Re: Windows Installer [Cacti 1.2.0] [Updated 2019-01-08]

#957 Post by vgauthier » Thu Jan 31, 2019 1:02 pm

Hi, I just downloaded and installed your Cacti 1.2.0 installer. Everything seems like it worked perfectly. However, when I launched cacti for the first time and entered in the randomly generated cacti administrator password, it tells me that it is incorrect. How can I change the password so I can get in? Thanks in advance.

User avatar
BSOD2600
Cacti Moderator
Posts: 12160
Joined: Sat May 08, 2004 12:44 pm
Location: USA

Re: Windows Installer [Cacti 1.2.1] [Updated 2019-01-31]

#958 Post by BSOD2600 » Fri Feb 01, 2019 10:56 am

vgauthier:
are you sure you didnt copy any trailing spaces for the password?
What language is your OS and keyboard?

vgauthier
Posts: 5
Joined: Thu Jan 31, 2019 8:18 am

Re: Windows Installer [Cacti 1.2.1] [Updated 2019-01-31]

#959 Post by vgauthier » Fri Feb 01, 2019 11:20 am

Positive about the spaces as I tried both pasting and typing in the password. I'm running this on a Windows 2012 R2 server with standard English keyboard.

vgauthier
Posts: 5
Joined: Thu Jan 31, 2019 8:18 am

Re: Windows Installer [Cacti 1.2.1] [Updated 2019-01-31]

#960 Post by vgauthier » Fri Feb 01, 2019 1:01 pm

I rebuilt the server and ran the install again. This time I had no issues and I'm ready to configure graphs in Cacti. Thanks for making the install so simple!

Post Reply