Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Wed Aug 23, 2017 6:07 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 7 posts ] 
Author Message
 Post subject: [solved] Cacti Mail not working with SMTP settings
PostPosted: Wed Aug 02, 2017 4:12 am 
Offline

Joined: Fri Mar 17, 2017 8:59 am
Posts: 16
Hi,

Cacti emails are not working with SMTP settings on version 1.1.13. I am using the same settings across the different application and servers however getting error with cacti only. Below is the result of the test email.

Checking Configuration...
Method: SMTP
Ping Results: SMTP error: Authentication failed: 250-SIZE 26214400 250-PIPELINING 250-DSN 250-ENHANCEDSTATUSCODES 250-STARTTLS 250-X-ANONYMOUSTLS 250-X-EXPS GSSAPI NTLM 250-8BITMIME 250-BINARYMIME 250-CHUNKING 250 XRDST
Message Not Sent due to ping failure.

Please help if any specific settings needs to be done to get the email working from cacti.

Regards
Ravi


Last edited by RaviKant on Wed Aug 09, 2017 4:56 am, edited 1 time in total.

Top
 Profile  
 
 Post subject: Re: Cacti Mail not working with SMTP settings
PostPosted: Fri Aug 04, 2017 1:12 am 
Offline

Joined: Fri Mar 17, 2017 8:59 am
Posts: 16
Hello Everyone,

Please help me to resolve this mail issue.

Regards
Ravi


Top
 Profile  
 
 Post subject: Re: Cacti Mail not working with SMTP settings
PostPosted: Fri Aug 04, 2017 10:04 am 
Offline
Cacti Moderator
User avatar

Joined: Sat May 08, 2004 12:44 pm
Posts: 12130
Location: USA
are you certain the mail server is reachable from the cacti server? that error states both a ping and authentication failures.

_________________

| Scripts: Monitor processes | RFC1213 MIB | DOCSIS Stats | Dell PowerEdge | Speedfan | APC UPS | DOCSIS CMTS | 3ware | Motorola Canopy |
| Guides: Windows Install | [HOWTO] Debug Windows NTFS permission problems |
| Tools: Windows All-in-one Installer |


Top
 Profile  
 
 Post subject: Re: Cacti Mail not working with SMTP settings
PostPosted: Wed Aug 09, 2017 4:29 am 
Offline

Joined: Fri Mar 17, 2017 8:59 am
Posts: 16
Test email via power shell is working fine which eliminates any communication issue in between cacti server and the mail server.

Send-MailMessage -SmtpServer 10.202.48.52 -To [email protected] -From [email protected]@cadence.com -Subject "test email" -Body "This is a test email"

Does any specific settings needed for windows machines? I read post related to cacti installation on CentOS:

Hello,

I just recently (3/22/17) built a new Cacti server on CentOS 7 and have been having some issues with email alerts. Previously I was using SMTP authentication with a blank username and password on the older Cacti Server (0.8.8 ). This still works great, I can send test emails all day with these SMTP settings. If I try to use the exact same settings on the 1.0.4 Cacti instance, I am getting the error: Ping Results: SMTP error: Connect Failed. Message Not Sent due to ping failure". I saw here ( https://github.com/Cacti/cacti/issues/243 ) that this issue had been brought up and closed in the 1.0.0 version. I can ping and telnet to our mail server on port 25 and I have tried using an email account on that exchange server as well and I still get this ping error. The older Cacti server is alerting just fine over unauthenticated SMTP. I've even been messing with sendmail a bit for an alternate route but even though I can use sendmail directly from the server to myself (through our exchange server), the application never produces a test email.


--update
This was resolved by letting the HTTPD service to ping and network connect. doh.

setsebool -P httpd_can_network_connect 1
setsebool -P nis_enabled 1
setsebool -P httpd_can_sendmail 1

Regards
Ravi


Top
 Profile  
 
 Post subject: Re: Cacti Mail not working with SMTP settings
PostPosted: Wed Aug 09, 2017 4:29 am 
Offline

Joined: Fri Mar 17, 2017 8:59 am
Posts: 16
Test email via power shell is working fine which eliminates any communication issue in between cacti server and the mail server.

Send-MailMessage -SmtpServer 10.202.48.52 -To [email protected] -From [email protected]@cadence.com -Subject "test email" -Body "This is a test email"

Does any specific settings needed for windows machines? I read post related to cacti installation on CentOS:

Hello,

I just recently (3/22/17) built a new Cacti server on CentOS 7 and have been having some issues with email alerts. Previously I was using SMTP authentication with a blank username and password on the older Cacti Server (0.8.8 ). This still works great, I can send test emails all day with these SMTP settings. If I try to use the exact same settings on the 1.0.4 Cacti instance, I am getting the error: Ping Results: SMTP error: Connect Failed. Message Not Sent due to ping failure". I saw here ( https://github.com/Cacti/cacti/issues/243 ) that this issue had been brought up and closed in the 1.0.0 version. I can ping and telnet to our mail server on port 25 and I have tried using an email account on that exchange server as well and I still get this ping error. The older Cacti server is alerting just fine over unauthenticated SMTP. I've even been messing with sendmail a bit for an alternate route but even though I can use sendmail directly from the server to myself (through our exchange server), the application never produces a test email.


--update
This was resolved by letting the HTTPD service to ping and network connect. doh.

setsebool -P httpd_can_network_connect 1
setsebool -P nis_enabled 1
setsebool -P httpd_can_sendmail 1

Regards
Ravi


Top
 Profile  
 
 Post subject: Re: Cacti Mail not working with SMTP settings
PostPosted: Wed Aug 09, 2017 4:29 am 
Offline

Joined: Fri Mar 17, 2017 8:59 am
Posts: 16
Test email via power shell is working fine which eliminates any communication issue in between cacti server and the mail server.

Send-MailMessage -SmtpServer 10.202.48.52 -To [email protected] -From [email protected]@cadence.com -Subject "test email" -Body "This is a test email"

Does any specific settings needed for windows machines? I read post related to cacti installation on CentOS:

Hello,

I just recently (3/22/17) built a new Cacti server on CentOS 7 and have been having some issues with email alerts. Previously I was using SMTP authentication with a blank username and password on the older Cacti Server (0.8.8 ). This still works great, I can send test emails all day with these SMTP settings. If I try to use the exact same settings on the 1.0.4 Cacti instance, I am getting the error: Ping Results: SMTP error: Connect Failed. Message Not Sent due to ping failure". I saw here ( https://github.com/Cacti/cacti/issues/243 ) that this issue had been brought up and closed in the 1.0.0 version. I can ping and telnet to our mail server on port 25 and I have tried using an email account on that exchange server as well and I still get this ping error. The older Cacti server is alerting just fine over unauthenticated SMTP. I've even been messing with sendmail a bit for an alternate route but even though I can use sendmail directly from the server to myself (through our exchange server), the application never produces a test email.


--update
This was resolved by letting the HTTPD service to ping and network connect. doh.

setsebool -P httpd_can_network_connect 1
setsebool -P nis_enabled 1
setsebool -P httpd_can_sendmail 1

Regards
Ravi


Top
 Profile  
 
 Post subject: Re: Cacti Mail not working with SMTP settings
PostPosted: Wed Aug 09, 2017 4:29 am 
Offline

Joined: Fri Mar 17, 2017 8:59 am
Posts: 16
Test email via power shell is working fine which eliminates any communication issue in between cacti server and the mail server.

Send-MailMessage -SmtpServer 10.202.48.52 -To [email protected] -From [email protected]@cadence.com -Subject "test email" -Body "This is a test email"

Does any specific settings needed for windows machines? I read below post related to cacti installation on CentOS:

Hello,

I just recently (3/22/17) built a new Cacti server on CentOS 7 and have been having some issues with email alerts. Previously I was using SMTP authentication with a blank username and password on the older Cacti Server (0.8.8 ). This still works great, I can send test emails all day with these SMTP settings. If I try to use the exact same settings on the 1.0.4 Cacti instance, I am getting the error: Ping Results: SMTP error: Connect Failed. Message Not Sent due to ping failure". I saw here ( https://github.com/Cacti/cacti/issues/243 ) that this issue had been brought up and closed in the 1.0.0 version. I can ping and telnet to our mail server on port 25 and I have tried using an email account on that exchange server as well and I still get this ping error. The older Cacti server is alerting just fine over unauthenticated SMTP. I've even been messing with sendmail a bit for an alternate route but even though I can use sendmail directly from the server to myself (through our exchange server), the application never produces a test email.


--update
This was resolved by letting the HTTPD service to ping and network connect. doh.

setsebool -P httpd_can_network_connect 1
setsebool -P nis_enabled 1
setsebool -P httpd_can_sendmail 1

Regards
Ravi


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: Majestic-12 [Bot] and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group