PHP query script hangs (works on command line)

Post support questions that relate to the Windows 2003/2000/XP operating systems.

Moderators: Moderators, Developers

Post Reply
Author
Message
Deano
Cacti User
Posts: 101
Joined: Wed Oct 29, 2003 7:08 am
Contact:

PHP query script hangs (works on command line)

#1 Post by Deano » Thu Jan 22, 2004 3:08 pm

Ok been using Cacti on Linux for a while. Now got it running on my Home Win2K Server.

Cacti installed, fell over CGI/ISAPI bug now running CGI Ok. Cacti happily polling local Server for disk space (PHP scripts!) etc and interfaces. Also polling local Cisco router via SNMP.

Just writing a new Query though. Query script runs fine for all modes (index , query, get) from a dos box - but cacti hangs whenever it tries to run the script from the polling hosts screen. Eventually get a CGI timed out message. I've double checked my XML etc.

Can anyone point me too IIS or PHP logfiles which might give me a clue as to whats going on - or permissions I should be checking etc ?

Thanks

Deano

Deano
Cacti User
Posts: 101
Joined: Wed Oct 29, 2003 7:08 am
Contact:

#2 Post by Deano » Thu Jan 22, 2004 3:32 pm

Bugger. Now no PHP script based query will run - not even the disk/cpu ones - and they have been working. :(

Deano

Deano
Cacti User
Posts: 101
Joined: Wed Oct 29, 2003 7:08 am
Contact:

#3 Post by Deano » Mon Jan 26, 2004 6:59 pm

My Win32 setup wont run php.exe from a PHP exec() call - With even the simplest of test scripts (completely outside Cacti) - a whole heap pf php.exe tasks get created until the whole thing dies.

It will however run cli/php.exe.

Changing the Cacti php binary path to c:/usr/php/cli/php.exe has bought everything to life. Is this normal !?!

Thanks
Deano

Post Reply