Trying to migrate from cmd.php to Spine - Devices down issue

Post support questions that relate to the Windows 2003/2000/XP operating systems.

Moderators: Moderators, Developers

Post Reply
Author
Message
jround
Posts: 8
Joined: Thu Mar 16, 2017 6:20 am

Trying to migrate from cmd.php to Spine - Devices down issue

#1 Post by jround » Wed Nov 28, 2018 9:29 am

Running Cacti 1.1.38

SNMP Version 5.5
Spine 1.1.36

378 devices, a mix of Windows servers (SNMPv2) and network switches (SNMPv2/v3)

cmd polling was working, but as we have added devices bit by bit it is now starting to not complete within 5 minutes. So I thought try switching to the Spine poller.

The issue is weirdly every poll run it seems to keep thinking various devices are DOWN, it seems a bit random as to the devices picked too. When you go into them manually in Cacti the SNMP summary and ping response at the top is fine (ping is set for ICMP and responds well under the 500ms timeout)

Spine.exe when run manually also comes up with a lot of 'use snmp_sess_select_info2() for processing large file descriptors' errors

So wondering where I am going wrong as this would otherwise be a much faster poller! :)

netniV
Cacti Guru User
Posts: 2691
Joined: Sun Aug 27, 2017 12:05 am

Re: Trying to migrate from cmd.php to Spine - Devices down i

#2 Post by netniV » Thu Nov 29, 2018 3:29 am

Make sure you are using the same version of spine as you are Cacti. This ensures that you have alignment between the database and function calls being made.

Try to also see if there is an update for net-snmp on your system (you haven't said what the OS is).

Post Reply