Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Sun Jan 21, 2018 3:36 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 13 posts ] 
Author Message
 Post subject: [QUERY] PHP Mail() Function
PostPosted: Mon Mar 13, 2017 3:19 am 
Offline
Cacti User

Joined: Wed Nov 23, 2016 2:42 am
Posts: 68
I am trying to try use cacti reporting by sending email to us annually to our e-mail.
Cacti is upgraded into 1.1.16.

Currently the test ping is successful but no email received in my inbox / spam.

This is the settings :

- php.ini :
SMTP : localhost
SMTP_Port : 25

sendmail_from = [email protected]


Last edited by zetoo on Thu Dec 07, 2017 11:49 pm, edited 1 time in total.

Top
 Profile  
 
 Post subject: Re: [HELP] PHP Mail() Function does not work
PostPosted: Mon Oct 02, 2017 10:20 pm 
Offline
Cacti User

Joined: Wed Nov 23, 2016 2:42 am
Posts: 68
Someone please help me :(


Top
 Profile  
 
 Post subject: Re: [HELP] PHP Mail() Function does not work
PostPosted: Mon Oct 02, 2017 10:29 pm 
Offline
Developer

Joined: Thu Apr 07, 2005 3:29 pm
Posts: 2661
Location: B/CS Texas
You need to configure your server so that your mail daemon of choice works on it. There are ~1 million or more how-to's on Google on how to do this. No reason to rehash all of them here. Especially since you don't list anything at all about the OS that you are running on.

_________________
Report a bug
Download Releases
1.X Compatible Plugins


Top
 Profile  
 
 Post subject: Re: [HELP] PHP Mail() Function does not work
PostPosted: Wed Oct 11, 2017 10:34 pm 
Offline
Cacti User

Joined: Wed Nov 23, 2016 2:42 am
Posts: 68
cigamit wrote:
You need to configure your server so that your mail daemon of choice works on it. There are ~1 million or more how-to's on Google on how to do this. No reason to rehash all of them here. Especially since you don't list anything at all about the OS that you are running on.


Yes, finally i can configure the server and set it up to send monthly report. Thanks alot cigamit !

Have mercy on me :oops:


Top
 Profile  
 
 Post subject: Re: [HELP] PHP Mail() Function does not work
PostPosted: Wed Oct 11, 2017 10:50 pm 
Offline
Cacti User

Joined: Wed Nov 23, 2016 2:42 am
Posts: 68
Anyone know why the image I got is broken image for JPG and GIF? (Attached or Inline)


My technical supports :
Cacti 1.1.16
Spine 1.1.13
RRDTool 1.4.5 VC10
Net-SNMP 5.5.0-2
MySQL 5.7.16
PHP 5.5.33
IIS 8.5
Window Server 2012


Top
 Profile  
 
 Post subject: Re: [HELP] PHP Mail() Function does not work
PostPosted: Tue Oct 17, 2017 9:22 am 
Offline
Cacti Moderator
User avatar

Joined: Sat May 08, 2004 12:44 pm
Posts: 12147
Location: USA
what does the rrdtool output / error show?

_________________

| Scripts: Monitor processes | RFC1213 MIB | DOCSIS Stats | Dell PowerEdge | Speedfan | APC UPS | DOCSIS CMTS | 3ware | Motorola Canopy |
| Guides: Windows Install | [HOWTO] Debug Windows NTFS permission problems |
| Tools: Windows All-in-one Installer |


Top
 Profile  
 
 Post subject: Re: [HELP] PHP Mail() Function does not work
PostPosted: Tue Oct 17, 2017 9:54 pm 
Offline
Cacti User

Joined: Wed Nov 23, 2016 2:42 am
Posts: 68
BSOD2600 wrote:
what does the rrdtool output / error show?


The mail is sent successfully but no image is attached or inline on e-mail report.

The JPEG or GIF is only showing "Error while opening" but PNG is showing :o


Top
 Profile  
 
 Post subject: Re: [HELP] PHP Mail() Function does not work
PostPosted: Fri Oct 20, 2017 8:52 am 
Offline
Cacti Moderator
User avatar

Joined: Sat May 08, 2004 12:44 pm
Posts: 12147
Location: USA
zetoo wrote:
The JPEG or GIF is only showing "Error while opening" but PNG is showing :o

screenshot and exact error message from rrdtool please.

_________________

| Scripts: Monitor processes | RFC1213 MIB | DOCSIS Stats | Dell PowerEdge | Speedfan | APC UPS | DOCSIS CMTS | 3ware | Motorola Canopy |
| Guides: Windows Install | [HOWTO] Debug Windows NTFS permission problems |
| Tools: Windows All-in-one Installer |


Top
 Profile  
 
 Post subject: Re: [HELP] PHP Mail() Function does not work
PostPosted: Sun Oct 29, 2017 9:51 pm 
Offline
Cacti User

Joined: Wed Nov 23, 2016 2:42 am
Posts: 68
BSOD2600 wrote:
zetoo wrote:
The JPEG or GIF is only showing "Error while opening" but PNG is showing :o

screenshot and exact error message from rrdtool please.


This is what I got.


Attachments:
Cacti - Error while opening.jpg
Cacti - Error while opening.jpg [ 25.55 KiB | Viewed 306 times ]
RRDTool Output.txt [5.88 KiB]
Downloaded 10 times
Top
 Profile  
 
 Post subject: Re: [HELP] PHP Mail() Function does not work
PostPosted: Sat Nov 04, 2017 12:14 pm 
Offline
Cacti Moderator
User avatar

Joined: Sat May 08, 2004 12:44 pm
Posts: 12147
Location: USA
are you able to view the images on Cacti without error?

_________________

| Scripts: Monitor processes | RFC1213 MIB | DOCSIS Stats | Dell PowerEdge | Speedfan | APC UPS | DOCSIS CMTS | 3ware | Motorola Canopy |
| Guides: Windows Install | [HOWTO] Debug Windows NTFS permission problems |
| Tools: Windows All-in-one Installer |


Top
 Profile  
 
 Post subject: Re: [HELP] PHP Mail() Function does not work
PostPosted: Sun Nov 05, 2017 10:38 pm 
Offline
Cacti User

Joined: Wed Nov 23, 2016 2:42 am
Posts: 68
BSOD2600 wrote:
are you able to view the images on Cacti without error?


Yes, its perfect on Cacti
But when i send it to my mail, those error message appear.

Kinda confused why since I can send jpg image from one e-mail to other.


Top
 Profile  
 
 Post subject: Re: [HELP] PHP Mail() Function does not work
PostPosted: Sat Nov 11, 2017 2:07 am 
Offline
Cacti Moderator
User avatar

Joined: Sat May 08, 2004 12:44 pm
Posts: 12147
Location: USA
Is it possible your email client is blocking the images? Tried sending to a different domain?
Tried updating to the latest Cacti?

_________________

| Scripts: Monitor processes | RFC1213 MIB | DOCSIS Stats | Dell PowerEdge | Speedfan | APC UPS | DOCSIS CMTS | 3ware | Motorola Canopy |
| Guides: Windows Install | [HOWTO] Debug Windows NTFS permission problems |
| Tools: Windows All-in-one Installer |


Top
 Profile  
 
 Post subject: Re: [HELP] PHP Mail() Function does not work
PostPosted: Wed Dec 06, 2017 10:39 pm 
Offline
Cacti User

Joined: Wed Nov 23, 2016 2:42 am
Posts: 68
I will try 1.1.28 since phpmail is updated.

Does anyone know how to edit php mail body format for system monitoring warning/alert mail ?

Since i cant found it on Cacti folder or Settings or Reporting/Nectar Tab. :roll:

BSOD2600 wrote:
Is it possible your email client is blocking the images? Tried sending to a different domain?
Tried updating to the latest Cacti?


any idea BSOD2600?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 13 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group