Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Sun Nov 18, 2018 9:57 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 82 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6  Next
Author Message
 Post subject: Re: cacti DB failed, updgrade lost everything
PostPosted: Tue Jan 09, 2018 12:36 pm 
Offline
Cacti User

Joined: Tue Aug 26, 2014 2:58 pm
Posts: 58
cmd poller seems to be working.. for the most part.. but some graphs don't work..
when I set it to spine, nothing gets graphed.. id rather use spine.


Top
 Profile  
 
 Post subject: Re: cacti DB failed, updgrade lost everything
PostPosted: Tue Jan 09, 2018 12:56 pm 
Offline
Cacti Guru User

Joined: Sun Aug 27, 2017 12:05 am
Posts: 1693
What errors does spine give? Did you configure the database settings in the spine configuration?

_________________
Official Cacti Developer

Cacti Resources:
Cacti Website (including releases)
Cacti Issues
Cacti Development Releases
Cacti Development Documentation

My resources:
How to submit Pull Requests
Development Wiki and How To's
Updated NetSNMP Memory template for Cacti 1.x
Cisco SFP template for Cacti 0.8.8


Top
 Profile  
 
 Post subject: Re: cacti DB failed, updgrade lost everything
PostPosted: Tue Jan 09, 2018 1:02 pm 
Offline
Cacti User

Joined: Tue Aug 26, 2014 2:58 pm
Posts: 58
when I installed it, I used the cacti windows installer , which is supposed to do everything for you.. at least the last version did.. what do I have to do for spine's config"?


Top
 Profile  
 
 Post subject: Re: cacti DB failed, updgrade lost everything
PostPosted: Tue Jan 09, 2018 2:06 pm 
Offline
Cacti User

Joined: Tue Aug 26, 2014 2:58 pm
Posts: 58
this is a plug in I found particularly useful
https://docs.cacti.net/userplugin:intropage


Top
 Profile  
 
 Post subject: Re: cacti DB failed, updgrade lost everything
PostPosted: Tue Jan 09, 2018 2:26 pm 
Offline
Cacti User

Joined: Tue Aug 26, 2014 2:58 pm
Posts: 58
ha! ok I get it.. found some plug ins I may use from github.. I tried webseer.. had some issues removed it.
now for some ODD reason I cant get to the settings page.. HTTP 500 error.. might have to reboot my sad computer LOL


Top
 Profile  
 
 Post subject: Re: cacti DB failed, updgrade lost everything
PostPosted: Tue Jan 09, 2018 2:49 pm 
Offline
Cacti Guru User

Joined: Sun Aug 27, 2017 12:05 am
Posts: 1693
The itntropage plugin is this one I believe
https://github.com/xmacan/plugin_intropage

_________________
Official Cacti Developer

Cacti Resources:
Cacti Website (including releases)
Cacti Issues
Cacti Development Releases
Cacti Development Documentation

My resources:
How to submit Pull Requests
Development Wiki and How To's
Updated NetSNMP Memory template for Cacti 1.x
Cisco SFP template for Cacti 0.8.8


Top
 Profile  
 
 Post subject: Re: cacti DB failed, updgrade lost everything
PostPosted: Tue Jan 09, 2018 2:55 pm 
Offline
Cacti User

Joined: Tue Aug 26, 2014 2:58 pm
Posts: 58
yeah that was it.. I had it in.. I was getting heavily into fixing some of my graph issues, when my settings went bye bye LOL
I cant get into the settings at all.. error 500.. may have to go backwards in my setup.
I was trying to figure out why my email notifications weren't working. noticed "monitor" wasn't there. I installed it from the plugins.. but wasn't getting notifications..
now I cant get in to check my settings. monitor is the only plug in listed as enabled.


Top
 Profile  
 
 Post subject: Re: cacti DB failed, updgrade lost everything
PostPosted: Tue Jan 09, 2018 4:12 pm 
Offline
Cacti Guru User

Joined: Sun Aug 27, 2017 12:05 am
Posts: 1693
If you are getting error 500, that is internal server error and usually means something is falling over. That will be in the website logs, as it's IIS, this may even be in the eventlogs under Application or System.

_________________
Official Cacti Developer

Cacti Resources:
Cacti Website (including releases)
Cacti Issues
Cacti Development Releases
Cacti Development Documentation

My resources:
How to submit Pull Requests
Development Wiki and How To's
Updated NetSNMP Memory template for Cacti 1.x
Cisco SFP template for Cacti 0.8.8


Top
 Profile  
 
 Post subject: Re: cacti DB failed, updgrade lost everything
PostPosted: Wed Jan 10, 2018 7:38 am 
Offline
Cacti User

Joined: Tue Aug 26, 2014 2:58 pm
Posts: 58
yeah I went back and re did my steps.. got back up and running..
my next issue is getting Monitor to work.. I guess the old plug in LOOKS like its compatible.. but it requires thold.. and thold requires the old settings plug in.
I cant get thold or settings working, based on the GUI im looking at.
so I uninstalled thold and monitor, downloaded the versions for github
monitor needs thold to install.. and the version on github for thold tells me "Not Compatible, Requires: Cacti >= 1.1.4" is there a download spot for thold for Version 1.1.29?


Top
 Profile  
 
 Post subject: Re: cacti DB failed, updgrade lost everything
PostPosted: Wed Jan 10, 2018 8:22 am 
Offline
Cacti User

Joined: Tue Aug 26, 2014 2:58 pm
Posts: 58
got it.. found the answer.. new functions.php file.. waiting to see if my monitor notifications.. work
hey .. thanks so far for ALL your help.. still working through some issues.. like I didn't know the "old" ways of using spine changed and that I had to do compiling to make spine work for this new version. I went to spine years ago because the cmd.php poller stopped working and spine worked perfectly.. im back to the default poller for now.


Top
 Profile  
 
 Post subject: Re: cacti DB failed, updgrade lost everything
PostPosted: Wed Jan 10, 2018 8:33 am 
Offline
Cacti User

Joined: Tue Aug 26, 2014 2:58 pm
Posts: 58
ok monitor isn't sending alerts. I can send a test email and my nectar reports get sent..
I click save on my settings\mail setup and I get this error.. but everything looks correct to me
error: forms types dirpath and filepath must point to a valid directory or file


Top
 Profile  
 
 Post subject: Re: cacti DB failed, updgrade lost everything
PostPosted: Wed Jan 10, 2018 8:51 am 
Offline
Cacti Guru User

Joined: Sun Aug 27, 2017 12:05 am
Posts: 1693
The "Sendmail Path" is the only item that sets a path on the mail tab and it defaults to /usr/sbin/sendmail

If you haven't changed it from that, it shouldn't report an error.

_________________
Official Cacti Developer

Cacti Resources:
Cacti Website (including releases)
Cacti Issues
Cacti Development Releases
Cacti Development Documentation

My resources:
How to submit Pull Requests
Development Wiki and How To's
Updated NetSNMP Memory template for Cacti 1.x
Cisco SFP template for Cacti 0.8.8


Top
 Profile  
 
 Post subject: Re: cacti DB failed, updgrade lost everything
PostPosted: Wed Jan 10, 2018 9:43 am 
Offline
Cacti User

Joined: Tue Aug 26, 2014 2:58 pm
Posts: 58
I have it using SMTP. .and I JUST got a host up notification from a test host that I had in downed status.


Top
 Profile  
 
 Post subject: Re: cacti DB failed, updgrade lost everything
PostPosted: Wed Jan 10, 2018 9:47 am 
Offline
Cacti User

Joined: Tue Aug 26, 2014 2:58 pm
Posts: 58
I think I may have to either re import, or look for new templates for my EXSI hosts, and a TCP script for this new version. my CLOG shows these errors, and thus far are my only errors that I can detect in the CLOG
2018/01/10 08:45:35 - CMDPHP PHP ERROR NOTICE Backtrace: (C:\inetpub\wwwroot\cacti\script_server.php: 223 TCP)(C:\inetpub\wwwroot\cacti\scripts\tcp.php: 32 CactiErrorHandler)(C:\inetpub\wwwroot\cacti\lib\functions.php: 4434 cacti_debug_backtrace)
2018/01/10 08:45:35 - ERROR PHP NOTICE: Undefined variable: val_limite in file: C:\inetpub\wwwroot\cacti\scripts\tcp.php on line: 32

2018/01/10 08:45:25 - CMDPHP PHP ERROR NOTICE Backtrace: (C:\inetpub\wwwroot\cacti\script_server.php: 223 ss_esxi_vhosts)(C:\inetpub\wwwroot\cacti\scripts\ss_esxi_vhosts.php: 42 CactiErrorHandler)(C:\inetpub\wwwroot\cacti\lib\functions.php: 4434 cacti_debug_backtrace)
2018/01/10 08:45:25 - ERROR PHP NOTICE: Use of undefined constant value - assumed 'value' in file: C:\inetpub\wwwroot\cacti\scripts\ss_esxi_vhosts.php on line: 42


Top
 Profile  
 
 Post subject: Re: cacti DB failed, updgrade lost everything
PostPosted: Wed Jan 10, 2018 10:49 am 
Offline
Cacti User

Joined: Tue Aug 26, 2014 2:58 pm
Posts: 58
while cacti will notify me that hosts return to an "up" status, and I can even get a ping threshold to alert me, it does not alert me when something is "DOWN".
that's a problem.. I have a bogus device set to an IP for a device that I know is offline.. it gets an SNMP error OR a PING ICMP error.. did this on purpose so it would see a downed device.
cacti keeps showing it as "UP", and I never got an alert for it.

edit... see this in the CLOG now for some odd reason
2018/01/10 09:50:28 - CMDPHP PHP ERROR NOTICE Backtrace: (C:\inetpub\wwwroot\cacti\plugins\monitor\poller_monitor.php: 132 process_email)(C:\inetpub\wwwroot\cacti\plugins\monitor\poller_monitor.php: 430 CactiErrorHandler)(C:\inetpub\wwwroot\cacti\lib\functions.php: 4434 cacti_debug_backtrace)
2018/01/10 09:50:28 - ERROR PHP NOTICE: Undefined variable: config in file: C:\inetpub\wwwroot\cacti\plugins\monitor\poller_monitor.php on line: 430


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 82 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6  Next

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group