Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Sun Jun 24, 2018 5:00 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: RRDTool Says:...rrd': No such file or directory
PostPosted: Thu Nov 27, 2008 8:03 pm 
Offline

Joined: Wed Nov 19, 2008 4:15 pm
Posts: 41
Previously Cacti 0.8.7b, I have already installed the xampp 1.6.7 which is a application that includes a big package with php 5.2.6, Apache, filezilla and mysql all together at once, so I installed all these softwares on window xp in my computer and later, I installed the Cacti following the standard procedure led by the documentation, I started to work on it but there is a problem with my graphs, and I m afraid that is given to a error messages that comes out from the rrdtool application, the error is the following:

RRDTool Command:

c:/rrdtool/rrdtool.exe graph - \
--imgformat=PNG \
--start=-86400 \
--end=-300 \
--title="Localhost - Logged in Users" \
--rigid \
--base=1000 \
--height=120 \
--width=500 \
--alt-autoscale-max \
--lower-limit=0 \
--vertical-label="users" \
--slope-mode \
--font TITLE:12: \
--font AXIS:8: \
--font LEGEND:10: \
--font UNIT:8: \
DEF:a="C\:/xampp/htdocs/cacti/rra/localhost_users_6.rrd":users:AVERAGE \
AREA:a#4668E4FF:"Users" \
GPRINT:a:LAST:"Current\:%8.0lf" \
GPRINT:a:AVERAGE:"Average\:%8.0lf" \
GPRINT:a:MAX:"Maximum\:%8.0lf"
RRDTool Says:

ERROR: opening 'C:/xampp/htdocs/cacti/rra/localhost_users_6.rrd': No such file or directory


Top
 Profile  
 
 Post subject:
PostPosted: Fri Nov 28, 2008 9:22 am 
Offline
Developer
User avatar

Joined: Thu Dec 02, 2004 2:46 am
Posts: 22461
Location: Muenster, Germany
You double-checked that the crontab entry is in place and crond is running?
Reinhard

_________________
Official Cacti Documentation
Official Debugging Help
Central Plugin Repository
Central Templates Repository


Top
 Profile  
 
 Post subject: answer for Gandalf
PostPosted: Fri Nov 28, 2008 12:41 pm 
Offline

Joined: Wed Nov 19, 2008 4:15 pm
Posts: 41
gandalf wrote:
You double-checked that the crontab entry is in place and crond is running?
Reinhard


Gandalf, I downloaded the cron.zip from http://www.kalab.com/freeware/cron/cron.htm, I extracted it to a directory which a renamed cron, I ran the application cron.exe and automatically a cron.log file was created in that folder, I opened that log and says "28.11.2008 10:25 Cron started", that means that cron is already running, right? so I looked into the contrab.add and it says something like this:

#
# Some samples how to call the rrd log scripts from crontab.
# A Win32 cron service can be downloaded from here:
# http://www.kalab.com/freeware/cron/cron.htm
#

# start rrdtool every 5 mins
0,5,10,15,20,25,30,35,40.45,50,55 * * * * c:\rrdtool\memlog.pl
2,7,12,17,22,27,32,37,42.47,52,57 * * * * c:\rrdtool\memlog.pl

# start rrdtool every 3 mins
0,3,6,9,12,15,18,21,24,27,30,33,36,39,42,45,48,51,54,57 * * * * c:\rrdtool\memlog.pl


What comes next, I m still having the same problem, what am I doing wrong, what am I missing?


Top
 Profile  
 
 Post subject:
PostPosted: Mon Dec 01, 2008 7:45 am 
Offline
Developer
User avatar

Joined: Thu Dec 02, 2004 2:46 am
Posts: 22461
Location: Muenster, Germany
Moved to windows as I'm not familiar with the cron/at there
Reinhard

_________________
Official Cacti Documentation
Official Debugging Help
Central Plugin Repository
Central Templates Repository


Top
 Profile  
 
 Post subject:
PostPosted: Mon Dec 01, 2008 2:19 pm 
Offline
Cacti Moderator
User avatar

Joined: Sat May 08, 2004 12:44 pm
Posts: 12150
Location: USA
1) Why on earth are you using cron instead of scheduled tasks?

2) Read http://forums.cacti.net/viewtopic.php?t=11747 and repost. You really should follow my installation guide completely.

_________________

| Scripts: Monitor processes | RFC1213 MIB | DOCSIS Stats | Dell PowerEdge | Speedfan | APC UPS | DOCSIS CMTS | 3ware | Motorola Canopy |
| Guides: Windows Install | [HOWTO] Debug Windows NTFS permission problems |
| Tools: Windows All-in-one Installer |


Top
 Profile  
 
 Post subject: Re: RRDTool Says:...rrd': No such file or directory
PostPosted: Mon Jan 08, 2018 3:51 am 
Offline

Joined: Fri Jan 05, 2018 5:45 am
Posts: 1
hello All,


I also having a same issue, I have install on windows 7 x64, using xmapp but the following showing following error

RRDTool Command:
c:/rrdtool/rrdtool.exe graph - \
--imgformat=PNG \
--start=-86400 \
--end=-300 \
--title="Localhost - Logged in Users" \
--rigid \
--base=1000 \
--height=120 \
--width=500 \
--alt-autoscale-max \
--lower-limit=0 \
--vertical-label="users" \
--slope-mode \
--font TITLE:12: \
--font AXIS:8: \
--font LEGEND:10: \
--font UNIT:8: \
DEF:a="C\:/xampp/htdocs/cacti/rra/localhost_users_12.rrd":users:AVERAGE \
AREA:a#4668E4FF:"Users" \
GPRINT:a:LAST:"Current\:%8.0lf" \
GPRINT:a:AVERAGE:"Average\:%8.0lf" \
GPRINT:a:MAX:"Maximum\:%8.0lf\n"
RRDTool Says:
ERROR: opening 'C:/xampp/htdocs/cacti/rra/localhost_users_12.rrd': No such file or directory

and into graph section No graph loading,

cacti loag as following

01/08/2018 08:08:04 AM - AUTH LOGIN: User 'admin' Authenticated
01/08/2018 05:10:28 AM - AUTH LOGIN: User 'admin' Authenticated
01/05/2018 06:28:26 AM - AUTH LOGIN: User 'admin' Authenticated
01/04/2018 11:57:31 AM - AUTH LOGIN: User 'admin' Authenticated
01/04/2018 11:05:50 AM - AUTH LOGIN: User 'admin' Authenticated
01/04/2018 10:59:57 AM - AUTH LOGIN: User 'admin' Authenticated
01/04/2018 10:30:45 AM - AUTH LOGIN: User 'admin' Authenticated

POLLER cache following

Localhost - Load Average Script: perl C:/xampp/htdocs/cacti/scripts/loadavg_multi.pl
RRD: C:\xampp\htdocs\cacti\rra\localhost_load_1min_5.rrd
Localhost - Logged in Users Script: perl C:/xampp/htdocs/cacti/scripts/unix_users.pl
RRD: C:\xampp\htdocs\cacti\rra\localhost_users_6.rrd
Localhost - Memory - Free Script: perl C:/xampp/htdocs/cacti/scripts/linux_memory.pl MemFree:
RRD: C:\xampp\htdocs\cacti\rra\localhost_mem_buffers_3.rrd
Localhost - Memory - Free Script: perl C:/xampp/htdocs/cacti/scripts/linux_memory.pl MemFree:
RRD: C:\xampp\htdocs\cacti\rra\localhost_mem_buffers_16.rrd
Localhost - Memory - Free Swap Script: perl C:/xampp/htdocs/cacti/scripts/linux_memory.pl SwapFree:
RRD: C:\xampp\htdocs\cacti\rra\localhost_mem_swap_4.rrd
Localhost - Memory - Free Swap Script: perl C:/xampp/htdocs/cacti/scripts/linux_memory.pl SwapFree:
RRD: C:\xampp\htdocs\cacti\rra\localhost_mem_swap_17.rrd
Localhost - Processes Script: perl C:/xampp/htdocs/cacti/scripts/unix_processes.pl
RRD: C:\xampp\htdocs\cacti\rra\localhost_proc_7.rrd


And attached all technical support doc for more info. Request all to please help me to resolve the this issue.

Thanks to all.


Attachments:
File comment: cacti technical report
Cactiinfo.pdf [121.83 KiB]
Downloaded 12 times
File comment: cacti technical log
Cactiinfo.pdf [121.83 KiB]
Downloaded 9 times
Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group