RRDTool Says:...rrd': No such file or directory

Post support questions that relate to the Windows 2003/2000/XP operating systems.

Moderators: Moderators, Developers

Post Reply
Author
Message
sakurasanta86
Posts: 1
Joined: Fri Apr 06, 2018 11:48 pm

RRDTool Says:...rrd': No such file or directory

#1 Post by sakurasanta86 » Fri Apr 06, 2018 11:50 pm

Previously Cacti 0.8.7b, I have already installed the xampp 1.6.7 which is a application that includes a big package with php 5.2.6, Apache, filezilla and mysql all together at once, so I installed all these softwares on window xp in my computer and later, I installed the Cacti following the standard procedure led by the documentation, I started to work on it but there is a problem with my graphs, and I m afraid that is given to a error messages that comes out from the rrdtool application, the error is the following:

RRDTool Command:

c:/rrdtool/rrdtool.exe graph - \
--imgformat=PNG \
--start=-86400 \
--end=-300 \
--title="Localhost - Logged in Users" \
--rigid \
--base=1000 \
--height=120 \
--width=500 \
--alt-autoscale-max \
--lower-limit=0 \
--vertical-label="users" \
--slope-mode \
--font TITLE:12: \
--font AXIS:8: \
--font LEGEND:10: \
--font UNIT:8: \
DEF:a="C\:/xampp/htdocs/cacti/rra/localhost_users_6.rrd":users:AVERAGE \
AREA:a#4668E4FF:"Users" \
GPRINT:a:LAST:"Current\:%8.0lf" \
GPRINT:a:AVERAGE:"Average\:%8.0lf" \
GPRINT:a:MAX:"Maximum\:%8.0lf"
RRDTool Says:

ERROR: opening 'C:/xampp/htdocs/cacti/rra/localhost_users_6.rrd': No such file or directory

netniV
Cacti Guru User
Posts: 2930
Joined: Sun Aug 27, 2017 12:05 am

Re: RRDTool Says:...rrd': No such file or directory

#2 Post by netniV » Sat Apr 07, 2018 6:09 am

The graph will normally be created from the RRD file. The RRD file is populated via the poller.php which is called by the task scheduler. If the poller is scheduled, then it could be that the data from the device isn't being returned properly so check your cacti logs, put the device in question into debug mode via Console -> Devices -> Edit Device or Console -> Settings -> Device Debug (if you know the id).

Also, make sure that the permissions on the RRD directory are valid for the users attempting to read/write from them. For the poller this may be a different user to the apache web user.

Post Reply