Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Mon Oct 15, 2018 8:52 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 8 posts ] 
Author Message
 Post subject: Issue with new Cacti 1.1.37
PostPosted: Thu Apr 12, 2018 2:10 am 
Offline

Joined: Thu Apr 12, 2018 1:44 am
Posts: 3
I am trying to install cacti 1.1.37 on new Windows 2012-R2 64bit server using:

- Apache 2.4.33 Win64
- PHP 7.2.4
- MySQL 5.7.21.0
- rrdtool-1.2.15

it never works with me, I have tried everything but with no luck. I reached very good place in installation of this tool till I got stuck :cry: . now I am able to add the device but no graphs template or data query appear to me.

I am attaching some picture to show what I have & hopping to find the solution here.


Thanks in advance for your support.


Attachments:
Cacti-Paths.jpg
Cacti-Paths.jpg [ 262.96 KiB | Viewed 740 times ]
Errors in Cacti logs.jpg
Errors in Cacti logs.jpg [ 556.1 KiB | Viewed 740 times ]
Adding Device 2.jpg
Adding Device 2.jpg [ 223.72 KiB | Viewed 740 times ]
Adding Device 1.jpg
Adding Device 1.jpg [ 381.3 KiB | Viewed 740 times ]
File comment: Pictures shows you the error I got in logs & the configuration in cacti.
cacti-pics.rar [910.01 KiB]
Downloaded 17 times
Top
 Profile  
 
 Post subject: Re: Issue with new Cacti 1.1.37
PostPosted: Thu Apr 12, 2018 4:15 am 
Offline
Cacti Guru User

Joined: Sun Aug 27, 2017 12:05 am
Posts: 1486
OK so not really sure about Cacti on Windows as I have never run it there. However, I will say that I can see a problem immediately with your CSRF in that it is trying to write to c:\temp and that folder either does not exist or the user that the website is running under does not have permissions to read/write/modify there.

_________________
Official Cacti Developer

Cacti Resources:
Cacti Website (including releases)
Cacti Issues
Cacti Development Releases
Cacti Development Documentation

My resources:
How to submit Pull Requests
Development Wiki and How To's
Updated NetSNMP Memory template for Cacti 1.x
Cisco SFP template for Cacti 0.8.8


Top
 Profile  
 
 Post subject: Re: Issue with new Cacti 1.1.37
PostPosted: Thu Apr 12, 2018 4:52 am 
Offline

Joined: Thu Apr 12, 2018 1:44 am
Posts: 3
Thanks netniV

the error message is cleared, but about graphs template and data query still there is no options there + the devices status it shows me Unknown


Attachments:
Cacti.jpg
Cacti.jpg [ 216.47 KiB | Viewed 731 times ]
Top
 Profile  
 
 Post subject: Re: Issue with new Cacti 1.1.37
PostPosted: Thu Apr 12, 2018 6:58 am 
Offline
Cacti User
User avatar

Joined: Fri Feb 10, 2017 2:45 pm
Posts: 144
Location: Long Island, New York, USA
I believe there will be no status until a graph is created. That was what I had experienced in the past.

_________________
See the Cacti 1.x templates I use at: http://www.camerabob.com/cacti

Live: Cacti 1.1.36 @ CentOS 7.4.1708
Test: Cacti 1.1.37 @ CentOS 7.5.1804


Top
 Profile  
 
 Post subject: Re: Issue with new Cacti 1.1.37
PostPosted: Thu Apr 12, 2018 7:32 am 
Offline
Cacti Guru User

Joined: Sun Aug 27, 2017 12:05 am
Posts: 1486
It's normal for 'Unknown' until the Poller.php has been run and created the RRD files for the graphs. The graphs status and display is then read from the RRD files. I would check that your poller is indeed running and able to create the RRD files in the <cacti>/rra folder.

_________________
Official Cacti Developer

Cacti Resources:
Cacti Website (including releases)
Cacti Issues
Cacti Development Releases
Cacti Development Documentation

My resources:
How to submit Pull Requests
Development Wiki and How To's
Updated NetSNMP Memory template for Cacti 1.x
Cisco SFP template for Cacti 0.8.8


Top
 Profile  
 
 Post subject: Re: Issue with new Cacti 1.1.37
PostPosted: Sun Apr 15, 2018 1:43 am 
Offline

Joined: Thu Apr 12, 2018 1:44 am
Posts: 3
nothing in rra folder :roll:

I followed the same steps showing in this website. I think it will never work in windows server.


Top
 Profile  
 
 Post subject: Re: Issue with new Cacti 1.1.37
PostPosted: Mon Apr 16, 2018 9:03 am 
Offline
Cacti User
User avatar

Joined: Fri Feb 10, 2017 2:45 pm
Posts: 144
Location: Long Island, New York, USA
Try opening the write permissions in the folder to 'everyone' and see if that changes things. If you do get data, find the owner of the new files and limit the writing to that user.

_________________
See the Cacti 1.x templates I use at: http://www.camerabob.com/cacti

Live: Cacti 1.1.36 @ CentOS 7.4.1708
Test: Cacti 1.1.37 @ CentOS 7.5.1804


Top
 Profile  
 
 Post subject: Re: Issue with new Cacti 1.1.37
PostPosted: Mon Apr 16, 2018 4:19 pm 
Offline
Cacti Guru User

Joined: Sun Aug 27, 2017 12:05 am
Posts: 1486
As this is a windows box, camerabob's idea isn't a bad one. Once you know what user is creating them, you can remove the everyone permission and add the creator. You will still need to allow the website user permission to read though (generally users have read access to most folders under the C:\ drive).

_________________
Official Cacti Developer

Cacti Resources:
Cacti Website (including releases)
Cacti Issues
Cacti Development Releases
Cacti Development Documentation

My resources:
How to submit Pull Requests
Development Wiki and How To's
Updated NetSNMP Memory template for Cacti 1.x
Cisco SFP template for Cacti 0.8.8


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group