Error after installation

Post support questions that relate to the Windows 2003/2000/XP operating systems.

Moderators: Moderators, Developers

Post Reply
Author
Message
nowy123321
Posts: 4
Joined: Mon Sep 17, 2018 12:02 am

Error after installation

#1 Post by nowy123321 » Mon Sep 17, 2018 12:10 am

Hello,
I have problem. I installed Cacti on Windows Server 2012. Everything was well set up during the installation, because it even wrote green. Unfortunately, after the installation such a mistake came up:

"Error
This installation is already up-to-date. Click here to use Cacti."

When I click on "Click here" nothing happens.
What can I do to fix it?

netniV
Cacti Guru User
Posts: 2809
Joined: Sun Aug 27, 2017 12:05 am

Re: Error after installation

#2 Post by netniV » Mon Sep 17, 2018 2:32 am

This would suggest that the system can't read the version from the database. As such, it's getting stuck in a loop where the global code thinks that an installation process needs to run, but the installer believes that the correct version is installed so tells you to start using it.

Check your database is up and running and can be accessed using the details put in config.php. Make sure that there is a firewall rule in place for MySQL. Check the version that is listed in the "version" table in the "cacti" column.

nowy123321
Posts: 4
Joined: Mon Sep 17, 2018 12:02 am

Re: Error after installation

#3 Post by nowy123321 » Mon Sep 17, 2018 5:07 am

It works well, thank you. Only now has another problem occurred. I do not have any graph templates at all.

netniV
Cacti Guru User
Posts: 2809
Joined: Sun Aug 27, 2017 12:05 am

Re: Error after installation

#4 Post by netniV » Mon Sep 17, 2018 6:21 am

Check that your system has a task scheduled to run poller.php and that the user this task runs as has permission to create/update the RRD's in the rra folder.

nowy123321
Posts: 4
Joined: Mon Sep 17, 2018 12:02 am

Re: Error after installation

#5 Post by nowy123321 » Tue Sep 18, 2018 1:36 am

I'm sorry, but I'm a beginner and I did not really understand :( I have to check in the Windows task scheduler? If so, I do not have anything there :( How can I add that a file with the PHP extension be launched?

User avatar
BSOD2600
Cacti Moderator
Posts: 12160
Joined: Sat May 08, 2004 12:44 pm
Location: USA

Re: Error after installation

#6 Post by BSOD2600 » Tue Sep 18, 2018 11:54 pm

nowy123321:

Did you create/configure the Windows scheduled task to run Cacti every X minutes? Docs are a wee bit dated, but the same steps apply:
https://docs.cacti.net/manual:100:1_ins ... gure_cacti

nowy123321
Posts: 4
Joined: Mon Sep 17, 2018 12:02 am

Re: Error after installation

#7 Post by nowy123321 » Fri Sep 21, 2018 6:03 am

I don't know where is it: "1. Click on Devices. Delete the Localhost device as it intended for a Linux environment. ..." ? It is on website cacti, after installation?




Edit.
Ok. I done this, but i have this problem(when wrote command to run poller.php):

C:\>php c:/inetpub/wwwroot/cacti/poller.php
s

What can i do?

Post Reply