Cacti 1.1.38-error in Data Query [SNMP - Get Processor Infom

Post support questions that relate to the Windows 2003/2000/XP operating systems.

Moderators: Moderators, Developers

Post Reply
Author
Message
georgejiang
Posts: 2
Joined: Fri Jan 18, 2019 1:46 am

Cacti 1.1.38-error in Data Query [SNMP - Get Processor Infom

#1 Post by georgejiang » Fri Jan 18, 2019 2:02 am

Hi Guys,

I'm new to cacti. I recently installed cacti 1.138 on Windows 2012 R2 server. Everything looks fine except Data Query [SNMP - Get Processor Information]. I created Graphs for Memory/Disk, looks good as usual. However when I created Graphs for CPU utilization, nothing in Graphs. I imported some templates into Cacti previously, I'm not sure whether this caused the issue.

POLLER: Poller[Main Poller] WARNING: Invalid Response(s), Errors[3] Device[44] Device[BJ08HYPERV01] Thread[1] Graphs[BJ08HYPERV01 - CPU Utilization - CPU1, BJ08HYPERV01 - CPU Utilization - CPU1] Graphs[BJ08HYPERV01 - CPU Utilization - CPU6, BJ08HYPERV01 - CPU Utilization - CPU6] Graphs[BJ08HYPERV01 - CPU Utilization - CPU11, BJ08HYPERV01 - CPU Utilization - CPU11] DS[BJ08HYPERV01 - CPU Utilization - CPU1, BJ08HYPERV01 - CPU Utilization - CPU6, BJ08HYPERV01 - CPU Utilization - CPU11]

netniV
Cacti Guru User
Posts: 2795
Joined: Sun Aug 27, 2017 12:05 am

Re: Cacti 1.1.38-error in Data Query [SNMP - Get Processor I

#2 Post by netniV » Fri Jan 18, 2019 2:12 am

Invalid responses generally mean that either the OID is wrong or the device isn't giving that information back. You can try to reimport the base packages again to make sure that the templates are correct for them, though you may cause issues with the other imported templates if they have tampered with something.

The packages are in install/templates/ and you should use the cli/import_package.php script to reload them.

georgejiang
Posts: 2
Joined: Fri Jan 18, 2019 1:46 am

Re: Cacti 1.1.38-error in Data Query [SNMP - Get Processor I

#3 Post by georgejiang » Fri Jan 18, 2019 2:22 am

Thanks for quick information. I will have a try to re-input the packages from https://docs.cacti.net/templates --- Official Cacti 1.x Packages.
One more thing, is there a way to remove templates/packages before importing? I just want to make sure no legacy templates/packages corrupts new one.

netniV
Cacti Guru User
Posts: 2795
Joined: Sun Aug 27, 2017 12:05 am

Re: Cacti 1.1.38-error in Data Query [SNMP - Get Processor I

#4 Post by netniV » Fri Jan 18, 2019 4:13 am

If these are the basic ones, use the packages that I suggested rather than the templates from the website. Those are probably outdated when compared to the package .tgz files.

Post Reply