IronPort C10 Mail & Spam Appliance

Addons for Cacti and discussion about those addons

Moderators: Moderators, Developers

Author
Message
superdave913
Posts: 28
Joined: Fri Jan 14, 2005 7:10 pm
Contact:

IronPort C10 Mail & Spam Appliance

#1 Post by superdave913 » Fri Nov 11, 2005 1:06 pm

I'm submitting a host template for the IronPort C10 Mail and Spam Appliance. I am guessing that this template will work with most of their appliances running the AsyncOS.

This template was built against an IronPort running:
IronPort Model C10, AsyncOS Version: 4.5.0-736, Build Date: 2005-10-13,

I believe you need to be running at least 4.0.8 or 4.5 to support these SNMP features.

My IronPort has pretty low usage, making it difficult to test this template properly.

Please feel free to send any comments or suggestions on how this template could be improved.
Attachments
cacti_host_template_ironport_mail_appliance.xml
Host Template for IronPort C10 Mail & Spam Appliance
(176.07 KiB) Downloaded 5573 times

superdave913
Posts: 28
Joined: Fri Jan 14, 2005 7:10 pm
Contact:

Template Monitors...

#2 Post by superdave913 » Fri Nov 11, 2005 1:11 pm

I'm sorry, but I should have listed what this host template monitors...

Ambient Temperature
CPU Temperature
CPU Usage
Disk I/O Usage
DNS Requests
Mail Transfer Threads
Memory Usage
Messages in Work Queue
Open Files/Sockets
Queue Utilization

EnjoY!

sapofeo
Posts: 13
Joined: Thu Feb 17, 2005 5:23 pm
Contact:

#3 Post by sapofeo » Wed Nov 23, 2005 9:37 pm

OMG, someone other than me uses Ironports, lol. I'll be trying this out on my A60's next week. I'll tell you how it goes.

superdave913
Posts: 28
Joined: Fri Jan 14, 2005 7:10 pm
Contact:

Awesome!

#4 Post by superdave913 » Mon Nov 28, 2005 7:57 pm

Please let me know how it goes! Make sure you are running a recent version of the AsyncOS.

Dave

mlambie
Posts: 9
Joined: Wed Feb 18, 2004 3:01 am
Location: Perth, Western Australia
Contact:

#5 Post by mlambie » Wed Dec 14, 2005 10:27 am

I tried this on Cacti v0.8.5a (Debian) that ships with Ubuntu Hoary and it doesn't like it.

I uploaded the XML file through the "Import Templates" link and it appears to upload the file, but dumps me back at the file upload page. It didn't add the template.

Any ideas?
Matt Lambie
Chief Information Officer
THE FRONTIER GROUP

superdave913
Posts: 28
Joined: Fri Jan 14, 2005 7:10 pm
Contact:

Probably Need to Upgrade

#6 Post by superdave913 » Wed Dec 14, 2005 11:45 am

I am pretty sure you need to be running 0.8.6 for it to work. :(
Each release of Cacti seems to add functionality and information to the XML files... making it necessary to be at the same (or better) version as when it was exported.

For reference... this was exported using: 0.8.6f

Dave

mlambie
Posts: 9
Joined: Wed Feb 18, 2004 3:01 am
Location: Perth, Western Australia
Contact:

#7 Post by mlambie » Wed Dec 14, 2005 1:13 pm

Sounds like a good reason to move to Breezy then... that version is available. Thanks.
Matt Lambie
Chief Information Officer
THE FRONTIER GROUP

Halfwalker
Posts: 18
Joined: Tue Jan 24, 2006 6:11 pm

#8 Post by Halfwalker » Tue Jan 24, 2006 11:32 pm

I'm testing on a Debian Sarge/stable machine, with 0.8.6c. Importing the xml file returns an error :


Error: XML: Hash version does not exist.
D.

superdave913
Posts: 28
Joined: Fri Jan 14, 2005 7:10 pm
Contact:

Upgrade Likely Required

#9 Post by superdave913 » Thu Jan 26, 2006 1:50 pm

Try upgrading to at least 0.8.6f.

Dave

mlambie
Posts: 9
Joined: Wed Feb 18, 2004 3:01 am
Location: Perth, Western Australia
Contact:

#10 Post by mlambie » Fri Feb 24, 2006 8:24 pm

I have been running this template now for about a month. It works great, and is spurring me on to monitor everything that I can on our servers now.

Note: I upgraded to Breezy Badger (Ubuntu) and it all worked first time. The upgrade process was a little hairy, but after that the XML template dropped straight in.
Matt Lambie
Chief Information Officer
THE FRONTIER GROUP

superdave913
Posts: 28
Joined: Fri Jan 14, 2005 7:10 pm
Contact:

Thanks!

#11 Post by superdave913 » Fri Feb 24, 2006 9:41 pm

Thanks for the input and letting me know its working for you.
If you have any suggestions on possible changes, feel free to let me know.
Thanks!
Dave

User avatar
Morgan
Cacti User
Posts: 187
Joined: Wed Feb 25, 2004 3:38 am
Contact:

#12 Post by Morgan » Tue Feb 28, 2006 8:33 am

super, could you post screenshots of the graphs generated by this template.
thanks
Morgan

superdave913
Posts: 28
Joined: Fri Jan 14, 2005 7:10 pm
Contact:

Samples - Part 1

#13 Post by superdave913 » Tue Feb 28, 2006 12:24 pm

Here are some sample graphs from this template
Attachments
ironport-ambient_temp.png
Ambient Temperature
ironport-ambient_temp.png (2.51 KiB) Viewed 49963 times
ironport-cpu_temp.png
CPU Temp
ironport-cpu_temp.png (2.9 KiB) Viewed 49963 times
ironport-cpu_usage.png
CPU Usage
ironport-cpu_usage.png (3.22 KiB) Viewed 49963 times
ironport-disk_io.png
Disk I/O
ironport-disk_io.png (2.68 KiB) Viewed 49963 times
ironport-dns_requests.png
DNS Requests
ironport-dns_requests.png (2.96 KiB) Viewed 49963 times

superdave913
Posts: 28
Joined: Fri Jan 14, 2005 7:10 pm
Contact:

Samples - Part 2

#14 Post by superdave913 » Tue Feb 28, 2006 12:25 pm

More samples
Attachments
ironport-mail_queue.png
Mail Queue
ironport-mail_queue.png (2.64 KiB) Viewed 49962 times
ironport-mail_threads.png
Mail Threads
ironport-mail_threads.png (3.08 KiB) Viewed 49962 times
ironport-memory_usage.png
Memory Usage
ironport-memory_usage.png (2.28 KiB) Viewed 49962 times
ironport-open_sockets.png
Open Sockets
ironport-open_sockets.png (2.82 KiB) Viewed 49962 times
ironport-queue_utilization.png
Queue Utilization
ironport-queue_utilization.png (2.25 KiB) Viewed 49962 times

superdave913
Posts: 28
Joined: Fri Jan 14, 2005 7:10 pm
Contact:

Screen shots posted.

#15 Post by superdave913 » Tue Feb 28, 2006 12:27 pm

Morgan wrote:super, could you post screenshots of the graphs generated by this template.
thanks
Morgan
Hopefully the above samples are what you are looking for.

Dave

Post Reply