IronPort C10 Mail & Spam Appliance

Addons for Cacti and discussion about those addons

Moderators: Moderators, Developers

Author
Message
eric_stewart
Posts: 2
Joined: Sun May 23, 2010 4:21 pm

#61 Post by eric_stewart » Mon May 24, 2010 9:06 am

:lol: Thanks! I contacted customer support and reset the password.

Now I just need to obtain some keys for Anti-Virus and SPAM and I'll be all set. I'm setting this up in my lab.

/Eric

User avatar
hscsadm
Posts: 1
Joined: Wed Mar 09, 2011 11:11 am

Re: IronPort C10 Mail & Spam Appliance

#62 Post by hscsadm » Wed Mar 09, 2011 11:15 am

Thanks for the templates!

spoonman
Cacti User
Posts: 299
Joined: Tue May 03, 2005 8:54 am
Location: GA

Re: IronPort C10 Mail & Spam Appliance

#63 Post by spoonman » Wed Mar 09, 2011 11:39 am

Has anyone successfully gotten templates for the S650 Web security box?? They would be very helpful..
Thanks
CCNA

alokshrivastwa
Posts: 1
Joined: Wed Aug 03, 2011 4:20 pm

Re: IronPort C10 Mail & Spam Appliance

#64 Post by alokshrivastwa » Wed Aug 03, 2011 4:24 pm

Hi,

I managed to make a rough template for the Ironport WSA Devices (S Series). I am attaching it here. Please feel free to comment on it (If needed improve it)

This is just a starting point, but I thought I would share. (exported from 0.8.7g)
Attachments
cacti_host_template_ironport.xml
Host template for the Ironport S Series devices
(120.03 KiB) Downloaded 2350 times

jophlynn
Posts: 1
Joined: Fri Aug 05, 2011 12:32 am

Re: IronPort C10 Mail & Spam Appliance

#65 Post by jophlynn » Fri Aug 05, 2011 12:36 am

making it necessary to be at the same (or better) version as when it was exported.
....

artagel
Cacti User
Posts: 226
Joined: Wed May 21, 2008 11:33 pm

Re: IronPort C10 Mail & Spam Appliance

#66 Post by artagel » Thu Jun 28, 2012 2:34 am

Just started graphing our Ironport S650 with this template. Works perfectly. Thanks for the work.
-Dan
Please mark the topic solved if this resolves your problem.

NewJoiner
Posts: 11
Joined: Fri Jan 18, 2013 4:51 am

Re: IronPort C10 Mail & Spam Appliance

#67 Post by NewJoiner » Fri Jan 18, 2013 4:54 am

Where to add the python script in Cacti ?
Placed it in the scripts dir but how to cal it with the proper switches.

the XML is imported but not sure how to handle the python script (which runs fine on the commandline)

Chrs..

Dan5ielle
Posts: 8
Joined: Sat Jan 19, 2013 2:22 am

Re: IronPort C10 Mail & Spam Appliance

#68 Post by Dan5ielle » Sat Jan 19, 2013 2:43 am

Please feel free to send any comments or suggestions on how this template could be improved.
Image
Image
Image
Image
Image

NewJoiner
Posts: 11
Joined: Fri Jan 18, 2013 4:51 am

Re: IronPort C10 Mail & Spam Appliance

#69 Post by NewJoiner » Wed Feb 06, 2013 5:11 am

NewJoiner wrote:Where to add the python script in Cacti ?
Placed it in the scripts dir but how to cal it with the proper switches.

the XML is imported but not sure how to handle the python script (which runs fine on the commandline)

Chrs..
Anyone to help me on my way..........?!

Vampyra
Posts: 1
Joined: Fri Apr 05, 2013 4:54 am

Re: IronPort C10 Mail & Spam Appliance

#70 Post by Vampyra » Fri Apr 05, 2013 4:57 am

Hello,

We are using the latest python script to monitor our Ironports.

But apparently, and that's what causes troubles on the GUI the script is not closing correctly the session to request the information.

Is it possible to correct this ? (I do not have any training on Python, and this information cames from the Ironport Support guys)

Thanks a lot !

eschoeller
Cacti User
Posts: 234
Joined: Mon Dec 13, 2004 3:03 pm

Re: IronPort C10 Mail & Spam Appliance

#71 Post by eschoeller » Wed Apr 24, 2013 8:35 pm

How many Ironport devices do you have? I'd suggest looking at my post from a couple years ago, we had a similar complaint from the Ironport team, stating that there were too many connections open. It may be along the same lines as the situation you are encountering.

My suggestion then, and still is, after creating all the graphs, remove all but one of the associated data sources. This will break all but one of your graphs. Then reassociate the broken graphs with the single data source. This will dramatically cut down on the amount of polling cacti is doing on the Ironport device. If you need step-by-step, I can try to provide that.

On a separate note, we recently made some changes to our Ironports and we're sporadically dropping connections to our Ironport devices now. This is a problem on their end, but the exceptions weren't being handled well in the python script, and it got to be annoying. I made the following edit:

Code: Select all

52     try:
53         client = urllib2.urlopen(url)
54     except (urllib2.HTTPError, urllib2.URLError):
55         try:
56             client = urllib2.urlopen(urls)
57         except (urllib2.HTTPError, urllib2.URLError):
58             print "ERROR: cacti_check_esa.py - Problem opening url: %s or %s" % (url,urls)
59             # traceback.print_exc()
60             sys.exit(2)
This is probably trivial for anyone in Python, but it is not my native language (yet). We redirect STDERR from the poller process to a separate file, and the log file was getting cluttered with python tracebacks. I don't care about those, I just need a legible error. So I commented out the traceback.print_exc() and reformatted the print statement to be more informative.

yreddy
Posts: 43
Joined: Fri May 02, 2008 7:33 am
Location: Canada

Re: IronPort C10 Mail & Spam Appliance

#72 Post by yreddy » Tue Nov 19, 2013 5:34 am

Hi,

I've compiled the different ironport graphs I've found on this forum and I have also added own graphs to the following resulting template (Cisco IronPort Web Security Appliance [WSA]):
http://docs.cacti.net/usertemplate:host ... ronportwsa

Please let me know if I missed some graphs.

Youri

ps: I've fixed the URL on december 1st
Last edited by yreddy on Sat Nov 30, 2013 7:05 pm, edited 1 time in total.

eschoeller
Cacti User
Posts: 234
Joined: Mon Dec 13, 2004 3:03 pm

Re: IronPort C10 Mail & Spam Appliance

#73 Post by eschoeller » Sat Nov 30, 2013 1:17 pm

@yreddy

I looked over your host template. I don't entirely understand what your goal is. The host template you posted doesn't include any of the Ironport specific template items that have been developed in this thread. Most of what your template includes are interface statistics, TCP stats and UCD/Net SNMP uptime.

When I develop host templates and post them I try to follow a couple simple guidelines. In the included host template I only include those items that are specific to the device being monitored. I remove things like Interface Statistics, TCP Connection Stats, Unix Ping Latency, or any other additional associated data queries or graph templates. I feel pretty strongly about doing this becuase I don't want to break someone else's customoziations (or impose my own) for unrelated data collection methods. I then leave it up to the user to associate any other necessary data queries and graph templates as they see fit - but I'll usually make some recommendations. And of course, it's always encouraged to import alien templates into your dev environment first!

Anyway, from your message it sounds like you may have intended to combine the Ironport Web/Spam templates together ... but it doesn't look like that made it into your host template. I'd be happy to help you accomplish this if you want.

yreddy
Posts: 43
Joined: Fri May 02, 2008 7:33 am
Location: Canada

Re: IronPort C10 Mail & Spam Appliance

#74 Post by yreddy » Sat Nov 30, 2013 7:04 pm

Hi,

Sorry I've posted the wrong link, the template I wanted to post is the one for the WSA which you can find here:
http://docs.cacti.net/usertemplate:host ... ronportwsa

There are specific graphs for Ironport WSA as client / server requests and also generic graphs as interface statistics. In fact, I try to include everything that can be useful when administrating this kind of device and not only the graphs specific to the product. I took some graphs here few months ago and created others by myself... This is why I thought some of you might be interested.

eschoeller
Cacti User
Posts: 234
Joined: Mon Dec 13, 2004 3:03 pm

Re: IronPort C10 Mail & Spam Appliance

#75 Post by eschoeller » Sat Nov 30, 2013 7:16 pm

My only point is that if you modified the built-in "Interface - Statistics" templates, and then included them with your host template, they will overwrite everyone else's built-in templates. So, for example, all my Interface Statistics graphs would now have "Graph Last Updated" on them and I may not want that. But regardless, I'd hope most people would import into a dev environment first and decide what they want and don't want. I was bitten by this a few years ago, I imported a template set that included a customized version of the "Interface - Statistics" template and it blew away all my traffic graphs. Folks were not happy.

Thanks for posting the other link, I can see the different graphs now. I am curious ... is there a reason that you did not include GPRINT legends for items such as "Misses", "Active", "Other" ? Also, "Objects in Cache" and "CPU Usage" don't have MIN values in the legends, but others do ...

Post Reply